Jump to content

Archived

This topic is now archived and is closed to further replies.

Knomax

Infinite Warfare ports for XBox One and PS4

Recommended Posts

I see many people having problems with Nat type in Infinite Warfare.
 
Soooo.... the ports you are need for XBox One is:
 
TCP Ports:
 
53, 80, 3074 
 
UDP Ports:
 
53, 88, 500, 3074, 3544, 4500 
 
TCP&UDP Ports: 30753076  (added with the last patch for Infinite Warfare be sure that you portforward 3075 in your SECOND console....etc  1 XboxOne 3074 -------2 XboxOne 3075--------3 XboxOne 3076)
...................................................................
 
And for PS4
 
TCP Ports:  
 
80, 443, 1935, 3074, 3478-3480
 
 
UDP Ports:
 
3074, 3478-3479 
 
 
Portforwarding Two Xboxes
 
iQEKFYF.png
 
The Problem
 
It all starts with NAT or Network Address Translation. This is a technology that allows more than one computer to be on the Internet at the same time using the same IP Address. The type of NAT you use determines how easily your console can talk to another console across the Internet. There are three different NAT types:
 
Open - This is the best connection. If your NAT type is Open you can connect with any other NAT type. This means a better gaming experience.
 
Moderate - If you have Moderate NAT you can only connect to other consoles also using Moderate or Open. If you have Moderate NAT and your friend has strict you are going to experience problems.
 
Strict - If you have Strict NAT you can only connect to Open NAT consoles. Strict NAT is extremely restrictive and will result in frustration.
 
 
To attain open nat on one Xbox you simply forward port 3074 (UDP and TCP). To get open NAT when you have more than one Xbox on your router you need to use a second port. This is where the problem lies. Xbox has allowed the use of port 3074 (UDP and TCP) only. However if you have another Xbox console you cannot forward that same port to the second console. A port only allows one set of data to pass through at a time. This works great for the primary Xbox but the secondary Xbox will lag and have trouble playing an online game in general. To solve this problem Activision has made it so you can port your second Xbox to 3075 (UDP and TCP). If you have a third console go ahead and port 3076 (UDP and TCP) to that one.
 
*****Of course you must assign STATIC IP'S in both XboxOne's and use Energy saving not Instant mode.******
 
Another TIP
 

For those of you not familiar with UPnP, think of it in this context as automatic port forwarding. The device communicates with the router and says "hey, I'm located here at [iP address] and [MAC address] and I need access to ports [port], [port], and [port] please!" This is great, as it allows for consoles to have an "open NAT" and communicate effectively with the internet, allowing players to connect to other players and servers and such without hassle. It's also great for situations where multiple consoles are being used on the same network where manual port forwarding would not be effective.
 
However, the Xbox One's implementation of UPnP is bugged. Since devices are requesting ports to be opened and held for them, it's obvious that these reservations can't be held forever for security and compatibility reasons. So routers will eventually expire these UPnP reservations after a period of time of inactivity. No big deal - when a device needs access again, it renegotiates the leases and they become active again.
 
The Xbox One, however, doesn't do this unless a full reboot of the console occurs. As a result, users with a secure UPnP setup and the Xbox One on the "Instant On" setting will have a moderate or closed NAT, impeding their ability to connect to other players and services. So for those of you with the console with "Instant On" enabled, there are three ways I've found so far to temporarily resolve the issue:
 
1  Hard reset the console by holding the power button on the console.
 
2  Perform the "test multiplayer connection" test in the settings app. Once it finishes, hold LT + RT + LB + RB and an advanced screen will appear. During the advanced screen, the Xbox will attempt to renew its UPnP leases.
 
3  Disable "Instant On" and switch to "Energy Saver" and deal with very long console boot times.
 
 

Detailed........>>>>>

 

Settings->Network->Test Multiplayer Connection
 
It will say "Checking Connection..."
 
Once it is done, it will display a message and give you the option to continue.
 
DO NOT CONTINUE
 
Hold down the two bumpers and the two triggers at the same time(hold LT + RT + LB + RB), this will launch the Detailed Network Statistics.
 
uWPIQpM.png
 
Here you want to look at the Detailed NAT information section and it should say "Getting Info...".
 
It will refresh in a few seconds and if it says "Your network is behind a cone NAT" you've just switched your NAT from strict to open. Any other message and you'll probably need to power cycle your console.
 
 Don't be fooled by the short "NAT type" description, either, as this is cached and not accurate. As the above example shows, the NAT type is listed as Moderate, but the description from the advanced test is that of a "cone NAT" (open). The reverse happens as well - the console will show that your NAT is open, when in fact the UPnP leases are not active and you're not able to connect with some other players.

 

 
 
 Why changing from Instant mode to Energy saving make sense???
 
 Evidence of the issue in the form of detailed system log files from  mini UPnP daemon.
 
 With the data captured and logged, we've been able to conclude that the issue does in fact reside with the Xbox One, and is a bug that Microsoft needs to address. Technical details below for those interested:
 

Here's part of the UPnP negotiations from the Xbox One booting out a full power-off state ("energy saver"). Note the AddPortMapping request, where the Xbox One asks for port 3074 to be redirected/forwarded to it. To simplify things, this is what gives you an open nat.
 

Look at lines with  **  at start  ;)

miniupnpd[521]: HTTP connection from 192.168.1.106:49164
miniupnpd[521]: HTTP REQUEST : POST /ctl/IPConn (HTTP/1.1)
miniupnpd[521]: SOAPAction: urn:schemas-upnp-org:service:WANIPConnection:1#GetConnectionTypeInfo
miniupnpd[521]: HTTP connection from 192.168.1.106:49165
miniupnpd[521]: HTTP REQUEST : POST /ctl/IPConn (HTTP/1.1)
miniupnpd[521]: SOAPAction: urn:schemas-upnp-org:service:WANIPConnection:1#GetNATRSIPStatus
miniupnpd[521]: HTTP connection from 192.168.1.106:49166
miniupnpd[521]: HTTP REQUEST : POST /ctl/IPConn (HTTP/1.1)
miniupnpd[521]: SOAPAction: urn:schemas-upnp-org:service:WANIPConnection:1#AddPortMapping
**miniupnpd[521]: AddPortMapping: ext port 3074 to 192.168.1.106:3074 protocol UDP for: Teredo leaseduration=0 rhost=
**miniupnpd[521]: UPnP permission rule 0 matched : port mapping accepted
**miniupnpd[521]: redirecting port 3074 to 192.168.1.106:3074 protocol UDP for: Teredo
miniupnpd[521]: upnpevents_selectfds: 0x43b3f8 1 10
miniupnpd[521]: upnp_event_notify_connect: '192.168.1.106' 2869 '/upnp/eventing/rtkfsdxeim'
miniupnpd[521]: upnpevents_processfds: 0x43b3f8 2 10 0 1
miniupnpd[521]: upnp_event_send: sending event notify message to 192.168.1.106:2869
miniupnpd[521]: upnp_event_send: msg: NOTIFY /upnp/eventing/rtkfsdxeim HTTP/1.1
Host: 192.168.1.106:2869
Content-Type: text/xml
Content-Length: 389
NT: upnp:event
NTS: upnp:propchange
SID: uuid:4e59862d-6fc0-4e8b-8575-62a4454a095b
SEQ: 1
Connection: close
Cache-Control: no-cache

Here's the Xbox One shutting down into standby ("instant on") mode. It relinquishes its hold on port 3074 now that it's done with it.
 
 

miniupnpd[521]: HTTP connection from 192.168.1.106:49524
miniupnpd[521]: HTTP REQUEST : UNSUBSCRIBE /evt/L3F (HTTP/1.1)
miniupnpd[521]: ProcessHTTPUnSubscribe /evt/L3F
miniupnpd[521]: SID 'uuid:4e59862d-6fc0-4e8b-8575-62a4454aa048'
miniupnpd[521]: HTTP connection from 192.168.1.106:49525
miniupnpd[521]: HTTP REQUEST : POST /ctl/IPConn (HTTP/1.1)
miniupnpd[521]: SOAPAction: urn:schemas-upnp-org:service:WANIPConnection:1#DeletePortMapping
**miniupnpd[521]: DeletePortMapping: external port: 3074, protocol: UDP
**miniupnpd[521]: removing redirect rule port 3074 UDP
miniupnpd[521]: Trying to delete nat rule at index 0
miniupnpd[521]: Trying to delete filter rule at index 0
miniupnpd[521]: upnpevents_selectfds: 0x43b098 1 10
miniupnpd[521]: upnp_event_notify_connect: '192.168.1.106' 2869 '/upnp/eventing/wlofnqblfn'
miniupnpd[521]: upnpevents_processfds: 0x43b098 2 10 0 1
miniupnpd[521]: upnp_event_send: sending event notify message to 192.168.1.106:2869
miniupnpd[521]: upnp_event_send: msg: NOTIFY /upnp/eventing/wlofnqblfn HTTP/1.1
Host: 192.168.1.106:2869
Content-Type: text/xml
Content-Length: 389
NT: upnp:event
NTS: upnp:propchange
SID: uuid:4e59862d-6fc0-4e8b-8575-62a4454a959e
SEQ: 1
Connection: close
Cache-Control: no-cache

Here's the Xbox One booting up out of its stanby ("instant off") state. Nothing like the full boot, just a simple "hey I'm here" without any of the port mapping. Note that the port mapping is absolutely necessary since it released it during shut down. Without it, we're stuck in moderate NAT land again.
 
 

miniupnpd[521]: ST: urn:schemas-upnp-org:device:InternetGatewayDevice:1 (ver=1)
miniupnpd[521]: SSDP M-SEARCH from 192.168.1.106:50249 ST: urn:schemas-upnp-org:device:InternetGatewayDevice:1
miniupnpd[521]: Single search found
miniupnpd[521]: SendSSDPResponse(): 0 bytes to 192.168.1.106:50249 ST: HTTP/1.1 200 OK
CACHE-CONTROL: max-age=120
ST: urn:schemas-upnp-org:device:InternetGatewayDevice:1
USN: uuid:4e59862d-6fc0-4e8b-8575-62a4454a01e1::urn:schemas-upnp-org:device:InternetGatewayDevice:1
EXT:
SERVER: UPnP/AsusWRT UPnP/1.1 MiniUPnPd/1.9
LOCATION: http://192.168.1.1:42856/rootDesc.xml
OPT: "http://schemas.upnp.org/upnp/1/0/"; ns=01
01-NLS: 1
BOOTID.UPNP.ORG: 1
CONFIGID.UPNP.ORG: 1337

So with Instant mode "on" XboxOne will not do port mapping.....Soooo will not change NAT.....shutdown it again ...and again...and again will not change anything unless you change it in "Energy saver" mode.

 
Portforwarding Two PS4's
 

1.    In R1 enable UPnP, UPnP forwarding and give static IP in both consoles.

2.    In first PS4 in network settings enable UPnP .

3.    In second PS4 disable UPnP.

4.    In R1 portforward 3075 or 3076 for the second PS4. (reboot R1)

5.    Enable first PS4---load game (so UPnP starts working and assign port 3074 in first PS4)

6.    Enable second PS4---load game (UPnP is disabled so portforward of R1 will open 3075 or 3076 port for this PS4) 

 

The same procedure may work and for XboxOne.

 

The right way is to don't use at the same time UPnP and portforward...but you can try....using UPnP and portforward together may "slow GUI in R1".

 

 

Have fun  ;)

Share this post


Link to post
Share on other sites

Um jus start game up and go to network monitor , click on ports graph. Shows every port being used. It's same ports as bo3 but yea...

U don't need all those ports that's for old games. 3074 ps4

3075 xbox

What the matter if you open these ports???Some ports is for Xbox live..some is for psn not only for the game.

 

I have upnp on but still get moderate

UPnP is the "easy way" for routers to open ports for specific applications but sometimes can"t open these ports at all.Close your device...reboot router...when your R1 starts up properly ...start your device and connect.

But is preferred to open ports manually.

 

UPnP open the ports needed for game just to RUN....but to have "smooth" game many others needed.

Give a try and open ALL the necessary ports....for PSN,Xbox Live and for game...many times will increase dramatically your gaming experience.

 

The think of all of this is of course to have OPEN Nat (Open Nat simply is..how one device communicates with the others...how difficult is this  communication) and for device (R1) to don't "lose" time finding which device (Ps4/XboxOne) needs the data.

This decrease RTT (round-trip time...is the time required for a signal pulse or packet to travel from a specific source to a specific destination and back again.) 

 

Decreasing RTT will prevend your router to be a bottleneck!! And if your device is a bottleneck in your network this increase "bufferbloat".And you know if you have bufferbloat what means for your gaming  :) .

 

And also would recommend using "Reactive" ..find the settings for your connection to minimize bufferbloat....reactive uses fq_codel.

fq_codel is a smart queue management algorithm where puts each flow’s traffic into its own queue.

(A “flow” is typically defined as traffic from a single IP addresses/port to another address/port.)

 

Try these and i think your game will be better. :)

Share this post


Link to post
Share on other sites

Ok well I added all the ones for xbox one and I still get a moderate NAT type.

Maybe it is because I have two xbox consoles on at the same time.

One will be open, other strict, whoever console starts up 1st is usually open.

Share this post


Link to post
Share on other sites

One will be open, other strict, whoever console starts up 1st is usually open.

Yea I know that but since IW launched neither consoles has shown open NAT.

Also last night I forwarded the remaining ports to no avail, not even today.

But I rememeber someone saying to launch MWR and then IW and wouldnt you know, it shows open NAT on IW now.

Share this post


Link to post
Share on other sites

Ok well I added all the ones for xbox one and I still get a moderate NAT type.

Maybe it is because I have two xbox consoles on at the same time.

This is because you can't forward the same ports to multiple same devices. So to fix this, do the following:

 

Xbox side: Change BOTH Xbox names (under Xbox settings> system>console info) to something unique from one another

Turn ON Energy Savings (Under Xbox settings>Power & startup) which allegedly allows UPNP to work without constraints.

 

Router side: DISABLE all port forwarding

Ensure UPNP (and zeroconfig if applicable) is turned ON

 

Tell us if your problem solved. :)

Share this post


Link to post
Share on other sites

Great thread, very helpful!

 

 

That's very strange, something weird happening there but good tip!

 

Can confirm, have UPnP enabled in Settings>UPnP and Settings>Misc, CoD ports forwarded and always get Moderate NAT on IW.

 

Open MWR and then go to Settings>UPnP and can see that the PS4 CoD port is now in the port forwarding rules.

 

Open IW and have Open NAT  :huh:.

Share this post


Link to post
Share on other sites

This is because you can't forward the same ports to multiple same devices. So to fix this, do the following:

 

Xbox side: Change BOTH Xbox names (under Xbox settings> system>console info) to something unique from one another

Turn ON Energy Savings (Under Xbox settings>Power & startup) which allegedly allows UPNP to work without constraints.

 

Router side: DISABLE all port forwarding

Ensure UPNP (and zeroconfig if applicable) is turned ON

 

Tell us if your problem solved. :)

 

Ok I knew about PF the same ports to other devices would cause issues and I didnt do that when I said I added the PF

I just PF to my console only but didnt get the open NAT until I launched MWR.

 

So if I portforward the 3074 udp/tcp on both consoles and change the device name on one it will have no issues using the same PF?

I just dont want to have to launch MWR just to get open NAT

 

 

Where did you hear this about turning on enrgy savings? I have my console shut down completely all the time.

Share this post


Link to post
Share on other sites

You shouldn't need to turn on MWR every time you want an open NAT; try what Knomax suggested, though I'll be interested in hearing where Knomax learned of energy saving allowing UPnP to work without constraints. We're still testing out IW though, hopefully some of these issues will be solved for good soon.

Share this post


Link to post
Share on other sites

Great thread, very helpful!

 

 

That's very strange, something weird happening there but good tip!

 

Yeah this helped me to get an Open NAT again with UPNP. :D

Share this post


Link to post
Share on other sites

Ok I knew about PF the same ports to other devices would cause issues and I didnt do that when I said I added the PF

I just PF to my console only but didnt get the open NAT until I launched MWR.

 

So if I portforward the 3074 udp/tcp on both consoles and change the device name on one it will have no issues using the same PF?

I just dont want to have to launch MWR just to get open NAT

 

 

Where did you hear this about turning on enrgy savings? I have my console shut down completely all the time.

 

You shouldn't need to turn on MWR every time you want an open NAT; try what Knomax suggested, though I'll be interested in hearing where Knomax learned of energy saving allowing UPnP to work without constraints. We're still testing out IW though, hopefully some of these issues will be solved for good soon.

 

 

See this...

 

http://windowsreport.com/your-network-is-behind-port-restricted-nat-xbox-one/

 

See Method 3 – UPnP and Energy Saver...

 

http://www.tech-recipes.com/rx/46572/xbox-one-how-to-open-your-nat-to-connect-to-live-members-and-servers/

 

https://forums.xbox.com/en-US/thread/476BB97D-87A4-4B16-9D3F-E78A44211E74

 

https://www.reddit.com/r/xboxone/comments/4h5e8k/how_to_run_2_or_more_xbox_ones_with_open_nat_on_1/

 

Give a try ..i don't think you have something to lose ...right? :)

 

 

Please confirm or not if it is solves the problem to have a "sure" and complete method for XboxOne users.

Share this post


Link to post
Share on other sites

See this...

 

http://windowsreport.com/your-network-is-behind-port-restricted-nat-xbox-one/

 

See Method 3 – UPnP and Energy Saver...

 

http://www.tech-recipes.com/rx/46572/xbox-one-how-to-open-your-nat-to-connect-to-live-members-and-servers/

 

https://forums.xbox.com/en-US/thread/476BB97D-87A4-4B16-9D3F-E78A44211E74

 

https://www.reddit.com/r/xboxone/comments/4h5e8k/how_to_run_2_or_more_xbox_ones_with_open_nat_on_1/

 

Give a try ..i don't think you have something to lose ...right? :)

 

 

Please confirm or not if it is solves the problem to have a "sure" and complete method for XboxOne users.

 

 

Yea I have been having my console in engery saver mode. ( I dont like kinect listening)

 

This issue could get fixed if the router was able to support DUAL OPEN NAT

Share this post


Link to post
Share on other sites

Interesting, will put the consoles in energy saver and see if we get the same.

 

We'll have more UPnP options in DumaOS, I'm going to push really hard for that.

Having two consoles really is a pain. Lol

Share this post


Link to post
Share on other sites

Here My settings: 

 

My FritzBox (Router): All needed Ports are opened for my PS4 only, UPNP is UNticked 

 

My Netduma: Setting-> Miscall.-> Enable UPNP- Forwarding  is ticked.  under Settings-> UPNP: enable is ticked, under Setting-> Port Forwarding: All needed Ports are opened for PS4 again 

 

After that Restart PS4

 

Result: 

NAT is Opened in IW & MWR 

 

Hope this works for all of other ppl!! 

Share this post


Link to post
Share on other sites

×
×
  • Create New...