Jump to content
Netduma Admin

Apex Legends is now Geo-Filter Compatible!

Recommended Posts

@Netduma Fraser what can I do? I'm still being matchmaked in Dallas servers and UK. And filter mode forces my game to not load. I actually tried a workaround. When im in the main screen with Wraith on screen, I leave it on spectate mode but when I load in the lobby, i switch to filter mode. But the success rate on finding a NY server is 10%-20%. BUT, when the match finishes, I have to go back to spectate mode, if not, then I get code Leaf 100% AND back to the "unable to connect to EA servers" thus starting the process all over.

Share this post


Link to post
Share on other sites

i wouldn't even worry about using the duma filtering mode in this game, the connectivity aspect is a complete mess, terrible lag and packet loss it really doesn't matter what server you choose, constant prediction error symbols. I'm so disappointed with the latest patch, still the code net and code leaf errors rampant also. No noticeable difference in connectivity its still so poor.

Looks like EA see this game as nothing more than a way to milk the kiddies of all their pocket money with the monetisation, they will keep doing events like the crown for cash crab, and they will not put a cent into upgrading the servers. i will finish the season 2 battle pass and move on from this game to modern warfare, i don't want to but i can't deal with the lag in this game and their reluctance to spend any money on improving 20 tick servers.

Share this post


Link to post
Share on other sites

All Aussie servers are still either mislocated, wrongfully classified as peer or both. Filtering Mode is still unusable too as you can't even get past the splash screen. I know Australia is a very small portion of your consumer base but I was really hoping it would've been fixed after 7 months 😕

I really hope it'll be a different story for Modern Warfare 😕

Share this post


Link to post
Share on other sites

Well we don't really focus on any one country specifically. We're certainly not excluding Australia either intentionally or otherwise.

We're going to be doing more testing on Modern Warfare during the beta so our support for that game should be pretty good. A large chunk of our community love Call Of Duty so it's certainly a priority for us.

Share this post


Link to post
Share on other sites

The servers for this game are still in an atrocious state, prediction errors all the time and packet loss, i took some time out to play modern warfare but im not impressed with that offering and all i could think about was playing apex legends. its so much better than the tired call of duty formula. i just wanted to update you fellow legends that they are working on server fix for season 3 dropping, so there may or may not be some light at the end of the tunnel, we shall see. 

Share this post


Link to post
Share on other sites
20 hours ago, Netduma Fraser said:

That's great to hear Buckeye, Season 3 is looking promising!

Yes fraser i cannot wait, im a super addicted apex fanboy, with all the connection quality problems it suffers there is still nothing beats it at the moment, if these developers sort out the connectivity i don't think ill play any other fps again. Can't wait to see crypto in the real and see what he brings to the meta. Also im hoping whatever changes they implement we can finally get the geo filter working in tandem, even selecting the in game server browser of your choice you know as soon as you play its not the one you selected cause it feels way over 100 ping at times. 

Share this post


Link to post
Share on other sites
On 10/7/2019 at 2:43 AM, gkontos10 said:

since S3 launch am facing geofilter problems / errors

am usually get a leaf error or i get kick from lobby

Same here brother! Servers are absolutely terrible! Utterly ridiculous that it’s S3 and nothing has been done! What I do not understand is why I can’t reconnect to the servers that I have allowed in my Geo-Filter? 

Share this post


Link to post
Share on other sites
On 10/7/2019 at 7:43 AM, gkontos10 said:

since S3 launch am facing geofilter problems / errors

am usually get a leaf error or i get kick from lobby

I'll have to re-test the game to make sure that it still works as expected. By the sounds of it, they've changed something with the server setup.

Share this post


Link to post
Share on other sites

So I bought an XR500 router a few days ago.  I really like it so far as a router.  I specifically bought it for the NETDUMAS software and overall it has some nice features.  I play console games, mainly on the Xbox 1 X and mainly play APEX Legends.  I'm located in FL so the nearest servers are SC and VA and TX and had it set to a 1000 mile radius.  I seem to get the issue mentioned in this thread where it won't connect to a server quite often even when expanding to 1864 max suggested, filtering mode and auto-ping enabled.  Ipv4 and Ipv6 address and

Now lets move on to to the issues I am experiencing so far.  I kicked back to the main menu after each round or match, annyoing especially if in a partied up lobby and would like to know how this can be avoided.  I can say it is annoying, but the in game experience has been better, EXCEPT for one BIG issue.  Randomly in games and party chat, and of course it always seems to happen when I am doing exceptionally well, the game will freeze and disconnect me from the server.  I am not sure why, but since this happens I am fearful to play any ranked matches and I don't know how reliable and stable the connection will be. I believe it is somehow related to XBOX compatibability issues and not necessarily the game as I don't lose internet at all or access to xbox live. Prior to the new router my supplied router never dropped in game nor party chat.  It does it atleast a handful of times during a 3-4 period of gaming which to me is unacceptable. I just linked that the dropping issue is time related every hour at the half hour mark it drops.  Are there settings in the router to refresh something at that time?  I also click on the Person Icon in game lobbies to add those users I play with to the list of acceptance, but not sure this is working as it should cause it will place them in games and drop me from the lobby. 

*Update it also disconnects my work connection in the same frequency.  It says disconnected from "peer reset,"  so I think somehow the router is re-establishing its connection every hour in some way.  I just need to determine how or why this can be changed.

I have Spectrum service and my router sees speeds between 495MB Download and 25MB Upload.  Any help or other users experiencing the same issues? I really want to utilize this router to its max potential so perhaps if I don't have something setup correctly please advise.

 

Thanks for taking the time to read.

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

The first thing to do would be to use Spectating Mode for your console or remove it from the Geo-Filter and see if this continues. We are working on a cloud update which should prevent getting booted for the game. Meanwhile if you see this then an icon should appear on the map, allow it and the issue should be resolved but you may need to allow several. Are you using PPPoE at all? If so is it set to Always Connect?

Share this post


Link to post
Share on other sites

Hey Netduma Fraser, Thank you Glad to be here! 

I called NETGEAR and they had me change DNS settings but that didn't resolve my issue.  They then had me reset the router and leave the GEOFILTER off.  This did work, which is odd cause the only device I had applied to the filter was my xbox my work laptop shouldn't have been influenced but somehow it was impacted.  I was not using PPPoE. 

Since then I have used the filter when searching for games, and then immediate once in the game change to spectating, this seems to be working, but I will keep you all posted!

Share this post


Link to post
Share on other sites

Hi Fraser,

Same problem as above. Geo filter works perfectly in game when searching for a match. Had some great games the past few days (only recently bought the XR500) but after the match  5 times out of 10 it will kick me out to the main menu whilst stating error code leaf and I’ll then have to try to reconnect to EA servers. 

I find looking at the geo filter screen whilst I’m connecting it’s trying to connect to servers outside of my geofilter - I’m from the U.K. and have the Europe servers selected in my range but it will try to connect to servers in the US for the authentication but of course it doesn’t like that because they’re outside of my geofilter. I know you mentioned above you’re looking into a cloud update. Any timescale on this? Is it as easy as you guys updating the authentication server list?

Cheers!

Share this post


Link to post
Share on other sites
17 hours ago, Green Sam said:

Hi Fraser,

Same problem as above. Geo filter works perfectly in game when searching for a match. Had some great games the past few days (only recently bought the XR500) but after the match  5 times out of 10 it will kick me out to the main menu whilst stating error code leaf and I’ll then have to try to reconnect to EA servers. 

I find looking at the geo filter screen whilst I’m connecting it’s trying to connect to servers outside of my geofilter - I’m from the U.K. and have the Europe servers selected in my range but it will try to connect to servers in the US for the authentication but of course it doesn’t like that because they’re outside of my geofilter. I know you mentioned above you’re looking into a cloud update. Any timescale on this? Is it as easy as you guys updating the authentication server list?

Cheers!

Hey, welcome to the forum!

Glad to hear you're enjoying the game with the Geo-Filter. I asked Alex last night when an update will be done so he should let me know shortly. If you ping those servers and then allow them then that should prevent you from being booted whilst we work on the cloud.

Share this post


Link to post
Share on other sites
On 4/2/2020 at 6:10 PM, Netduma Fraser said:

Hey, welcome to the forum!

Glad to hear you're enjoying the game with the Geo-Filter. I asked Alex last night when an update will be done so he should let me know shortly. If you ping those servers and then allow them then that should prevent you from being booted whilst we work on the cloud.

Any news on that cloud update Fraser? Keep being booted back to lobby although I’m trying to add the authentication servers when they pop up 

Share this post


Link to post
Share on other sites
15 hours ago, Green Sam said:

Any news on that cloud update Fraser? Keep being booted back to lobby although I’m trying to add the authentication servers when they pop up 

Thanks for your patience, I appreciate it is frustrating. If you could please put those IDs in the form here to be whitelisted so we can make sure they're all added that would be really helpful. I haven't heard anything yet which means Alex is probably testing but I should get an update on Monday.

https://forum.netduma.com/topic/29742-found-mislocated-servers-post-here/

 

Share this post


Link to post
Share on other sites

Hello.. Apex legends have added middle east servers. Anyway to test and update   the geo cloud accordingly. Help appreciated.. 

Share this post


Link to post
Share on other sites
15 hours ago, Muhammed said:

Hello.. Apex legends have added middle east servers. Anyway to test and update   the geo cloud accordingly. Help appreciated.. 

We will definitely do that, so happy that they're listening to the community and providing servers there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...