Jump to content

Welcome to Netduma Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

New XR500 DumaOS Upgrade Available V2.2.1.10


  • Please log in to reply
39 replies to this topic

#1
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,592 posts
  • Local time: 06:22 PM

Hi all, 

 

There is a new download available V2.2.1.10 - this is mainly just bug fixes. Once available I will update with the changelog and the official link from Netgear. 

 

DO NOT UPGRADE USING THE TOP RIGHT BUTTON OF THE INTERFACE. The new version fixes an error with that top right button but if you upgrade using it from your current version you may have an issue that will leave your router unable to access the interface.

 

If you do get that issue please let us know and we can help you recover it.

 

If you would like to upgrade safely please follow these instructions.

  1. Download latest firmware : https://www.dropbox....2.1.10.img?dl=0

  2. Run your web browser and open http://www.routerlogin.net.
  3. Click Settings => Administration => Firmware Upgrade page.
  4. Click Browser button and locate the firmware image file.
  5. Click Upload button.
  6. Wait for upgrade progress to complete.

If any problem occurs after upgrading, try clearing the configuration by pressing the Reset Button on Rear Panel until the Power LED blinks and hold on for 5 seconds at least, then the router will reboot with default configuration.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST



Official DumaOS/XR500 Support Times: 12pm - Midnight BST



Time Converter

If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#2
velloonythedeity

velloonythedeity

    Senior Member

  • Members
  • PipPipPipPip
  • 263 posts
  • Local time: 12:22 PM
  • LocationSt.Louis, MO

so there's no new feature?.



#3
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,592 posts
  • Local time: 06:22 PM

so there's no new feature?.

 

Just bug fixes as far as I am aware.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST



Official DumaOS/XR500 Support Times: 12pm - Midnight BST



Time Converter

If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#4
HappyLittleChap

HappyLittleChap

    Member

  • Members
  • PipPipPip
  • 104 posts

Hi all, 

 

There is a new download available V2.2.1.10 - this is mainly just bug fixes. Once available I will update with the changelog and the official link from Netgear. 

 

DO NOT UPGRADE USING THE TOP RIGHT BUTTON OF THE INTERFACE. The new version fixes an error with that top right button but if you upgrade using it from your current version you may have an issue that will leave your router unable to access the interface.

 

If you do get that issue please let us know and we can help you recover it.

 

If you would like to upgrade safely please follow these instructions.

  1. Download latest firmware : https://www.dropbox....2.1.10.img?dl=0

  2. Run your web browser and open http://www.routerlogin.net.
  3. Click Settings => Administration => Firmware Upgrade page.
  4. Click Browser button and locate the firmware image file.
  5. Click Upload button.
  6. Wait for upgrade progress to complete.

If any problem occurs after upgrading, try clearing the configuration by pressing the Reset Button on Rear Panel until the Power LED blinks and hold on for 5 seconds at least, then the router will reboot with default configuration.

 

I've upgraded but it broke my PPPoE connection so I have had to roll back the firmware again. 



#5
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,592 posts
  • Local time: 06:22 PM

I've upgraded but it broke my PPPoE connection so I have had to roll back the firmware again. 

 

Not sure why that would be. I will contact a Netgear developer and see if they can arrange a troubleshooting or at least data gathering session - the timezone would be factor and they may not be able to do it but will see what I can do.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST



Official DumaOS/XR500 Support Times: 12pm - Midnight BST



Time Converter

If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#6
rckrz6

rckrz6

    Advanced Member

  • Members
  • PipPipPip
  • 47 posts
  • Local time: 01:22 PM
  • LocationRochester, NY USA

I feel like most users are going to try upgrading using the button in the top right corner, unless there're going through initial setup



#7
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,592 posts
  • Local time: 06:22 PM

I feel like most users are going to try upgrading using the button in the top right corner, unless there're going through initial setup

 

The router's can be easily recovered so any one who has an issue after doing so just needs to contact us or Netgear and we'll be able to get them back up and running again.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST



Official DumaOS/XR500 Support Times: 12pm - Midnight BST



Time Converter

If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#8
doc octopus

doc octopus

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • Local time: 07:22 PM

I uploaded this firmware version and I have these problems:

Unable to browse due to problems with SSL certificates (PPPoE connection type)
The configuration section concerning the 5 GHz channel has disappeared in the wireless section.

I had to reload the previous version 2.2.0.4 (for me it works very well) and reset the router, now everything is back to normal.



#9
crawlgsx

crawlgsx

    Member

  • Members
  • PipPip
  • 14 posts
  • Local time: 01:22 PM

Firmware working great here. I upgraded using the firmware section under Administration (although I did let it auto download rather than picking the file from Dropbox). 

 

I am not using PPPoE however. 



#10
xlr8r

xlr8r

    Member

  • Members
  • PipPipPip
  • 205 posts
  • Local time: 06:22 PM
  • LocationN.Ireland

upgraded from V2.1.0.6 to this new one V2.2.1.10 via Settings, Administration, Firmware Update -> Check , downloaded rebooted, no issues so far as i can tell...

 

[UPDATE] - actually , just noticed my QoS is active for no apparent reason, throttling my Internet when I'm NOT playing games or Downloading anything. Pc is sitting idle....

 

it will only turn off if i disable (untick) DumaOS Classified Games....?

 

antibuffer-float.jpg

 

traffic.jpg

 

 

Screenshot_2.jpg


wwii.jpg

Rockets all gone... Mnnnn...Your fooling no-one Kim !!!


#11
doc octopus

doc octopus

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • Local time: 07:22 PM

Mystery solved: the problems are caused by the change of language. The wireless menu is displayed completely if I switch from Italian to English.



#12
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,592 posts
  • Local time: 06:22 PM

upgraded from V2.1.0.6 to this new one V2.2.1.10 via Settings, Administration, Firmware Update -> Check , downloaded rebooted, no issues so far as i can tell...

 

[UPDATE] - actually , just noticed my QoS is active for no apparent reason, throttling my Internet when I'm NOT playing games or Downloading anything. Pc is sitting idle....

 

it will only turn off if i disable (untick) DumaOS Classified Games....?

 

 

Do you have steam in your system tray? I've noticed sometimes that will allow it to happen. Easiest way to tell is to check the Network Monitor and click on a total usage bar for download/upload, then drill down under category and application to see what's using bandwidth. You should see a DPI entry for Source Engine for example.

 

Mystery solved: the problems are caused by the change of language. The wireless menu is displayed completely if I switch from Italian to English.

 

Great to hear that, thanks for the info!


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST



Official DumaOS/XR500 Support Times: 12pm - Midnight BST



Time Converter

If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#13
Killhippie

Killhippie

    Member

  • Members
  • PipPipPip
  • 96 posts
  • Local time: 06:22 PM
  • LocationUK

All working well here, I did a factory reset after updating, two things i've noticed are, if I have PSN messenger on my iPad the router thinks my iPad is a PlayStation, and my Sony UPH-1 Sony Blu-ray player gets recognised as a PlayStation too, I think that's something to do with Bravia sync but both need looking into as more blu-rays players by Sony may trigger the same issue, and the PSN messenger turning my iPad into a PlayStation every time I launch the app is a bit annoying.



#14
Netduma Admin

Netduma Admin

    Netduma Staff

  • Administrators
  • 634 posts
  • Local time: 06:22 PM
  • LocationNetduma HQ

All working well here, I did a factory reset after updating, two things i've noticed are, if I have PSN messenger on my iPad the router thinks my iPad is a PlayStation, and my Sony UPH-1 Sony Blu-ray player gets recognised as a PlayStation too, I think that's something to do with Bravia sync but both need looking into as more blu-rays players by Sony may trigger the same issue, and the PSN messenger turning my iPad into a PlayStation every time I launch the app is a bit annoying.

 

Thanks - improving device recognition is on our roadmap.



#15
Stealth_01

Stealth_01

    Member

  • Members
  • PipPipPip
  • 168 posts
  • Local time: 06:22 PM
  • LocationLondon

Hi,

 

Any chance we can get a list of all the fixes in latest firmware??

 

Regards,



#16
Whitmow

Whitmow

    Advanced Member

  • Validating
  • PipPipPip
  • 43 posts
  • Local time: 06:22 PM
is there any firmware update yet for the LED Reversal issue

#17
Netduma Admin

Netduma Admin

    Netduma Staff

  • Administrators
  • 634 posts
  • Local time: 06:22 PM
  • LocationNetduma HQ

Hi,

 

Any chance we can get a list of all the fixes in latest firmware??

 

Regards,

 

Just waiting on Netgear to post the change log. We’ll update the OP once it’s available. 

 

is there any firmware update yet for the LED Reversal issue

 

Also waiting for more info from Netgear on this. 



#18
Trueseeker

Trueseeker

    Member

  • Members
  • PipPipPip
  • 66 posts
  • Local time: 01:22 PM
Since I’ve done update had issues, just now my router dropped WiFi and I have been loosing internet where their scratching sound through game audio like internet was unstable and my character couldn’t control movement. This is 2nd time my router has done this.

#19
Netduma Admin

Netduma Admin

    Netduma Staff

  • Administrators
  • 634 posts
  • Local time: 06:22 PM
  • LocationNetduma HQ

Ok - I don’t think this will be the update itself causing this (but you can always downgrade back to another version if you like) and it won’t be DumaOS either so at this point I recommend you contact Netgear’s 24/7 live support and they can walk you through tests they need to do to diagnose the issue. You can contact them here:

 

https://www.netgear....rt/contact.aspx

 

Let us know how you get on and hopefully this will all be fixed for you very soon. 



#20
Killhippie

Killhippie

    Member

  • Members
  • PipPipPip
  • 96 posts
  • Local time: 06:22 PM
  • LocationUK

is there any firmware update yet for the LED Reversal issue

I wouldn't hold your breath, if that was going to happen it would have been with this update I'm pretty sure, they are not going to keep pushing routers out with this reversal without fixing it in firmware asap, which I don't think is possible tbh. I would love to be proved wrong on this but I think it will be new hardware that just prints the ports on the back the right way round maybe and as it does not effect the actual usage of the router, people that grabbed the XR500 at release may be left with this which is really just cosmetic.. but annoying as hell if you are even slightly OCD.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users