Jump to content

Recommended Posts

Weird behavior of the Geo-Filter in South America.

 Hi, I’m from Buenos Aires Argentina, had been playing Apex since Launch. The game has improved very little too, and the game's connection is very irregular. I will try to explain here with screenshots in these easy 5 steps what is happening in every game I had.

 

 1. In the title screen… the Geo-Filter show this. I can see all the servers’ location, including my nearest server in Sao Paulo.

1815052378_0CONEXCION.thumb.JPG.27cb9f249c6024ecaa700f58998280c2.JPG

 

 

2. Then, when I connect and enter the lobby if I have the Geo-Filter in Spectating mode, the Sao Paulo server is gone and I´m connected to a server in the US or Europe, always. And even, if I turn the Geo-Filter and select Strict mode, it will connect me to those regions.

 Conectado.thumb.JPG.73de485bb0385fae800ebfd39f347788.JPG

  

 

3. Now with the Apex Legends Lag Fix Guide, I turn the Geo-filter and try to DENY some servers in the US and Europe, so in this situation, I can´t connect to the Lobby at all.

 1537141368_1CONEXCION.thumb.JPG.4185de2eef1cbeadff2371d5a7f6c1c7.JPG

 

 

4. So, to play I need to turn off the Geo-Filter. So in the lobby, the Geo-Filter show me that I´m connected to the US, in this case, Texas with 165 ms Ping,

 Conectado.thumb.JPG.5310ad66c2d330a4fb8292e0071e4c3a.JPG

 

 

 

5. but when I enter the map or the Legends selection, the connection change to a 37 ms Ping and I´m connected to a Brasilian Host, which is not a Server but a Peer

 1997107349_conectadobrasilpeer.thumb.JPG.d6055c949d392c52336759ff84277a7f.JPG

 

That´s all. And for me, it´s weird.  I hope this information can help me and others in the same situation.

Regardless of this inconvenient I still have fun and very nice games, but if I can improve my hit detection and the lag it will be the best.

FYI, I have set up my QoS, and my buffer bloat is +A, so it´s not a problem.

Thanks all for reading… I hope this help.

See ya!!

Alvaro

 

 

Share this post


Link to post
Share on other sites

The problem here is you are not blocking the connections outside of your radius when you boot up the game. You can tell this because all the servers have dotted rings around them.

The fix should be simple: set Ping Assist to 0 and make sure Strict Mode is enabled. Then reboot the game.

This should then fix your problem. We double checked yesterday and forced the Brazil server at bootup and we then were able to guarantee we only played on the Brazil server. If the game ever gave us a different server, the Geo-Filter would block it, so it was working great.

Let us know how you get on after making these changes.

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Admin said:

The problem here is you are not blocking the connections outside of your radius when you boot up the game. You can tell this because all the servers have dotted rings around them.

The fix should be simple: set Ping Assist to 0 and make sure Strict Mode is enabled. Then reboot the game.

This should then fix your problem. We double checked yesterday and forced the Brazil server at bootup and we then were able to guarantee we only played on the Brazil server. If the game ever gave us a different server, the Geo-Filter would block it, so it was working great.

Let us know how you get on after making these changes.

Yes, I already tried this. I never used ping assist in Apex, so my Ping Assist is always 0. And yes, I used Strict mode, and I start to deny those servers outside my range but then I can´t even enter the lobby. I do this an entire afternoon until I get tired and turn off the Geo-Filter and play where ever the game put me. I don´t have screenshots of the deny serves, but I can assure you it´s true. I can´t explain why, but with strict mode ON, it's never choosing the Brasilian server, that is the only server inside my range. 

Share this post


Link to post
Share on other sites

Ok - I think Ping Assist may have broken on your router. Could you factory reset the router to solve this please, and when setting up your Geo-Filter, could you make sure you have it set to 0 again (and Strict Mode on)

When you boot up the game next time, all those servers outside your range should all appear as triangles, not servers with dotted lines around them.

Let us know if you're not sure how to factory reset - would also be useful to know which router you have too.

Thanks

 

Share this post


Link to post
Share on other sites
 
 
 
3 hours ago, Netduma Admin said:

Ok - I think Ping Assist may have broken on your router. Could you factory reset the router to solve this please, and when setting up your Geo-Filter, could you make sure you have it set to 0 again (and Strict Mode on)

When you boot up the game next time, all those servers outside your range should all appear as triangles, not servers with dotted lines around them.

Let us know if you're not sure how to factory reset - would also be useful to know which router you have too.

Thanks

 

 

My Router is the R1 and my bios version is R1 2.1.3.29

Ok, I want to show this screenshot I took now because I think the first one of all servers was confusing... Here I'm using Filtering mode, Strict mode ON, and Ping Assist = 0:

72999109_filteringon.thumb.JPG.36d869a5a1f2b55a59a533715e16ac4c.JPG

 

But then, this happened: I connect to the lobby and is connected to a server in Texas outside the Strict range. 

48840322_inlobby.thumb.JPG.09639e9f68357d86532485892d27e822.JPG

 

So, nothing change. Strict mode ON, and Ping Assist in=0.  If I deny this Texas server, I wouldn't be able to connect to the lobby at all.

Maybe the Ping assist is broken, so I can reset the router to factory settings. Does that mean I will lose every setting until now?
 

thnaks

 

Share this post


Link to post
Share on other sites

That Texas server is whitelisted which means we've identified as being required to connect to the lobby so that is fine. When you got the host in Brazil I checked the IP address and it was actually a dedicated server, just mis-classified as a peer. So it does appear to be working, can you still get that server?

Share this post


Link to post
Share on other sites
On 5/4/2019 at 8:56 AM, Netduma Fraser said:

That Texas server is whitelisted which means we've identified as being required to connect to the lobby so that is fine. When you got the host in Brazil I checked the IP address and it was actually a dedicated server, just mis-classified as a peer. So it does appear to be working, can you still get that server?

Thanks, sorry for the delay.

Yes, actually, now that I understand that all the servers I was connecting to when in the lobby, where the whitelisted server and when I enter the match I connected to a Peer/server in Brasil, I can say now, I´m playing in servers near me, with 35-45 ping. But, all the servers that are in the area of Sao Paulo, Rio de Janeiro are all identified like Peers. Maybe there's is a way to change this.

I will attach here the screenshots of the few matches I had in this region, so you can check them out. And, please check the last one, named Apex LA. This one was very strange, the ping was very low, but on the map, the location was in California, US.

Thanks for all the answers!!!

 

1555166751_ApexSaoPaulo2.thumb.JPG.c5c37641cbc4199de3a954c8b61bd6a5.JPG2004894031_ApexSaoPaulo3.thumb.JPG.91a6125e1e7c0e1998aae28f97129c08.JPG1669814941_ApexSaoPaulo4.thumb.JPG.32881ff31635ae76a8783155865372fb.JPG386321086_ApexRio1.thumb.JPG.496d9c180cf4f016f910a0f665ba734c.JPG1028466080_ApexRio3.thumb.JPG.c06b517dc54210d7389f8313e17ed733.JPG94558749_ApexBrasil2.thumb.JPG.2adc159c871361dce844007b5aaf7fb9.JPG1269442898_ApexLA.thumb.JPG.a0cbad08a4385b6af49580c8bea793e0.JPG

 

Share this post


Link to post
Share on other sites

I have submitted this information to be added to our database. Thank you very much for helping us improve the accuracy of the Geo-filter!

Share this post


Link to post
Share on other sites

I have an issue with apex aswell. So if i have my Geo filter on filtered mode and i have my radius around 1200KM from my home location which is the north east of england. I cannot get into any games at all. Its just stays at the first loading screen and tries to connect. I can see there is servers within my radius but it still fails to connect to these servers. If i switch the geo filter to Spectating mode, I get a game straight away without any issue at all.

Any help would be appreciated 

Share this post


Link to post
Share on other sites

When you get a game in spectating mode, is the server you connect to somewhere that would be within your radius if you were using filtering mode?

Share this post


Link to post
Share on other sites
56 minutes ago, Netduma Alex said:

When you get a game in spectating mode, is the server you connect to somewhere that would be within your radius if you were using filtering mode?

Yeah the game i generally get is in the radius im in when using filtered mode.

Share this post


Link to post
Share on other sites

We've had some issues where we haven't correctly whitelisted all of the authentication servers for Apex Legends. Is this happening every single time you try to connect in filtering mode?

Here's something you can try:

  • Stay in filtering mode until you get to the "attempting to join lobby" screen
  • Now switch into spectating mode
  • Once you're in the lobby, go back into filtering mode

Now you should only get into servers that you want. If it works, can you give us the ID (in DumaOS) of the icon that appears when you enter the lobby in spectating mode? I think we'll need to manually whitelist this server from our end.

Share this post


Link to post
Share on other sites
3 hours ago, Netduma Alex said:

We've had some issues where we haven't correctly whitelisted all of the authentication servers for Apex Legends. Is this happening every single time you try to connect in filtering mode?

Here's something you can try:

  • Stay in filtering mode until you get to the "attempting to join lobby" screen
  • Now switch into spectating mode
  • Once you're in the lobby, go back into filtering mode

Now you should only get into servers that you want. If it works, can you give us the ID (in DumaOS) of the icon that appears when you enter the lobby in spectating mode? I think we'll need to manually whitelist this server from our end.

I will give this ago Alex. 

Thank you for your help

Share this post


Link to post
Share on other sites
On 5/17/2019 at 4:10 PM, Netduma Alex said:

We've had some issues where we haven't correctly whitelisted all of the authentication servers for Apex Legends. Is this happening every single time you try to connect in filtering mode?

Here's something you can try:

  • Stay in filtering mode until you get to the "attempting to join lobby" screen
  • Now switch into spectating mode
  • Once you're in the lobby, go back into filtering mode

Now you should only get into servers that you want. If it works, can you give us the ID (in DumaOS) of the icon that appears when you enter the lobby in spectating mode? I think we'll need to manually whitelist this server from our end.

 

On 5/17/2019 at 7:32 PM, Dialatech said:

I will give this ago Alex. 

Thank you for your help

The ID is 

712329f4c010c7cc

 

Another ID

2823efbac0c7c7cc

Share this post


Link to post
Share on other sites

Mentioned in another thread, but doesn’t seem to be very well known so figure I’ll drop it here too.  Your able to choose which server you want to play on similar to how battlefield was if you wait two minutes on the opening screen and then enter and exit the accessibility menu.  It’s an odd way to go about it, but it lists all the servers by location and ping/packet loss percentage after you do it.  Hopefully this makes things a bit more stable, it seems like sometimes I log in and it saved my preference, while other times I have to choose again so normally I just wait the two minutes now to have less frustration while playing. Good luck and hope this helps some folks

Share this post


Link to post
Share on other sites
14 hours ago, Sol0flyerz said:

Mentioned in another thread, but doesn’t seem to be very well known so figure I’ll drop it here too.  Your able to choose which server you want to play on similar to how battlefield was if you wait two minutes on the opening screen and then enter and exit the accessibility menu.  It’s an odd way to go about it, but it lists all the servers by location and ping/packet loss percentage after you do it.  Hopefully this makes things a bit more stable, it seems like sometimes I log in and it saved my preference, while other times I have to choose again so normally I just wait the two minutes now to have less frustration while playing. Good luck and hope this helps some folks

Yeah im aware of this but regardless if i pick London or not i will still get connected to a server in France 

Share this post


Link to post
Share on other sites

That’s strange haven’t really looked to be sure it put me exactly where I’d picked since I’ve got a few relatively close.  I’m guessing you’ve already flushed the cloud and all that then as well? I think the error kicking us after games is on their end and not just duma related, even though it’s a fairly quick login it is getting a bit old.   Really hope the hit reg, no footsteps and other bug fixes coming this week address most of our issues.  By the looks of the notes respawns addressing most of the issues I’m having personally so hopefully it helps to get you sorted as well.

 

Share this post


Link to post
Share on other sites
12 hours ago, Sol0flyerz said:

That’s strange haven’t really looked to be sure it put me exactly where I’d picked since I’ve got a few relatively close.  I’m guessing you’ve already flushed the cloud and all that then as well? I think the error kicking us after games is on their end and not just duma related, even though it’s a fairly quick login it is getting a bit old.   Really hope the hit reg, no footsteps and other bug fixes coming this week address most of our issues.  By the looks of the notes respawns addressing most of the issues I’m having personally so hopefully it helps to get you sorted as well.

 

Yeah I have flushed the cloud aswell. Last night i even tried adding the server i get connected it all the time to the deny list and it still connected me to server inside my radius but not the london one.

@Sol0flyerz are you playing on PC?

Share this post


Link to post
Share on other sites
On 5/21/2019 at 2:49 PM, Dialatech said:

Thanks Alex

I will give it ago tonight

So i have tried this the last few nights. 

so my findings are below

It will connect to a dedicated server, I will get 1 game and then it will disconnect me after every game and i have to reconnect to a server every time. Some times this can take up to 20 minutes to connect even tho i can see dedicated servers showing up on the Geo-filter and inside my radius.

Last night i was getting quite annoy with this game, on one occasion i waited almost 45 minutes to connect to a server and once connected, the game was working i could see the server was located in Germany but straight after the game it disconnected me and would not reconnect to a server.

Apex legend data centre server selection tool does not work at all. I have picked London and i have never connect to this server yet. I even tried putting the Geo-filter radius only covering the UK and that would just refuse to connect to any server at all. It was like the London was offline. I also tried putting my radius in the middle of the ocean and set ping assist to 30ms ..This refused to connect to any server aswell. Spectate mode obviously works fine

Overall i think apex is a poor networked optimised game 

Share this post


Link to post
Share on other sites

We're aware of the fact that the Apex Legends server selection screen seemingly doesn't actually do anything. As for why you're not connecting to dedicated servers within your radius... I wonder if there's some authentication servers being blocked by accident? We should have all of them on a permanent whitelist but it's possible EA changed something and we haven't caught it yet.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...