Jump to content
Netduma Luke

Announcement: DumaOS Development Milestone 1.3

Recommended Posts

1 hour ago, Netduma Admin said:

We're in the testing stage now, so the wait should not be much longer.

Correct me if I am wrong but this is regarding the milestone 1.3 which includes ping assist and other ping stats on the router? Cheers.

Share this post


Link to post
Share on other sites

I'd really like to echo fatal0Efx's comment from upthread. He stated: 
 

Quote

 

 Any chance we'll ever get features such as

- freeform geo filters vs the existing radius centric filter. E.g. I am in FL and want to keep my filter on the U. S. mainland but filter out Caribbean Islands, Mexico, etc.

- reverse ping assist, i.e. filtering out high ping hosts within our geo filter

 

This is extremely important for those of us in the Southeast US in Black Ops 4.  The Miami servers are being used to serve people in the Carribean, Mexico, South America, and Central America since they only have the one server cluster in Brazil. Its become a total mess for us because the infrastructure in these locations is often quite inferior (of course the distance is an issue as well) and creates huge lag issues. I want to be able to filter on the US mainland but be able to eliminate specific server clusters that bring in QOL-breaking players. 

One new problem I've seen with BO4 is that its doing a matchmaking check in Miami. It never used to do that and suddenly tonight I am getting bounced from the game and Miami is the matchmaking server that is being pinged (and blocked).  I'm wondering if this was implemented in response to people knowing how bad Miami is and blocking it.  Without an ability to delineate between matchmaking and game servers people are forced into not blocking the Miami servers and thereby a terrible game experience. I've been manually allowing servers when I get booted and so far its worked to get matchmaking working pretty well without having games hosted on the Miami cluster.

Reverse ping assist would be spectacular too, on its face, maybe even better than ping assist.

I am ecstatic to see the tick rate information coming. Great work, and excellent response from the dev team on a hot topic.  Well informed customers can keep the gaming companies honest when they so often try not to be...

Share this post


Link to post
Share on other sites

I'm from Costa Rica connections in Latin America aren't bad at all, for example in Costa Rica we have fiber optic ftth connections... also docsis 3.0 and vdsl the thing is our internet is provided by USA... every single country is connected to Miami..... Mexico, central America and south America we aren't interconnect, I'm going to provide an example, if I send a message to someone in Colombia that message goes first to Miami and then is routed to Colombia is the same way if that person respond back to me, the only country that connects to a different place than Miami is Mexico they connects also to Texas I hope this post explain a little bit better how the connections works in Latin America.

Share this post


Link to post
Share on other sites
6 hours ago, DetroitLionsPodcast.com said:

I'd really like to echo fatal0Efx's comment from upthread. He stated: 
 

This is extremely important for those of us in the Southeast US in Black Ops 4.  The Miami servers are being used to serve people in the Carribean, Mexico, South America, and Central America since they only have the one server cluster in Brazil. Its become a total mess for us because the infrastructure in these locations is often quite inferior (of course the distance is an issue as well) and creates huge lag issues. I want to be able to filter on the US mainland but be able to eliminate specific server clusters that bring in QOL-breaking players. 

One new problem I've seen with BO4 is that its doing a matchmaking check in Miami. It never used to do that and suddenly tonight I am getting bounced from the game and Miami is the matchmaking server that is being pinged (and blocked).  I'm wondering if this was implemented in response to people knowing how bad Miami is and blocking it.  Without an ability to delineate between matchmaking and game servers people are forced into not blocking the Miami servers and thereby a terrible game experience. I've been manually allowing servers when I get booted and so far its worked to get matchmaking working pretty well without having games hosted on the Miami cluster.

Reverse ping assist would be spectacular too, on its face, maybe even better than ping assist.

I am ecstatic to see the tick rate information coming. Great work, and excellent response from the dev team on a hot topic.  Well informed customers can keep the gaming companies honest when they so often try not to be...

Really helpful to know. Thank you. We'll look into both of these ideas.

40 minutes ago, fakkel said:

I have a question though, do I first need to install the NetdumaOS separately and after that, I can install the 1.3 firmware or is it a total package?

If your original R1 firmware is on 1.03.6 then you can install directly to this latest firmware.

Share this post


Link to post
Share on other sites
16 hours ago, josh200505 said:

I'm from Costa Rica connections in Latin America aren't bad at all, for example in Costa Rica we have fiber optic ftth connections... also docsis 3.0 and vdsl the thing is our internet is provided by USA... every single country is connected to Miami..... Mexico, central America and south America we aren't interconnect, I'm going to provide an example, if I send a message to someone in Colombia that message goes first to Miami and then is routed to Colombia is the same way if that person respond back to me, the only country that connects to a different place than Miami is Mexico they connects also to Texas I hope this post explain a little bit better how the connections works in Latin America.

I can appreciate this.

Its still a 1,500-1,600 mile one-way trip for packets, (3,100 round-trip) which is far less than ideal.  I'm finding that Puerto Rico and Honduras have been absolutely horrible and the Cayman Islands haven't been so hot either. Mexico has been horrible when I live in California, and now when I live in Florida - very likely a bad experience.  Colombia isn't on my complaint list, but (no offense intended) you are too far away and I don't want you in my lobby.

Share this post


Link to post
Share on other sites

Next on my issue with not being able to connect to a dedicated server:

even with the geofilter in spectating mode, cannot connect to a dedi. i see them flashing up when i start the game. including the server in Singapore. The game just doesnt connect to it.

sine i upgraded to DumaOS the game crashed twice and i have one host migration after the other.

I am on a fiber with 100 / 40 MB/s

Back to R1 it is.

Share this post


Link to post
Share on other sites
8 hours ago, NoMoreMyFriend-S said:

Next on my issue with not being able to connect to a dedicated server:

even with the geofilter in spectating mode, cannot connect to a dedi. i see them flashing up when i start the game. including the server in Singapore. The game just doesnt connect to it.

sine i upgraded to DumaOS the game crashed twice and i have one host migration after the other.

I am on a fiber with 100 / 40 MB/s

Back to R1 it is.

Have you tried the suggestions I've made in other topics? With spectating mode off it's not restricting your search at all. Don't always trust that its a peer if it says so on the Geo-Filter, it could be misclassified

Share this post


Link to post
Share on other sites
15 hours ago, Netduma Fraser said:

Have you tried the suggestions I've made in other topics? With spectating mode off it's not restricting your search at all. Don't always trust that its a peer if it says so on the Geo-Filter, it could be misclassified

with geofilter on I do not find a game at all, hence i went into spectating mode. then it is only peer connections. and as i constantly had host migrations and game crashing after the second migration, I do believe it is peer connections. Also I did not judge the symbol in geo filter, but by the info that is on the lower right corner with ping stats and tick rates.

I did play with geofilter distances and ping assist, then either one on/off. Either no lobby or peer to peer and game crashing...

Share this post


Link to post
Share on other sites

Hi - The game does a crucial network check when you boot up the game. It pings all the dedicated servers in the game and every server that your Geo-Filter blocks will no longer be chosen by the game to host any match you play. If you ever find you're just getting P2P, or you're getting long search times, reboot the game. It should then work better the next time.

Share this post


Link to post
Share on other sites
21 hours ago, Netduma Admin said:

Hi - The game does a crucial network check when you boot up the game. It pings all the dedicated servers in the game and every server that your Geo-Filter blocks will no longer be chosen by the game to host any match you play. If you ever find you're just getting P2P, or you're getting long search times, reboot the game. It should then work better the next time.

Thanks for thsi info.

I did restart the fame and console every time i made a relevant adjustment (learned that from other thread/previous postings). No change. no issue when using the R1OS.

also realised that when throttling from 70%b to 10% my game experience gets better. will try again today if i can reproduce that. 10/4 instead of 65/25

Share this post


Link to post
Share on other sites
6 hours ago, NoMoreMyFriend-S said:

Thanks for thsi info.

I did restart the fame and console every time i made a relevant adjustment (learned that from other thread/previous postings). No change. no issue when using the R1OS.

also realised that when throttling from 70%b to 10% my game experience gets better. will try again today if i can reproduce that. 10/4 instead of 65/25

Give it a go then and see how it goes. That's a pretty extreme throttle but if it's improving your gameplay then by all means :D

Share this post


Link to post
Share on other sites
19 hours ago, Netduma Jack said:

Give it a go then and see how it goes. That's a pretty extreme throttle but if it's improving your gameplay then by all means :D

I have like 2-3 good games, then the next 3-4 are straight garbage with shots not registering and literally the game/screen freezing up for split seconds.

when i then restart the game, the cycle starts again. i reproduced this cycle now for 7-8 times. planning to try tomorrow to restart as soon as i have the first bad game (bad I mean like cannot kill anybody for the first 5-6 engagements and instand death events).

My internet is pretty good from ping and buffer bloat. at least much better than ever before

http://www.dslreports.com/speedtest/42194827

I do not see other players that connect to the lobby (nothing popping up on the geofilter) and it seems that neither the ping assist nor the geofilter do work as I have people teleport and lag all over the place. what could be the reason for such behaviour?

 

 

 

Share this post


Link to post
Share on other sites
5 hours ago, NoMoreMyFriend-S said:

I have like 2-3 good games, then the next 3-4 are straight garbage with shots not registering and literally the game/screen freezing up for split seconds.

when i then restart the game, the cycle starts again. i reproduced this cycle now for 7-8 times. planning to try tomorrow to restart as soon as i have the first bad game (bad I mean like cannot kill anybody for the first 5-6 engagements and instand death events).

My internet is pretty good from ping and buffer bloat. at least much better than ever before

http://www.dslreports.com/speedtest/42194827

I do not see other players that connect to the lobby (nothing popping up on the geofilter) and it seems that neither the ping assist nor the geofilter do work as I have people teleport and lag all over the place. what could be the reason for such behaviour?

That's interesting. Given that nothing is changing in the Netduma settings after 3 or so games, that's some net-code on the game taking effect. I'm not sure what the reasoning would be behind that - maybe the game prioritises more stable servers to start you off and you move further down the priority list the more games you play? Could be some measure to deal with the amount of players online at one time. I'm just speculating really, it's the first time I've heard an issue like that.

Players teleporting around are sometimes unavoidable. Just to clarify - the Geo-Filter is built to reduce your lag, not other players. Other players are out of the control of any router, but with the Geo-Filter you can control your ping and distance to the server (and this in turn reduces the chance of there being laggy players on the server, since it's nearby). The Geo-Filter helps a lot with hit registration, rubber banding etc - your low ping should work favourably with the server lag compensation.

If literally nothing is showing on the Geo-Filter make sure you have the right device added - check its IP address against the address shown on the console itself.

Share this post


Link to post
Share on other sites
19 hours ago, Netduma Jack said:

That's interesting. Given that nothing is changing in the Netduma settings after 3 or so games, that's some net-code on the game taking effect. I'm not sure what the reasoning would be behind that - maybe the game prioritises more stable servers to start you off and you move further down the priority list the more games you play? Could be some measure to deal with the amount of players online at one time. I'm just speculating really, it's the first time I've heard an issue like that.

Players teleporting around are sometimes unavoidable. Just to clarify - the Geo-Filter is built to reduce your lag, not other players. Other players are out of the control of any router, but with the Geo-Filter you can control your ping and distance to the server (and this in turn reduces the chance of there being laggy players on the server, since it's nearby). The Geo-Filter helps a lot with hit registration, rubber banding etc - your low ping should work favourably with the server lag compensation.

If literally nothing is showing on the Geo-Filter make sure you have the right device added - check its IP address against the address shown on the console itself.

It goes even further.

I now upgraded again and when I start the PS I do get the Singapore router (mostly). The I play a few games, it gets bad and I back out of lobby or restart the game and then I do not get connected to the Singapore router anymore. Have to restart the game 4-5 times, also the router and console before I do get again onto Singapore Server. Nothing changes on router settings while I play.

That is so strange since with R1 OS I am on that server every time, without fail.

What is not working with DUma OS is when I flush the cloud. It is like trying for a minute and then I do get an error. Any idea what this could be?

This afternoon after the third time I did this, I couldnt access my PS games anymore until I did a connection test on PS. And never got back into Singapore server.

I checked the IP of my console (fixed), same as the one shown in game and on router. I have this since IW that I do not see other players when I am connected to a dedi. When P2P then I do see some of the other players.

 

Share this post


Link to post
Share on other sites

I can't think of any reason why you are seeing a difference - it could just be a complete coincidence.

We are working on a major Cloud update, so it might be worth going back to the original R1 firmware until this is rolled out - but this is up to yo (as I say, I think this is just a coincidence)

One other option you might want to try is putting your Geo-Filter location in the ocean with none of the red radius touching land. Then set Ping Assist to a low value, e.g. 15ms, and try loading the game again. This might force a Singapore server only.

Share this post


Link to post
Share on other sites
8 hours ago, Netduma Admin said:

I can't think of any reason why you are seeing a difference - it could just be a complete coincidence.

We are working on a major Cloud update, so it might be worth going back to the original R1 firmware until this is rolled out - but this is up to yo (as I say, I think this is just a coincidence)

One other option you might want to try is putting your Geo-Filter location in the ocean with none of the red radius touching land. Then set Ping Assist to a low value, e.g. 15ms, and try loading the game again. This might force a Singapore server only.

New observation. I had whitelisted (allow) 2 of the 'servers' when I played on Singapore. When I could not get any game on them anymore last night (I could ping them though; so I was sure they still exist), then I deleted these 'allowed' servers, and bang: I was getting put onto that Singapore server and played for hours, reconnected without issues even when backing out of lobbies. Conclusion: the whitelist/allow function needs to be looked at, as it seems to do exactly the opposite. 

Approach to place home location into the ocean and having a ping assist of 40 ms (the Singapore server usually pings for me between 32-37 ms):

Works great on the R1OS but when I tried this on the DumaOS, I cannot even connect to the verification server in Ireland (which I pinged at 300-450 ms). -> clear why I cannot connect with my PA settings (I actually thought that one to be whilelisted, which underlines my above observation that the whitelisting has issues).

To a point I am happy to be back on the server (p2p is even more unplayable), but the issue that I do not see the other players on the geofilter remains. I would like to see and ping them because my observation is that many others in the lobby lag heavily and also must have jitter/packet loss issues as they teleport all over the place.

I restarted my R1 daily several times, cleaned the browser, etc. still cannot see other players, unless I am on a p2p connection. Any ideas?

Share this post


Link to post
Share on other sites
On 11/25/2018 at 2:37 AM, NoMoreMyFriend-S said:

the issue that I do not see the other players on the geofilter remains. I

Are you playing on a PS4? When you're on a dedicated server in PS4, you cannot see other players on the Geo-Filter because you do not ping them. This is Treyarch's decision - probably to reduce server load.

 

Share this post


Link to post
Share on other sites
23 hours ago, Netduma Admin said:

Are you playing on a PS4? When you're on a dedicated server in PS4, you cannot see other players on the Geo-Filter because you do not ping them. This is Treyarch's decision - probably to reduce server load.

 

Thank you. That explains why i cannot see when on a server, but can see when p2p

hope you get your dumaOS fixed so i can try again to upgrade and play on the Singapore server as reliably as i can on the R1 OS

Share this post


Link to post
Share on other sites
On 24/11/2018 at 12:43, NoMoreMyFriend-S said:

Cela va encore plus loin.

J'ai maintenant mis à jour à nouveau et quand je commence le PS je reçois le routeur de Singapour (la plupart du temps). Puis-je jouer à quelques jeux, la situation se dégrade et je sors du lobby ou je redémarre le jeu, puis je ne suis plus connecté au routeur de Singapour. Je dois redémarrer le jeu 4-5 fois, ainsi que le routeur et la console avant que je ne revienne sur Singapore Server. Rien ne change sur les paramètres du routeur pendant que je joue.

C'est si étrange car avec R1 OS, je suis sur ce serveur à chaque fois, sans faute.

Ce qui ne fonctionne pas avec DUma OS, c’est lorsque je vide le cloud. C'est comme essayer pendant une minute et ensuite j'obtiens une erreur. Avez-vous une idée de ce que cela pourrait être?

Cet après-midi, après la troisième fois, je ne pouvais plus accéder à mes jeux PS tant que je n'avais pas fait de test de connexion sur PS. Et jamais rentré dans le serveur de Singapour.

J'ai vérifié l'adresse IP de ma console (fixe), identique à celle affichée dans le jeu et sur le routeur. J'ai ce depuis IW que je ne vois pas les autres joueurs quand je suis connecté à un dedi. Lorsque P2P, je vois certains des autres joueurs.

 

Bonjour 

J'ai exactement les mêmes problemes que toi avec dumaos pour  jouer à BO4

Filtre activé ou pas , je ne trouve pas de partie ou rarement, ainsi que de des parties avec un ping à 284ms !!!!

j'ai une fibre à 700mega down et 300 up et avec dumaos le jeu est horrible.

avec la version originale ça fonctionne un peu mieux.

Share this post


Link to post
Share on other sites
1 hour ago, Cécé said:

Bonjour 

J'ai exactement les mêmes problemes que toi avec dumaos pour  jouer à BO4

Filtre activé ou pas , je ne trouve pas de partie ou rarement, ainsi que de des parties avec un ping à 284ms !!!!

j'ai une fibre à 700mega down et 300 up et avec dumaos le jeu est horrible.

avec la version originale ça fonctionne un peu mieux. 

Hello!

With the R1 I have no issue to connect to Singapore.

What I notice is that the players I am teamed up with do lag and jitter badly and most lobbies I have to put entire magazine into a player to kill him.

The safeguard mode is completely unplayable for me.

The better my own connection, it seems also the more the server punishes me. Today I have a boost of 300/300 and it is worse than with 100/40. When I throttle with Netduma to like 4/3 then it seems to work much better than when at QoS settings 25/15 MB/s

Share this post


Link to post
Share on other sites
5 hours ago, NoMoreMyFriend-S said:

salut!

Avec le R1, je n'ai aucun problème pour me connecter à Singapour.

Ce que je remarque, c’est que les joueurs avec lesquels je fais équipe font très mal le décalage et la gigue, et la plupart des groupes de pression doivent mettre tout un magazine dans un joueur pour le tuer.

Le mode de sauvegarde est totalement injouable pour moi.

Plus ma propre connexion est bonne, plus le serveur me punit également. Aujourd'hui, j'ai un boost de 300/300 et c'est pire qu'avec 100/40. Quand j'accélère avec Netduma pour aimer 4/3, alors il semble que cela fonctionne beaucoup mieux que lorsqu'il est réglé à la QoS 25/15 Mo / s

salut

Je suis revenu sur le firmware original qui fonctionne pour trouver des games, geofiltre et ping assit fonctionne plus ou moins.

Le millestone est horrible : je ne trouve aucune voir très peu de game correct

 l'attribution de puissance par appareil est inexacte

le qos me donne des ralentissements alors que j'ai 750/300 fibre optique...

plus les années passent et plus j'ai li'impression que les routeurs n'y changent pas grand chose

malheureusement

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×