Jump to content

Slow send rate over 5GHz Wi-Fi

Recommended Posts


I have a Nighthawk XR500 router and a Nighthawk X4S D7800 router. For ease of reading, I’ll call the Nighthawk XR500 router ‘Router 1’ and the Nighthawk X4S D7800 router ‘Router 2’.

Router 1 is my main router and handles pretty much all of my devices, including my Win 10 Desktop PC which is connected to it via ethernet cable.

Router 2 is connected to Router 1 via its [5GHz] Wireless Bridge Mode feature. Router 2’s Link Rate (as reported by the Advanced >> Status page), is 1559mbps. Router 2 is approximately 8 meters away from Router 1 and the Wi-Fi signal goes through a plasterboard partition wall. Connected to Router 2 via an ethernet cable is a WD PR2100 NAS storage device. The files on the NAS are available on my PC from a mapped network drive. 

PC <Ethernet> Router 1 <5GHz> Router 2 <Ethernet> NAS

Question: When transferring files to and from my NAS, why do I get massively different send and receive rates from my PC? Two examples are below:

  • Downloading a 1GB file from my NAS to my PC comes through at a rate of 400mbps and takes about 25 seconds. 
  • Uploading a 1GB file back to the NAS from my PC sends at a rate of 45mbps and takes 3 minutes 50 seconds.

Router 1’s 5GHz channel is 100(DFS) but I have tried other channels and also tried the 2.4GHz band with pretty much the same results.

I realise a lot of stated Wi-Fi throughputs are theoretical figures. Router 2’s Link Rate is 1559mbps yet the most I can achieve is 400mbps. Don’t get me wrong, I’m very happy with 400mbps over Wi-Fi, but why can I not achieve the same rate when I send a file? Am I missing a blindingly obvious setting somewhere?

Of course I'm assuming that Wi-Fi is the issue when it might not be, but I can't think of anything else. My PC ethernet has a 1Gig link to Router 1 and QoS is turned off.

This isn’t a game-specific issue so I’m not sure whether to hop over to the Netgear forums or not, but it does involve the XR500 router so I’ll try here first.

Thank you in advance for any suggestions and happy new year’s eve to all – fssst, glug 🍻

Link to comment
Share on other sites

No input on your actual question, but I don't understand why you would want to use a NAS on router 2 and connect that over wifi. I would put it at router 1 if you use it from your PC.


And if possible I would actually hardwire your AP.


Also what speeds do you get when you plug the NAS in your XR500? (Router 1)



Link to comment
Share on other sites

Hi Bert,

Thanks for your reply.

The two 4TB WD40EFRX drives I have inside the NAS are good for their intended purpose, i.e., NAS storage, but they are not the quietest drives in the world. The ‘ticking’ sound of the actuator arms moving back and forth would be a constant source of irritation to me in the living room (where my XR500 is), hence the NAS's exile to the spare bedroom.

I paid around £200 GBP for 8TB of HDD storage. SSD’s would be nice because they are silent but I would need to sell a kidney to afford 8TB of SSD technology.

Hard wiring my entire apartment with high-category cable is a project I have been contemplating for a while now and may come to fruition next year. But, for the time being, my only option for the NAS is Wi-Fi.

In answer to your question, I’ve just tested the NAS plugged directly into my XR500 and the speeds I get with the same 1GB file as before are:

  • 1GB file download, 605mbps, 15 seconds (notably not 1 Gig speeds)
  • 1GB file upload, 215mbps, 50 seconds

Predictably, the throughput speeds to the NAS are better when connected directly to the XR500, but there’s still a clear discrepancy between the up/down speeds. So, my assumption that Wi-Fi was to blame for slow upload is, (ahem!), wrong.

Dependent on the 2020 hangover / consciousness, I will tomorrow try taking the XR500 out of the equation altogether and test the transfer speeds directly from PC to NAS.


Link to comment
Share on other sites

  • Administrators

Tricky one for us to help with this as it's hardware related, so more a question for NETGEAR than ourselves but we will try to help. What happens when you remove the XR500 from the equation? My gut feeling is it may be slow due to the Wireless Bridge mode as the default WiFi speeds are usually outstanding.

Link to comment
Share on other sites

Did you ever get better speeds?

Are you transferring files from NAS to a drive that can handle whatever speed you're after? 
i noticed you havent mentioned what drives you're using in your workstation. if you're using m.2, what motherboard do you have.

If you're just using a single HDD or ssd on sata or m.2 on a motherboard with insufficient lane bandwidth, you're not going to get gbit transfer speeds. also download and upload speed of an hdd is drastically different depending on the drive you're using.

Edited by acoop133
First question has already been answered
Link to comment
Share on other sites

Hi Netduma Admin & acoop133,

Thanks for your replies & happy new year!

A few workstation specs:

  • OS: Win 10 Pro Version 10.0.18363 Build 18363
  • Motherboard: GIGABYTE X58A-UD3R (rev. 2.0)
  • SSD: OCZ Vertex3 240GB
  • Processor: Intel(R) Core(TM) i7 950 @ 3.07GHz, 3060 Mhz, 4 Core(s), 8 Logical Processor(s)
  • Ethernet: Realtek PCIe GbE Family Controller

Not the newest of components but still very capable.

Just tried the NAS connected directly to the PC with a Cat 7 cable. The transfer speeds with the same 1GB file are:
Read 880mbps (about 10 seconds)
Write 864mbps (about 10 seconds)


Just short of 1 gig speeds both ways. Used Google for the conversions.


  • NAS connected via 5GHz Bridge Mode - 45mbps up - 400mbps down - a difference of 355
  • NAS connected directly to XR500 - 215mbps up - 605mbps down - a difference of 390
  • NAS connected directly to PC - 864mbps up - 880mbps down - a difference of 16

I know this isn’t a controlled laboratory experiment, but from these figures I can see that there are big differences when the XR500 is in the loop (EDIT: Even when Wi-Fi is not being used).

Generally this isn't a big issue for me, but it would be nice to get the same write speeds as I get with the read speeds over 5GHz Wi-Fi Bridge Mode, considering two high-end routers are being used.

Link to comment
Share on other sites

15 hours ago, Netduma Alex said:

Well those speeds sound about right for 2.4GHz, not for 5GHz. Are you using the mode where 2.4 and 5GHz are linked together?

Hi Alex,

Thanks for your reply.

I have my XR500 set up with 2 specifically different SSID's so I can select the Wi-Fi band I want to use when connecting a new device.

My Nighthawk X4S D7800 (the bridge router) is connected using the XR500's 5GHz SSID.

i.e. 'mynetwork' (for2.4GHz) & 'mynetwork-5GHz' (for, err... 5GHz) 😀

D7800 bridge wifi setting.jpg

Link to comment
Share on other sites

54 minutes ago, Netduma Alex said:

And I assume that the NAS is quite close to Router 2?

Because 5GHz has a much shorter range than 2.4GHz.

Yes, as I mentioned in my original post, the bridge router (and the NAS connected to it) is approximately 8 meters away from the XR500. The Wi-Fi signal goes through a plasterboard partition wall, not brick. Brick might degrade the signal quite a bit but tests through the partition wall using a geeky Android app give very favorable results.

Generally speaking, I know 5GHz is high throughput and short distance and 2.4GHz is high distance and low throughput but I’m not sure Wi-Fi is the real issue now…

In a previous post, I noted that when I connect the NAS directly to the XR500, (thus removing Wi-Fi from the equation), i.e.,
PC <Ethernet cable> XR500 <Ethernet Cable> NAS
There’s still a huge discrepancy with up/down speeds, even though everything is wired.

If I go one step further and remove the XR500 from the link, i.e.,
PC <Ethernet cable>NAS
I get pretty much 1 Gig speeds either direction.

Link to comment
Share on other sites

On 1/2/2020 at 6:45 PM, Netduma Fraser said:

Try putting the XR500 in AP mode, I'd be interested to see whether with DumaOS mostly disabled if those speeds change when wired/through WiFi.

Hi Fraser,

Thanks for your input.

That seemingly simple test took three hours!

Anyway, to cut a long story short, the results for the NAS connected directly to the XR500 via Cat7 cable in AP Mode are in!

[drum roll and ridiculously long talent-show-type-wait…]

168mbps write / up
560mbps read / down

I used Google for the MB - Mb conversions.


Worse figures than when the NAS was connected directly to the XR500 and not in AP Mode!

I’ll add that result onto the bottom of this table…

NAS connected to XR500 via X4S D7800 in 5GHz Bridge Mode

45mbps up

400mbps down

A difference of 355

NAS wired directly to XR500

215mbps up

605mbps down

A difference of 390

NAS wired directly to PC

864mbps up

880mbps down

A difference of 16

NAS wired directly to XR500 in AP Mode

168mbps up

560mbps down

A difference of 392

Note, I did a factory reset of the XR500 prior to putting it into AP mode to avoid any existing configuration interfering with the tests but there seems to be a pattern emerging here…

In all but one of those results, there ia a fairly steady difference between the up & down speeds of 350’ish to 390’ish. The only exception is when the XR500 is not in the loop. Then, there is only a negligible difference of 16mbps between the upload and download speeds.

Even when my NAS directly wired to the XR500 with Cat 7 cable (and not in AP Mode), transfer speeds only ever achieved 605mbps download. Disappointing, considering all the ethernet ports are supposed to be 1 Gig 😐

Connected directly to the PC, I get speeds approaching 1 Gig either way, confirming my PC and NAS are both capable. But why do I never come close to those speeds when the XR500 is in the loop?

Link to comment
Share on other sites

  • Administrators

Well that is very weird, so DumaOS isn't affecting the speed at all in this sense which means there isn't anything setting wise that would resolve this as far as I could see. As Admin mentioned before I think this might be a hardware issue and something you'll need to take up with Netgear directly - perhaps there is a setting in their Settings page that is affecting this - perhaps toggling IGMP Proxying in WAN Settings may help. Either way if you make a ticket with Netgear they should get to the bottom of it http://support.netgear.com/

Sorry that there isn't more we can do but with AP mode enabled DumaOS is effectively disabled so it's nothing we've done ourselves that's throttling you which makes it harder to us to diagnose.

Link to comment
Share on other sites

14 hours ago, Netduma Fraser said:

perhaps toggling IGMP Proxying in WAN Settings may help.

Hi Fraser,

Thanks for your reply.

I tried toggling the ‘Disable IGMP Proxying’ setting but no change. I’ve seen the setting before but am not particularly familiar with it. If my Google searches are correct, wouldn’t that setting just have an effect on WAN traffic?

Would you happen to know what the default setting is for ‘Disable IGMP Proxying’? I can’t remember but I would like to put it back to the default checked/unchecked setting?

Anyhoo, I’ll get in touch with Netgear and see what they have to say. I’ll point them towards this thread so they can brief themselves on the problem. If I get a resolution, I’ll post back to this thread for future reference.

Link to comment
Share on other sites

  • Administrators

It was a long shot, was the only thing I thought could be related as it's media. By default it is ticked. Sorry we can't help further but that would be really helpful if you come across a solution, best of luck!

Link to comment
Share on other sites

  • 2 weeks later...

I seem to have sorted my problem 😀

I posted over in the Netgear forum but got no suggestions so I created a ticket. The guy’s in telephone support were good and methodical at trying to resolve the issue but suggested nothing which I hadn’t tried thus far. 

I’ve spent many hours trying to get this sorted so I just gave up and decided to suffer the relatively slow transfer speeds... 

Then, one day (I’m not trying to make this sound like a story, honest), I was pottering around on the PC and remembered there were some under-the-bonnet settings for my ethernet adapter which I could try. In Windows 10, it is: 

  • Right click Start 
  • Device Manager 
  • Network adapters 
  • Realtek PCIe GBE Family Controller 
  • Advanced tab 

In the Property list, I selected Speed & Duplex. My Value was on Auto Negotiation. I assumed this was the default setting and it meant my devices would talk to each other and ‘negotiate’ the highest possible speeds. But I tried changing this to 1.0 Gbps Full Duplex and clicked OK. Guess what? Yup, speeds with my NAS connected directly to my XR500 went up to a, not too shoddy, 904Mbps down (0.904 Gigabit) and 875 up. Previous readings were 605Mbps down, 215 up. 

I then put Speed & Duplex back to Auto Negotiation and my speeds were still high! I presumed it was a driver glitch and looked on t' internet for a more recent driver. My old driver was released 2015 but I found a more recent ‘signed’ one for 2017 and installed that. 

What threw me is the fact that when I plugged my NAS directly into the PC, I got great speeds so why would I suspect the driver was to blame? Whether this was Auto Negotiation failing to ‘negotiate’ or not, I have no idea but I now have a shiny new driver installed and speeds are great. The real test was over Wi-Fi - my original dilemma... 

Speeds over 5GHz Wi-Fi are now 782Mbps down, 443 up. Previous readings were 400Mbps down, 45 up. 

To conclude, Wi-Fi write speeds have increased by almost half a Gig and read speeds are now approaching a Gig! Not bad for Wi-Fi 😎

The End.

Link to comment
Share on other sites

How did updating the Ethernet adapter fix the Wi-Fi problem? Oh well I ain't one to argue with a good thing.

This solution makes a lot of sense, i'll keep it in mind in case something similar comes up in future. Thanks for reporting back!

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...