Jump to content
TwiztedDemise

Port Forwarding Not Working Correctly Xbox X

Recommended Posts

So i have come across the issue when forwarding 3074, The main xbox port,  the xbox x  thinks the port is blocked and chooses a alternate port to force upnp. Even if the port is in manual mode and i select 3074 which i have go to offline mode and back online and quickly select that port as it will not give the option. It does a quick scan and sees it blocked, then switches back to another alternate port. Only work around is to forward 3074 and other ports used for games and turn upnp off. Game also goes to moderate sometimes with the ports required by xbox as well as games used aka black ops 4. I called xbox live and discussed this issue with them thinking it was the xbox issue in software. They stated that it checks the ports to see if they are available. How is it with wan open and ports forwarded that i gain a moderate nat type only unless its through upnp. I have the fastest internet in the nation epb fiber optics with nearly 1gb up and 1 gb down all fiber. 2 ping and 1 jitter to epb. 30ms ping to google and to the Washington teredo 40ms ping. Im wired and have static ip, been playing with port forwarding for 8 years. I also know that most every router in order for the xbox to see 3074 as good sometimes its best to make 2 ports 1 udp and the other tcp instead of selecting both option. So trying it both ways, still no avail unless upnp is fully disabled.

Share this post


Link to post
Share on other sites

Fastest internet doesn't mean you always get an open NAT, they're not related.

Disable the Geo-Filter, do you see an open NAT then? May be the filter causing a misreading. Have you put the router in the DMZ of your ISP hub? Have you tried DMZ with the console on the router? If something else has opened that port previously it may not have been released allowing the Xbox to use it. 

Share this post


Link to post
Share on other sites

So i have almost always had open nat, but there is a slight difference in connection with forwarded ports vs upnp. I can turn off upnp and my xbox can still aquire open nat, game... thats a different story. But that is what xbox live stated with skmething else using that port. But i have attempted with all devices off but xbox and a full restart on router and this still happens. 

Share this post


Link to post
Share on other sites

I have found that on ps4 having upnp on gives me a moderate nat type in bo4 and was having to manually port forward however a couple of days ago I reset the router which erased all my port forwarding rules so tried upnp again giving me moderate nat turned upnp off and nat type went to open and has been ever since so I am now running no upnp and no port forwarding rules and all is good

Share this post


Link to post
Share on other sites
23 hours ago, dav581005 said:

I have found that on ps4 having upnp on gives me a moderate nat type in bo4 and was having to manually port forward however a couple of days ago I reset the router which erased all my port forwarding rules so tried upnp again giving me moderate nat turned upnp off and nat type went to open and has been ever since so I am now running no upnp and no port forwarding rules and all is good

Hm, seems positive - you've got an open NAT so your settings can stay as they are! Nice one :)

Share this post


Link to post
Share on other sites

Yeah it's a bit weird but all is good.

I was thinking though would it be like this because my r1 is in the dmz on my router so all ports are open then when you enable upnp on the r1 it tries to open the ports again but because they are already open it is actually closing them

Share this post


Link to post
Share on other sites
10 hours ago, dav581005 said:

Okey dokey cheers and yes all is working great at the moment just need to get apex legends to work with the geofilter and it will be perfect

Thanks for the update. Could you follow this guide for Apex and then let us know how you get on:

http://support.netduma.com/en/support/solutions/articles/16000091840-optimal-dumaos-settings-for-apex-legends

Share this post


Link to post
Share on other sites
4 hours ago, dav581005 said:

Hi thanks I have followed the guide and so far the most I have managed is 2 games before it looses connection and then won't connect again so have to use spectating mode 

Can you make a separate post regarding this issue please? I'd suggest you zoom out fully on the map and see if anything is blocked when this occurs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×