Jump to content
xr450owner

XR450 Wi-Fi Calling Being Blocked

Recommended Posts

Ever since purchasing my XR450 router, Wi-Fi calling on my iPhone 7 (AT&T) and iPhone X (Verizon) stopped working. After hours of research online, it appears as though the router is blocking required traffic on ports 500 and 4500 (I think it's called IPSEC traffic). According to Apple's support site, both these ports for UDP traffic need to be allowed. Ideally, I want all devices that connect to my router to be allowed Wi-Fi calling.

I was able to get it working on a single device by configuring port forwarding, but unfortunately this method only allows this traffic for one device. I then started playing around with port triggering to allow the traffic on multiple devices. I got it to work briefly by creating (2) rules and setting Service Type:500 and Service Type:4500. I am unsure what to put for the inbound port range, so I just put a large range. Unfortunately, it stopped working after around 10 minutes. 

With this, I have a few questions:

What is the ideal way to configure this router to enable Wi-Fi calling on all connected devices?

For the port triggering method mentioned above, is there a recommended range for the inbound port section of each rule?

Thanks!

Share this post


Link to post
Share on other sites
1 hour ago, xr450owner said:

Ever since purchasing my XR450 router, Wi-Fi calling on my iPhone 7 (AT&T) and iPhone X (Verizon) stopped working. After hours of research online, it appears as though the router is blocking required traffic on ports 500 and 4500 (I think it's called IPSEC traffic). According to Apple's support site, both these ports for UDP traffic need to be allowed. Ideally, I want all devices that connect to my router to be allowed Wi-Fi calling.

I was able to get it working on a single device by configuring port forwarding, but unfortunately this method only allows this traffic for one device. I then started playing around with port triggering to allow the traffic on multiple devices. I got it to work briefly by creating (2) rules and setting Service Type:500 and Service Type:4500. I am unsure what to put for the inbound port range, so I just put a large range. Unfortunately, it stopped working after around 10 minutes. 

With this, I have a few questions:

What is the ideal way to configure this router to enable Wi-Fi calling on all connected devices?

For the port triggering method mentioned above, is there a recommended range for the inbound port section of each rule?

Thanks!

Hi, welcome to the forum! This is a difficult one for us to help with since Netgear designed all features relating to WiFi calling. I'll give it a bash though.

In Settings > WAN Setup try disabling SIP ALG. If that doesn't work also untick IGMP Proxying.

I'm not sure why those ports you mention would be blocked by the XR450... Do you have UPnP enabled? Really that should be automatically opening those ports on any device.

Share this post


Link to post
Share on other sites

Works okay on EE with the XR500.  Its. It helpful to say that I know when yours does not, but it’s working fine in the UK for me. It may be more of an issue with your phone provider than the router to be honest. I had it call my provider EE who had to reset the feature their end twice. 

Share this post


Link to post
Share on other sites

Hello and thanks for the quick reply! Unfortunately, toggling the SIP ALG and IGMP Proxying options did not work for me. This was part of my testing as I read about this possibility on other threads. Yes, UPnP is enabled. I played around with increasing the Time to Live, but that didn't work either. So far, the only thing that has allowed Wi-Fi calling is allowing UDP traffic on ports 500 and 4500 with either Port Forwarding or Port Triggering. Other than that, Wi-Fi calling fails. 

Might there be a fundamental issue with the built in UPnP feature, if that should be allowing Wi-Fi calling traffic? Is there a known bug or intention to release a new firmware version to improve?

 

Share this post


Link to post
Share on other sites
32 minutes ago, xr450owner said:

Hello and thanks for the quick reply! Unfortunately, toggling the SIP ALG and IGMP Proxying options did not work for me. This was part of my testing as I read about this possibility on other threads. Yes, UPnP is enabled. I played around with increasing the Time to Live, but that didn't work either. So far, the only thing that has allowed Wi-Fi calling is allowing UDP traffic on ports 500 and 4500 with either Port Forwarding or Port Triggering. Other than that, Wi-Fi calling fails. 

Might there be a fundamental issue with the built in UPnP feature, if that should be allowing Wi-Fi calling traffic? Is there a known bug or intention to release a new firmware version to improve?

 

I have wifi calling and have no issues, however as you are using 2 phones you could try adding the 1 that is causing issues to the DMZ.That should open all ports needed.  You could add those 500 and 4500 ports in the inbound range as well as outbound range too. Remember to reboot your phone once the changes you make are done. 

Share this post


Link to post
Share on other sites

I just tried adding the IP address of an iPhone that is not working with Wi-Fi calling to the DMZ. That did not fix the issue. Weird thing is, now when I re-add that same device IP to port forwarding feature, it's not working either! I was hoping to have narrowed this issue down, but it appears to be just as intermittent as before. This is driving me nuts haha. 

Share this post


Link to post
Share on other sites

WiFi calling has always been weird for me on my phone. I think it's mostly the phone, rather than the router.

If you connect a phone to your modem (assuming it has WiFi), do you get consistent WiFi through that? 

Share this post


Link to post
Share on other sites

I have a stand-alone SurfBoard modem without routing capabilities. I have an Archer C8 router that had worked with Wi-Fi calling in the past. I will try setting that up again to see if it still works. 

It sounds like there are many variables that go into WiFi calling that could be points of failure. Things like device, device OS, router and carrier all play parts. Makes it very hard to lock down a solid process. 

Share this post


Link to post
Share on other sites

 Wi-Fi calling uses the mac address of your router to identify you to the network. That may be the issue. Try turning wifi calling off then on again. You may have to do that more than once. Also contact your phone provider as they may have to disable and re enable WiFi calling from their end. This happened to me when I changed routers. I would say it’s more to do with your provider/phone than the router. Also I know this is a silly question but your phone is linked to the XR500 WiFi.

 If you have used the same ssid again I would turn on the old router and remove the WiFi connection from your phone as having two ssid”s with the same name on different routers can confuse handsets.  You only need to do that if you’ve used the same network name you used before though   

Share this post


Link to post
Share on other sites
44 minutes ago, xr450owner said:

I have a stand-alone SurfBoard modem without routing capabilities. I have an Archer C8 router that had worked with Wi-Fi calling in the past. I will try setting that up again to see if it still works. 

It sounds like there are many variables that go into WiFi calling that could be points of failure. Things like device, device OS, router and carrier all play parts. Makes it very hard to lock down a solid process. 

Hey I have similar issue as you for wifi calling.  I'm updated my R1 to DUMAOS and wifi calling stopped immediately.  I didn't notice it for a couple of days. It is an issue for a lot of people using DumaOS on the R1.  I know it's not the same as your router.  It did work on the original R1 firmware, but I had stopped using the R1 as my main router about 8 months ago. When I realized wifi calling wasn't working I called my phone service provider, and they had to reset my phone 2 times.  Wifi calling worked that day until I left the house and came back.  I tried manually forwarding the recommended ports, but it did not work.  

I ended up taking the R1 back out of service, and I am now using a different router until the DumaOS firmware gets sorted out.  Anyone who comes to my house needs to use wifi calling because I have very low cell phone signal in my area.  It doesn't matter which brand of phone is being used. They all work fine except when the R1 with DumaOS is in use. I attached the link to my wifi calling thread below for your reading enjoyment

 

 

 

Share this post


Link to post
Share on other sites

@Killhippie I will reach out to my carrier to see if that fixes it. Thanks  

@major masingil interesting. This stream seems to point back at Router OS. Someone from DumaOS even mentioned fixing this issue is on their roadmap. It’s crazy how all over the place this issue is. To me, nothing I’ve read from all the threads I’ve seen confirms anyone really knows what’s going on, other than it doesn’t work. Haha. Crazy stuff. Praying for a magic software fix, somewhere. 

Share this post


Link to post
Share on other sites
Just now, xr450owner said:

@Killhippie I will reach out to my carrier to see if that fixes it. Thanks  

@major masingil interesting. This stream seems to point back at Router OS. Someone from DumaOS even mentioned fixing this issue is on their roadmap. It’s crazy how all over the place this issue is. To me, nothing I’ve read from all the threads I’ve seen confirms anyone really knows what’s going on, other than it doesn’t work. Haha. Crazy stuff. Praying for a magic software fix, somewhere. 

It works fine on the XR500 in the uk I’m using it now on my iPhone Xs with my provider here EE. 

Share this post


Link to post
Share on other sites

also have Verizon, n wifi calling works here w. galaxys n iphones. but xr500, maybe issue with 450? no special configs on xr500

definite way to test it just put your phone in airplane mode and turn on wifi only, make a call .. if call goes thru, it's workin'

Share this post


Link to post
Share on other sites
1 minute ago, xr500user said:

also have Verizon, n wifi calling works here w. galaxys n iphones. but xr500, maybe issue with 450? no special configs on xr500

definite way to test it just put your phone in airplane mode and turn on wifi only, make a call .. if call goes thru, it's workin'

yeah my buddy is running the xr500 without any issue. He loves it.

Share this post


Link to post
Share on other sites

in addition, call your isp level 2/3 and make sure they aren't having issues with their firewalls blocking 500, sometimes when they update their chain of routers to latest version a bad config gets in there .. i have seen this before

Share this post


Link to post
Share on other sites
10 minutes ago, xr500user said:

also have Verizon, n wifi calling works here w. galaxys n iphones. but xr500, maybe issue with 450? no special configs on xr500

definite way to test it just put your phone in airplane mode and turn on wifi only, make a call .. if call goes thru, it's workin'

Don't think there would be any differences between the two, perhaps you and Killhippie could post your WAN settings, there may be a difference there thats preventing yours working

Share this post


Link to post
Share on other sites
51 minutes ago, Killhippie said:

It works fine on the XR500 in the uk I’m using it now on my iPhone Xs with my provider here EE. 

Yea before the issue @xr450owner identified with his router , I thought the problem may have been isolated to the R1. This is the first wifi calling issue I have seen that wasn't related to DumaOS on the R1.  I figured it could be related because of the Netduma's participation in it.  A couple of R1 owners tried, and it didn't work for them.

Share this post


Link to post
Share on other sites

true, i just don't get the point of the 450, best guess is that Netgear had some built with wrong specs and unloaded em to costco at a discount.

should of just trashed them.  as i always said - too many variants is going to be a support nightmare. i'm sure the ax8r is coming, but skip it man, go ax12r .. in the meantime maximize the xr500 and xr700, if it gets too splintered people will drop off, already been looking at other solutions if it doesn't improve soon and my prediction unfolds

but to be fair the xr500 has been very stable as of late, 42+ days uptime -- but neglected in the update department :(

Share this post


Link to post
Share on other sites
5 minutes ago, xr500user said:

in addition, call your isp level 2/3 and make sure they aren't having issues with their firewalls blocking 500, sometimes when they update their chain of routers to latest version a bad config gets in there .. i have seen this before

if it was the isp's firewall, I don't think wifi calling would work without a fuss when I use a different router.  Would it?  I'm speculating.  I have Fios internet, but I'm not using their router.  I'm using an Edgerouter X until the R1 gets squared away. 

Share this post


Link to post
Share on other sites

@xr500user I have been playing around with turning on airplane mode to test WiFi calling. Call me crazy, but it appears airplane mode doesnt actually disable all cellular calling ability. I was able to make a call with airplane mode on, and not using WiFi calling. On my iPhone 7 when WiFi calling is fully enabled, it says “call failed.” And I’ve noticed that even though the “WiFi calling” logo is presented on the device, it doesn’t actually mean its 100% using that feature. I think the mobile OS decides which to use based on signal strength. 

Share this post


Link to post
Share on other sites
1 minute ago, xr450owner said:

@xr500user I have been playing around with turning on airplane mode to test WiFi calling. Call me crazy, but it appears airplane mode doesnt actually disable all cellular calling ability. I was able to make a call with airplane mode on, and not using WiFi calling. On my iPhone 7 when WiFi calling is fully enabled, it says “call failed.” And I’ve noticed that even though the “WiFi calling” logo is presented on the device, it doesn’t actually mean its 100% using that feature. I think the mobile OS decides which to use based on signal strength. 

you're probably right about the signal strength. I know android phones have some settings where you can choose for it to prefer wifi calling over phone service.  Good luck man, I know this stuff can be frustrating to 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×