Jump to content
Sign in to follow this  
ifell

DHCP issue for Netgear Nighthawk XR1000

Recommended Posts

this occurs at random. the longest time this hasn't happened is 5-6 days 

this is with firmware XR1000-V1.0.0.54_1.0.40 I'm still using firmware Netduma Fraser provided me 

1 or 2 devices would be connected to the router but wouldn't configure properly, 

example IPV4 on a iPad would be set to DHCP and the settings would be

IP Address: 169.254.124.145 
Subnet Mask: 255.255.0.0
router: comes up blank

one or 2 of the game consoles had this happen too.


should be 

IP Address: 192.168.2.67
Subnet Mask: 255.255.255.0
Router: 192.168.2.1

DNS: 192.168.2.1


while this happened I tried to manually set the WIFI configuration to what it should be but it wouldn't work still, only a power cycle would remedy this issue.

this has happened a couple of times

Share this post


Link to post
Share on other sites

Have you tried setting a IP adress reservation in your DHCP table?

 

IP Address: 169.254.124.145 
Subnet Mask: 255.255.0.0
router: comes up blank

 

That range is essentially set if your device doesn't get a IP from DHCP at all, ie the DHCP service stops functioning.

Share this post


Link to post
Share on other sites

it should have been like this 

IP Address: 192.168.2.67
Subnet Mask: 255.255.255.0
Router: 192.168.2.1

DNS: 192.168.2.1


some devices were unaffected, but the effected ones I manually specified WIFI settings, which didn't work as mentioned before 


even with the configurations I've set it didn't work until the XR1000 was rebooted 

its really weird because even if the DHCP wasn't working, manually specifying the 
IP Address, Subnet Mask, Router\Gateway, DNS. should have worked, but it didn't 😕  

Share this post


Link to post
Share on other sites

On the iPad, go to the Wi-Fi settings for the XR1000 network and disable Private addresses, see if this helps! :) 

Share this post


Link to post
Share on other sites

all that comes up is 

auto-join: enabled

IPV4 Address
Configure IP: Automatic aka DHCP
IP Address: 192.168.2.24
Subnet Mask 255.255.255.0
router 192.168.2.1

DNS: manual
192.168.2.1
1.1.1.1
1.0.0.1
9.9.9.9



at the moment its working because I restarted the XR 1000

Share this post


Link to post
Share on other sites
6 hours ago, ifell said:

all that comes up is 

auto-join: enabled

IPV4 Address
Configure IP: Automatic aka DHCP
IP Address: 192.168.2.24
Subnet Mask 255.255.255.0
router 192.168.2.1

DNS: manual
192.168.2.1
1.1.1.1
1.0.0.1
9.9.9.9



at the moment its working because I restarted the XR 1000

OK, let us know if the issue re-occurs after disabling private addresses!

Share this post


Link to post
Share on other sites

I'll try disabling private addresses once the IPAD has connectivity troubles again.

this issue isn't just for the iPad, it also happens to consoles, computers, my android phone. my android doesn't have private addresses listed in the WIFI settings and it also runs into connected but no internet 

Share this post


Link to post
Share on other sites
47 minutes ago, ifell said:

I'll try disabling private addresses once the IPAD has connectivity troubles again.

this issue isn't just for the iPad, it also happens to consoles, computers, my android phone. my android doesn't have private addresses listed in the WIFI settings and it also runs into connected but no internet 

I'd suggest making the changes to the iPad now, then see if it continues to have connectivity troubles.

Out of interest, did you factory reset the XR1000 after upgrading to the beta firmware?

Share this post


Link to post
Share on other sites

yes I factory reset the XR1000 when updating the firmware you provided, the problem has occurred again, on both the iPad and this Computer, I had to USB tether my phone to the computer to get internet. here's what shows up. the iPad doesn't have a private addresses option.


943947273_Screenshot(109).thumb.png.e639a2b567fc87ae4a21ee7cd1d3e65e.png


I've tried setting up a static IP for the Computer, didn't work. doesn't work with Obtain an IP address automatically, as well as trying different DNS servers

  

Share this post


Link to post
Share on other sites

Just to clarify, did you change the LAN IP of the router to 192.168.2.1 manually as it's usually 1.1 by default. I have an iPad and it has the private addresses option, click the 'i' on the wifi network and you can disable there, did you also disable it on the PC?

Share this post


Link to post
Share on other sites

yes I set the LAN as 192.168.2.1, as 192.168.2.1 was the same gateway as the Netduma R2 I was using, just so I didn't have to re-enter everything password/SSID or change the gateway, and devices IP addresses (static IP's)

the iPad version 12 doesn't have Private addresses, can't be updated just checked

google Chromecast also had the same problem at the time.

I couldn't check if changing the network profile from Private to Public would work or not on the computer. Chromecast wasn't connected to the internet either as mentioned above, and someone wanted to stream Kayo so I had to restart the XR1000 just so everything could connect to the internet again ( temporary fix )

there seems to be a big issue with DHCP, but as I've shown previously, I tried to manually specify the IP Address/Gateway/SubnetMask/DNS
which again, should have worked but hasn't



when it happens to the computer again ill set the Network Profile to Public and see if it detects an internet connection ( IPV4 )

Share this post


Link to post
Share on other sites

Is it an older iPad then? On LAN Settings, set the DHCP range to start at .100 then in LAN settings reserve all your devices and give them IPs between .2-.99 and see if it helps

Share this post


Link to post
Share on other sites

yeah its an iPad Mini 2, the latest IOS version is 12.4 I think 

this is how I have LAN DHCP setup


LAN TCP/IP Setup

IP Address: 192.168.2.1
IP Subnet Mask: 255.255.255.0

RIP Direction: both
RIP Version: disabled
Use Router As DHCP Server: Enabled

Starting IP Address:192.168.2.20
Ending IP Address: 192.168.2.254


I have game consoles and computers already in Address Reservation, haven't changed it since installing the firmware you provided 

Share this post


Link to post
Share on other sites

Do change the starting IP address to .100 and make sure reservations are outside the range that DHCP provides - reason being if you give a device a reserved IP of .21 for example the router may mistakenly thing it's using DHCP, try and assign a new IP and thus cause a disconnection - thats a theory anyway

Share this post


Link to post
Share on other sites

Just a follow up, on the games consoles the Nat type comes up as ( NAT TYPE FAILED ) when this happens, only way to remedy this is to reboot the XR1000.

 

This can happen while the DHCP issue is occurring, and it can happen without the DHCP playing up.

 

 

 

 

I've posted this in the (Nat type trouble on the XR1000 ) since it seems to occur at the same time but not always.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...