Jump to content
kd14

Double Nat fix

Recommended Posts

just set up my netduma r2 router and I am receiving a double nat I have dmz passthrough selected on my att modem but on the netduma app it is still using the 192 ip address same as my att router any fix for this?

Share this post


Link to post
Share on other sites

Did you put the WAN IP from the R2 System Information page into the DMZ? Or did you put the LAN IP of the R2 in as the LAN IP won't work. 192 is normal for both of them, it's the last 192.68.x.x that will change. How are you measuring the NAT Type?

Share this post


Link to post
Share on other sites

I did a tracert prompt and it showed my att ip and netduma ip on first 2 hips also I put passthrough mode on my att modem for the netduma but I have not put the wan ip on the duma in dmz I also have the same wan ip showing on the duma as I do on my att modem

Share this post


Link to post
Share on other sites
On 8/19/2020 at 4:38 PM, Netduma Fraser said:

You need to use the R2 WAN IP which is the IP the ATT has given the R2 and put that in the ATT DMZ, then you should get an open NAT when connected to the R2.

I've randomly started having issues with this same problem now on Xbox One X. Everything was working fine until earlier when I had to reboot the R2 as it lost internet connection for some reason. On playing Xbox I noticed the Double NAT message and for some reason my R2 WAN IP had changed...so I updated this in the BT Smarthub DMZ settings. It has just started doing this again for no apparent reason giving me Double NAT and Moderate NAT rather than open. The R2 WAN IP has not changed in the R2 or the BT Smarthub.

The only other change is that I assigned a static IP to the Xbox One X, and that all appears to be fine.

Why is this happening, and what do I need to do to resolve?

Share this post


Link to post
Share on other sites
10 hours ago, K0NSPIRACY said:

I've randomly started having issues with this same problem now on Xbox One X. Everything was working fine until earlier when I had to reboot the R2 as it lost internet connection for some reason. On playing Xbox I noticed the Double NAT message and for some reason my R2 WAN IP had changed...so I updated this in the BT Smarthub DMZ settings. It has just started doing this again for no apparent reason giving me Double NAT and Moderate NAT rather than open. The R2 WAN IP has not changed in the R2 or the BT Smarthub.

The only other change is that I assigned a static IP to the Xbox One X, and that all appears to be fine.

Why is this happening, and what do I need to do to resolve?

OK so to be clear the R2 WAN IP changed the first time this happened, but it's now happened again and the WAN IP remains the same? 

Share this post


Link to post
Share on other sites
5 hours ago, Netduma Liam said:

OK so to be clear the R2 WAN IP changed the first time this happened, but it's now happened again and the WAN IP remains the same? 

Correct. I discovered the Double NAT and the first WAN IP change after I'd done a restart via DumaOS. The second time Double NAT error received, which was just hours later, had the same new WAN IP in DumaOS and DMZ on ISP router. I did a complete shutdown of all devices which resolved the issue the second time, but I haven't turned on my Xbox again yet today. I will reply in here if the issue persists.

Share this post


Link to post
Share on other sites
7 hours ago, Netduma Liam said:

OK so to be clear the R2 WAN IP changed the first time this happened, but it's now happened again and the WAN IP remains the same? 

Hi Liam and @Netduma Fraser. For the second day in a row, my R2 has now completely dropped connection to BT Smarthub2 (wired). I have not made any changes that would cause this to happen. The R2 remains on and shows activity, however I am unable to connect my Xbox or other devices online and unable to perform connection benchmark tests so it is clearly no longer connected to the internet. I am typing this post whilst being hard wired direct into the BT Smarthub2 so clearly there is something wrong here. The WAN IP is still the same on both the R2 and DMZ on BT Smarthub2. What am I supposed to do as I can't be having this every day?!

Edit: In my devices on Smarthub2, my MacBook is showing connected via port2 but R2 is showing as not connected via port1.

Share this post


Link to post
Share on other sites
55 minutes ago, K0NSPIRACY said:

Hi Liam and @Netduma Fraser. For the second day in a row, my R2 has now completely dropped connection to BT Smarthub2 (wired). I have not made any changes that would cause this to happen. The R2 remains on and shows activity, however I am unable to connect my Xbox or other devices online and unable to perform connection benchmark tests so it is clearly no longer connected to the internet. I am typing this post whilst being hard wired direct into the BT Smarthub2 so clearly there is something wrong here. The WAN IP is still the same on both the R2 and DMZ on BT Smarthub2. What am I supposed to do as I can't be having this every day?!

Edit: In my devices on Smarthub2, my MacBook is showing connected via port2 but R2 is showing as not connected via port1.

Just to be clear, on the Smarthub have you assigned a static/reserved IP to the R2? If you haven't, even though it hasn't change the DHCP renewal could have disconnected it.

Share this post


Link to post
Share on other sites
10 minutes ago, Netduma Fraser said:

Just to be clear, on the Smarthub have you assigned a static/reserved IP to the R2? If you haven't, even though it hasn't change the DHCP renewal could have disconnected it.

The only option I can find in BT Smarthub2 admin is to set R2 in the DMZ and select "Always use this IP address". There is a default lease time of 24 hours but it says "When a lease expires your device will automatically renew it the next time you connect and there will be no impact to your service", and DHCP lease server says "Valid leases are between 1 hour and 21 days". I don't see anywhere to set a static/reserved IP other than in the DMZ but may be I could completely disable DHCP? 

I've also just noticed that the IP address had changed again in the DMZ so that could be why it disconnected (it was quite subtle so didn't spot it earlier...the last digit changed from 48 to 148).

This is giving me a headache tbh.

 

 

Share this post


Link to post
Share on other sites

Apparently you can go to Advanced settings > My Network > select the device you wish to reserve an address and then select YES against 'Always use this IP address' and that should do it. Then put that IP in the DMZ and it should be all sorted.

Share this post


Link to post
Share on other sites
21 hours ago, Netduma Fraser said:

Apparently you can go to Advanced settings > My Network > select the device you wish to reserve an address and then select YES against 'Always use this IP address' and that should do it. Then put that IP in the DMZ and it should be all sorted.

Hi Fraser. Both of those settings were already done (I've just double checked) however it didn't stop the R2 losing connection to the Smarthub (which I believe may have been due to the IP changing again at end of 24 hour lease time).

Another question, whilst using the BT Smarthub, I'm now getting IPv4 and IPv6 on Xbox One, however when using the R2 it is IPv4 only. I have IPv6 enabled on both the R2 and Smarthub, so why is it that IPv6 is not recognised when the Xbox One is connected via the R2?

Share this post


Link to post
Share on other sites

Okay you may need to set this on the R2 side also, what is the IP the R2 has?

If you disable IPv6 on the R2 in LAN/WAN, then apply, then enable, apply, reboot does it show IPv6?

Share this post


Link to post
Share on other sites
5 hours ago, Netduma Fraser said:

Okay you may need to set this on the R2 side also, what is the IP the R2 has?

If you disable IPv6 on the R2 in LAN/WAN, then apply, then enable, apply, reboot does it show IPv6?

The R2 WAN IP was originally 192.168.1.112 but then it changed to 192.168.1.48 and then 192.168.1.148...it's safe to say that this will change again when I add it back into the mix, so will have to add/reserve again to the DMZ and device list. What details do I need to add on the R2 side and in which settings?

I will also try the suggested fix for IPv6 above, and confirm if it works or not.
 

Share this post


Link to post
Share on other sites
10 hours ago, Netduma Liam said:

I believe Fraser is suggesting you add this IP to Network settings -> WAN -> Static

Hi Liam and @Netduma Fraser 

Please advise what details need to go in here as I just added the R2 IP address into Network settings -> WAN -> Static as requested by Liam and the internet instantly dropped connection to the R2. I added the following details:

IP: 192.168.1.112 (IP address of the R2)

Subnet: 255.255.255.0

Gateway: 192.168.77.1

Is this correct or do other details need to be added here?

Also, I have just powered on my Xbox One, and it has immediately come up again with Double Nat and strict despite following all the instructions from yourselves to set the R2 WAN IP in the BT Smarthub. Why is this happening? 

Edit: rebooted the R2 again, checked all addresses are the same and now have Open Nat type. No logical explanation for this.

Share this post


Link to post
Share on other sites
On 1/21/2021 at 8:27 PM, Netduma Fraser said:

If you disable IPv6 on the R2 in LAN/WAN, then apply, then enable, apply, reboot does it show IPv6?

I have done this as requested but Xbox One is still showing as IPv4 only...as opposed to it being IPv4 and IPv6 connected directly to the BT Smarthub.

Share this post


Link to post
Share on other sites
4 hours ago, Netduma Fraser said:

You had it right but the gateway needs to be 192.168.1.1 and then it should work just fine.

Ok I've just done that and the internet fails immediately on all my devices. I also rebooted the R2 but still internet connection fails. Should there be further config in the BT Smarthub or do I need to complete either of the following in the R2 settings: MTU, Mac Address Cloning, DNS Override

Also worth noting that devices no longer connect to 5.0GHz wifi and they have all now defaulted to being on 2.4GHz.

Edit: I've solved the wifi issue by setting both 2.4GHz and 5.0GHz to automatic channel width (previously they were 40MHz and 80MHz respectively) and my devices have automatically reassigned themselves to the appropriate wifi. 

Edit2: apart from the fact that my iPhone is getting less than 10Mbps when connection benchmark on MacBook shows I'm getting 68Mbps. I'm really not sure what has happened, but something doesn't right after doing the factory reset (I'm on v3.0.179).

Edit3: set the channel width as per previous default above and copied the channel assignment from BT Smarthub2 (2.4GHz: Channel 11, Width 40MHz and 5.0GHz: Channel 36, Width 80MHz). Devices have reassigned themselves again between 2.4GHz and 5GHz. iPhone connected to 5GHz and Speedtest is now pretty much matching that on DumaOS connection benchmark on MacBook.

Share this post


Link to post
Share on other sites

@Netduma Liam @Netduma Fraser

Still having issues getting the BT Smarthub2 to be stable with R2 including the R2 and all my devices intermittently dropping connection from the internet.

A few questions...

1. Does the R2 have a built in firewall? If so, can I disable the firewall on the BT Smarthub2?

2. Still have issues with the reserved IP in DMZ for the R2 WAN IP changing by itself. I believe this could be related to the lease time, so can I disable DHCP on the BT Smarthub2 without any issues? I tried this over the weekend but it still dropped connection, so I currently have lease time set to 21 days on BT Smarthub2 and set lease time to 168 hours on R2 (as per advise that I found on here). I'd rather not have this situation where I will lose connection once the lease expires so there surely must be another way to fix this?

3. As detailed in my post above, setting the static IP on R2 still doesn't work...it just drops internet connection completely as soon as the change is made. Should I be entering the R2 WAN IP into static on the WAN section of the R2 as detailed above? Should there be further config in the BT Smarthub or do I need to complete either of the following in the R2 settings: MTU, Mac Address Cloning, DNS Override

4. I still can't get the IPv6 to be recognised on Xbox and your suggestion to "disable IPv6 on the R2 in LAN/WAN, then apply, then enable, apply, reboot" doesn't work. Presumably you meant to reboot the R2? I can confirm that the Xbox shows IPv4 and IPv6 when connected direct to BT Smarthub2 but it is only IPv4 when connected to R2.

5. I haven't changed any other settings such QoS, port forwarding or Geo Filter yet as I still need to test if the XBL party chat issue is still happening with minimal config on the R2. Should there be any port forwarding rules for XBL party chat or other Xbox console or game features?

Share this post


Link to post
Share on other sites

With regards to point 4 I have the same issue , iSP is Sky.  Strange though if you look in device manager it does show IPv6 and 4  IP add but only shows IPv4 in the XBOX

Share this post


Link to post
Share on other sites
21 hours ago, K0NSPIRACY said:

@Netduma Liam @Netduma Fraser

Still having issues getting the BT Smarthub2 to be stable with R2 including the R2 and all my devices intermittently dropping connection from the internet.

A few questions...

1. Does the R2 have a built in firewall? If so, can I disable the firewall on the BT Smarthub2?

2. Still have issues with the reserved IP in DMZ for the R2 WAN IP changing by itself. I believe this could be related to the lease time, so can I disable DHCP on the BT Smarthub2 without any issues? I tried this over the weekend but it still dropped connection, so I currently have lease time set to 21 days on BT Smarthub2 and set lease time to 168 hours on R2 (as per advise that I found on here). I'd rather not have this situation where I will lose connection once the lease expires so there surely must be another way to fix this?

3. As detailed in my post above, setting the static IP on R2 still doesn't work...it just drops internet connection completely as soon as the change is made. Should I be entering the R2 WAN IP into static on the WAN section of the R2 as detailed above? Should there be further config in the BT Smarthub or do I need to complete either of the following in the R2 settings: MTU, Mac Address Cloning, DNS Override

4. I still can't get the IPv6 to be recognised on Xbox and your suggestion to "disable IPv6 on the R2 in LAN/WAN, then apply, then enable, apply, reboot" doesn't work. Presumably you meant to reboot the R2? I can confirm that the Xbox shows IPv4 and IPv6 when connected direct to BT Smarthub2 but it is only IPv4 when connected to R2.

5. I haven't changed any other settings such QoS, port forwarding or Geo Filter yet as I still need to test if the XBL party chat issue is still happening with minimal config on the R2. Should there be any port forwarding rules for XBL party chat or other Xbox console or game features?

1. The R2 does indeed have a firewall, you can disable the one on the BT Smarthub if you'd like!

2. Do you have any devices with reserved IPs? If so, are they losing connection when the drops occur?

3. Usually you can just reserve an address for the R2 on the ISP router's (in this case BT) interface and it should work fine, but there's no harm in also entering it in Network Settings -> WAN on the R2 as well, see if that helps. I don't believe there's any further config you need to do with BT, but I'm not sure myself as I'm not with BT.

4. I would advise rebooting both the R2 and the Xbox to be safe. If it's not too much hassle it may be worth disconnecting the Xbox, deleting it from device manager, re-connecting it and seeing if it recognises IPv6 from the R2.

5. We are currently investigating issues with Party chat, but as far as I'm aware party chat works fine on the R2 with Geo-filter disabled?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...