Jump to content
Sign in to follow this  
kinel

Openwrt

Recommended Posts

I  know nothing about this firmware so i ws looking for some help

I have a tp link WR841N v9  router

And im looking to put the open wrt fw on it

Ki want to try these two algorthyms   fq codel  and sqm cake

It seems my router cant get the new open wrt with lede but im not sure

So does all open wrt firmware  have fq codel and sqm cake

Or is it the firmware with lede in its name

As i have no idea  about this stuff

im not to sure if i downwloaded the  firmware  from there websitr if it has these two algorthyms  in its firmware  

thanks i i hope i made sence

 

Share this post


Link to post
Share on other sites
4 hours ago, kinel said:

 

So does all open wrt firmware  have fq codel and sqm cake

 

 

Yes. Can't answer the rest but that one I know ;)

Share this post


Link to post
Share on other sites

I would highly recommend people to experiment with Openwrt. There are many good features and imo if one wants to really battle buffer bloat that is where I would start. Its always good to have an open mind about other options. There is no one superior firmware. And what was good one day is already being improved the next. 

Zippy.

Share this post


Link to post
Share on other sites
6 hours ago, kinel said:

I  know nothing about this firmware so i ws looking for some help

I have a tp link WR841N v9  router

And im looking to put the open wrt fw on it

Ki want to try these two algorthyms   fq codel  and sqm cake

It seems my router cant get the new open wrt with lede but im not sure

So does all open wrt firmware  have fq codel and sqm cake

Or is it the firmware with lede in its name

As i have no idea  about this stuff

im not to sure if i downwloaded the  firmware  from there websitr if it has these two algorthyms  in its firmware  

thanks i i hope i made sence

 

LEDE merged with OpenWRT .  LEDE kept their forum page but the firmaware's name is OpenWRT. It's excactly the same thing.

I've tested it extensively. I've also tested Gargoyle and DD-WRT. 

My opinion is (that for us gamers) DD-WRT is the king. 

Share this post


Link to post
Share on other sites

Thank you n3cro  zippy  sgt greco

Sgt greco i was hoping you would join in on this topic

As ive seen your name on these forums for a few years a when i was searching info on open  wrt forums

Im pretty sure i seen your name in there  

Does ddwrt have algorthyms  like cake and fq codel

As im pretty sure that if i download open wrt that version dosent have sqm

As what i was reading the tp link wr841n  only has 4mb of ram so its not enough space to run it 

But i new to this so im not sure

 

Share this post


Link to post
Share on other sites
1 hour ago, kinel said:

Thank you n3cro  zippy  sgt greco

Sgt greco i was hoping you would join in on this topic

As ive seen your name on these forums for a few years a when i was searching info on open  wrt forums

Im pretty sure i seen your name in there  

Does ddwrt have algorthyms  like cake and fq codel

As im pretty sure that if i download open wrt that version dosent have sqm

As what i was reading the tp link wr841n  only has 4mb of ram so its not enough space to run it 

But i new to this so im not sure

 

Cake no. It has SFQ, codel and fq_codel.

In OpenWRT, SQM is not embedded in the firmware once you install it. You have to manualy download it as an extra script from the OpenWRT's database.

It's true that OpenWRT is now more resource demanding thus your machine will suffer. 

Also keep in mind that OpenWRT will not provide you (by default) throttling or priority per IP so you have to achieve it with custom comands, something very difficult unless you are good with linux  and networking. I'm not, so I try to avoid it.

Cake is more like a fair share of bandwidth to all devices. But as a gamer I assume you don't care about Bandwidth Fairness and Network Democracy but Strict Dictatorship 😊, right?  It's me and all the other stuff.

For all of the above reasons, I'd suggest DD-WRT. Light and easy. Here is an emulator if you want to play around.

Best of luck

Share this post


Link to post
Share on other sites

I tried installing  the tp link wr841n v9 squashfs factry bin  i did that but now my router i cant acsess the gui after 

Wierd thing is i still have internet

 

I typed in 192.168 .1.1 but cant acsess the gui

I think kve broke it dam

It does mention this in a  page that this might happenand i need it mentions if i have telnet

And ssh acsess  

im lost now  have no clue what do do next

Share this post


Link to post
Share on other sites

Don't worry. Even if you bricked it I think the tftpd method will bring it back. I've done it many times. I suspect you installed the image without the luci interface (GUI). Probably your firmware is installed but you can't access it. Try to ping it and see if it responds. 

As I feel this is going to be a long thread, feel free to DM me with the procedure you followed. If it is OK with the rest of the community keep posting here. 

Share this post


Link to post
Share on other sites

So far what i think is i downloaded the sqaush factory bin

Witch was meant to be for my version v9 

But it does say  it might make the gui not load

 as far as i read it has luci in the image  thats why it wont load the gui because router only has 4mb ram  so its to big image

Atm i ve downloaded putty im just learning how to use tha

t is there any other telnet programe i can use that i can use that i can copy and paste with

Because  i cant with putty 

It seems im goona be tpying a load of code ide rather copy n paste it

So far   i typed root to get into  roter in putty

Then typed in ssh [email protected]

Then i typed in  opkg update

Then i typed in opkg install luci

But it fails here 

So im trying to find out wht to do next  

Cheers for the help

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

You can paste any command in putty. You don't have to write it. Be very careful what you type. Linux is case sensitive. Also in your 

25 minutes ago, kinel said:

opkg  upate

ssh [email protected]

commands there are two spaces in between words and wrong spelling. The IP is wrong too. It won't work. 

Are you sure you have Internet through your TP-LINK? 

Share this post


Link to post
Share on other sites

Yeh im using the internet now

Sorry my bad i was writing it from my ps4 so i always make loads of spelling mistakes

I will edit the post what i actually type  as i write it last time in a rush

I just read how to copy n paste but it dosent work for me on windows  

To copy ctrl and c over the text 

To paste right click  but it wont paste

 

 

 

Share this post


Link to post
Share on other sites

I have same settings as your post still i cant paste

What buttons do you use to paste 

Share this post


Link to post
Share on other sites

For me it dosent work

Cheers for your help 

I think im gonna have to give up on it

As i think im out of my depth 

LOll i cant even paste one of the most simplelist things to do and i cant even do that

Share this post


Link to post
Share on other sites

I found out why i couldnt paste 

Its because i have a gaming mouse and i used that 

I forgot i changed button maping on it a few years ago

 

Share this post


Link to post
Share on other sites

I really dont think im gonna fix it  the more i try nothing works its alot easier now i can copy n paste commands

Share this post


Link to post
Share on other sites

When i am using sqm cake\layercake

My speeds go from around 45mb download  12 mb upload to around 9 mb download  2 mb uplosd

Are you guys expeiriencing  the same kind of speeds drops it leaves me with around quater of my speeds

To me that cant be right

I must be doing somthing wrong in the settings 

All advise welcome

Share this post


Link to post
Share on other sites
18 minutes ago, kinel said:

When i am using sqm cake\layercake

My speeds go from around 45mb download  12 mb upload to around 9 mb download  2 mb uplosd

Are you guys expeiriencing  the same kind of speeds drops it leaves me with around quater of my speeds

To me that cant be right

I must be doing somthing wrong in the settings 

All advise welcome

What are you putting in the download and upload part? Your actual speeds?

Share this post


Link to post
Share on other sites

Im putting in 40000 dl  and 10000 upload

I get my normal speeds  but as soon as i tick enabe sqm thats when the spees drop to a quater

Share this post


Link to post
Share on other sites
11 hours ago, kinel said:

Im putting in 40000 dl  and 10000 upload

I get my normal speeds  but as soon as i tick enabe sqm thats when the spees drop to a quater

Strange. Doesn't happen to me.

You're not going off PS speed test are you coz that is straight up lies. I never get more than 4mb upload on that test lol.

Share this post


Link to post
Share on other sites
12 hours ago, Bert said:

What type of router is it and sort of CPU does it have? CAKE is pretty hardware intensive.

I dont have a clue on the cpu  all i know its a tp link WR841N v9

Btw im using a custum build designed for that model as it has loww specs

8 hours ago, N3CR0 said:

Strange. Doesn't happen to me.

You're not going off PS speed test are you coz that is straight up lies. I never get more than 4mb upload on that test lol.

This is on pc dsl reports

Without sqm enabled i get  my proper speeds speeds 

As soon i click enable i get a quater of them 

I just dont know why  lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...