Jump to content

Recommended Posts

ISP - BT
Previous Setup -Openreach HG612\Vigor 130 > TP-Link > R1 with DumaOS
Current Setup - HH6 > TP-Link
                                     > XR500

So had a pretty stable connection with the Openreach HG612 for the last 14 months, a few disconnections here and there but nothing to serious, was also getting a 53d/18u with a 23ms ping.

After purchasing the Vigor 130, right from the off speed decreased from 53d/18u to 38d/18u but the ping remained the same (23ms), after a few issues speeds dropped further to 33d/15u and the ping increased to 31ms but after a week of line stability, the ping went back down to 21ms but speed remained low., at first I thought my land had be banded by BT as every speed test I did came back at 33d/15u.

Yesterday phoned BT after 3 weeks from when the speed first dropped and they had me replace the Vigor 130 with the HH6, still getting the same speeds as I was before, was pretty much certain that my line had been banded by BT, until that is I saw my line stats on the HH6 router page and noticed that it was 60d/20u.

So today after work,, I unplugged the laptop and plugged it into the TP-Link router and done a speed test which came back as 55d/18u, plugged the laptop into the HH6 and ran another speed test and got the same results 55d/18u, plugged the laptop into the R1 (which was connected directly to the HH6 and not the TP-Link) but now getting 33d/18u, factory reset and rebooted the R1 and still got the same speeds, reverted back to the original firmware, then did a factory reset, reboot and am still getting the same speeds.

Currently have the Netgear XR500 plugged in but am getting the the speeds (approx) 55d/18u.

Could this be failing hardware?

R1 Speed Test

str1.JPG.c6e4c9669ad172a688cb174f3a685286.JPG

R1 Speed test after the factory rest and reboot after downgrading to the original Firmware

str1-2.JPG.ee35aace80d16b79f15bc2853d71dccc.JPG

Speed test when plugged into the TP Link

sttplink.JPG.2460153d91acc52bd1dab1f36cbbfacf.JPG

Share this post


Link to post
Share on other sites

My first thought really is that it could be due to the setup and that devices upstream not connected to the R1 are pulling bandwidth which is drawing it away from the router and so it appears you don't get all your speeds. Also what is your QoS settings?

Share this post


Link to post
Share on other sites

Did try a few things with the QoS, as I've had it set to "When High Priority Traffic Detected", changed this to Never, checked Disable QoS , had both Disable QoS checked and Anti Bufferbloat set to Never, no change in the speed, Bandwidth Allocation's never been touched and have gone as far as pressing the update\reset distribution.

On the original firmware have the bandwidth set to 60 down and 20 up with both sliders at 100% and with either Proactive/Reactive selected, even gone as far as changing the Ethernet cable as well.

Had the same configuration with the Vigor 130 > TP-Link > R1 with DumaOS that I did with the Openreach HG612 > TP-Link > R1 with DumaOS,, the TP link does have bandwidth control enabled but only from the range of 100 to 123, for 6d/3u and the R1 had a static ip ending in .50

The speeds tests are from DSLReports and Speedtest by Ookla

Share this post


Link to post
Share on other sites

Okay so all good there, could you try the Vigor directly to the R1, unplug the TP and see if the speed is the same please? When you do a speed test take a look on System Information, what does the CPU usage say?

Share this post


Link to post
Share on other sites

Sounds like it might be the Vigor causing the problem? Maybe the BT Hub does some extra authentication stuff that the Vigor doesn't?

Share this post


Link to post
Share on other sites

Well had to use PPPoE when I tested it with the Vigor 130 as it's in bridge mode but using DCHP with it plugged into the HH6, the cpu doesn't go past 50%.

Something strange did happen in the last 30 minutes that's back to normal, set the Download Bandwidth in the QoS to 56mb and Upload to 18mb ran a test and download speed never got past 35mb, set both sliders to 40%, download speed stayed at 35mb but upload went down to 6/7mb which is what I was expecting ran 3 tests and out of the 3 outcomes where the sliders where at 40%, all 3 tests came back as 35mb download speed and 6/7mb upload speed, typed in the value for the sliders to be at 100% and got the usual 35mb download speed and 17/18mb upload speed, then typed in the value for the download slider to be at 40% and then the download speed reduced to 20\21mb as it I was expecting from what was shown on from the QoS.

Attached are two logs from within the last 40 minutes

 

 log-1559925836831.txtlog-1559925208002.txtlog-1559924950973.txt

Share this post


Link to post
Share on other sites

UPnP has always been enabled both on the R1 and TP-Link (the TP-Link was connected to the HG612 and Vigor when it was setup for PPPoE), it's even enabled on the BT Hub and XR500 (where I'm able to get the full download speed), only used port forwarding for games.

One test I did do this evening was plug in the Vigor 130, connect it to the TP-Link,  configured the TP-Link for PPPoE so I could get the internet, turned bandwidth control off and was able to get full download speed, then connected the TP-Link to the BT Hub, again configured the TP-Link this time to dynamic IP  (as the BT Hub already does the PPPoE), ran a speed test and again got full download speeds.

Share this post


Link to post
Share on other sites

So on both the R1 and Tp-Link router disabled UPnP and port forwarded port 80, went with the HG612 instead of the Vigor, but got the same results

 

HG612 > R1 results 

hg612-r1.JPG.b3c09f70f50f7c0332650bff17dd5c43.JPG

HG612 > TP-Link results 

hg612-tplink.JPG.7e715940ddc31daf1a0a379e53ed3334.JPG

 

So then went to a familiar setup HG612 > TP-Link > XR500

hg612-tplink-xr500.JPG.207897a1980463b71bf0066c763dbb63.JPG

 

Lost some speed with the HG612 and the TP-Link and the TP-Link and XR500 combo but only 5mb, but still only getting 35mb download with R1 but full upload

Share this post


Link to post
Share on other sites

I'm guessing it's more of a software issue than a hardware one as the same thing has now just happened with the XR500 when I plugged the HG612 into it and now not getting download speeds no more than 42mb on that when I was getting 55/56mb earlier.

So turned off the XR500, plugged the HG612 in, let it settle for 10 minutes, turned the XR500 on, went into setting so could set up the PPPoE, everything got connected, went to DSL reports and speedtest.net, was only getting a download speed of 42mb, upload speed was 16mb (was expecting some loss of speed but not 13mb for download), thought things weren't right, turned the XR500 off and unplugged the HG612, plugged in the HH6 and let it settle for 10 minutes, turned on the XR500, went into setting and turned off the PPPoE, ran a speed test and was still getting 42mb down but upload speed increase back to 18mb. reset the XR500 back to factory settings, ran another speed test and still get 42d/18u.

I've plugged the laptop into the HH6 and Tp-link router and get 56 down and 18 up, even reset both back to factory settings and get the same results.

 

Share this post


Link to post
Share on other sites

So have reset the XR500 again back to factory setting and still seeing the download being limited to 42mb and upload is fine, however did notice that the sync speed is showing what I should be getting

 sync1.thumb.JPG.83d51c2f0f300d8440c7152bcf51fc81.JPG

 

sync2.JPG.f6941b6fbadb547eb0771a8c712197d5.JPG

but the speed test is showing what I am getting which is a loss of 12/13mb

speed.JPG.c6e9cab313305db65813beb30d9bd4cb.JPG

 

Also test the R1 and now the download speed has gone down to 9mb, tested this on a new installation of Firefox and also deleted all the history and cookies in Chrome

Share this post


Link to post
Share on other sites

There's a few factors based on what you've mentioned so far that could be to blame - One is PPPoE, one is the TP Link bandwidth control. Is it possible to disable bandwidth control on your TP Link? That could be messing the DumaOS QoS up. Also just to make sure, you have all devices connected to the Netduma right? QoS won't work properly if there are devices connected elsewhere.

PPPoE could also be to blame - you say you don't have a PPPoE connection, but you also said you "went into setting so could set up the PPPoE". If you have PPPoE enabled that can be a drain on the CPU of the router and is known to cause lower speeds as a result.

Share this post


Link to post
Share on other sites

I've had this set up since I got BT installed in September 2017 and bought the HG612.

Modem > TP-Link > R1\XR500 (bought last year)

The TP-Link's role was to handle not only the PPPoE but to also handle the other household devices, I put a bandwidth control on a range of address between 100 to 120, the speeds in the bandwidth control is 6mb down and 2mb upload, I entered the MAC address of the R1 and give it the ip ending in .42 so it was outside the bandwidth control and got all the bandwidth and it (basically followed This Video).

Everything's been running fine for 20 months, no loss of speed of this magnitude from the R1 or XR500, have had to replace the HG612 with the HH6 but that's only when I've had some issue with my line and BT needed the HH6 in to test my line but no more than 4 occasions.

Then in May 2019 I purchased the Vigor 130 modem and that's when it's all started, and it can all be seen in the OP.

I can disable bandwidth control on the TP Link and plug the laptop in and I get full speeds, I can plug the laptop into the HH6 and can get full speeds, but when I've introduce a new modem in the last 4 weeks, my speeds on the R1 or XR500 have then reduced.

The only times I've used PPPoE on the R1 is when I've been testing over the last 4\5 days, and the only time I've used PPPoE on the XR500 was yesterday when I wanted to check if the HH6 was blocking some ports that should be open (hence the Port Forwarding or Port Triggering? thread).

 

What I'm getting in the R1 logs are whole lot of 

image.thumb.png.2d5361dcdbf355c3263da72890a04e9e.png

 

image.thumb.png.eb3a3b2aab58e28a57f065294124e507.png

image.thumb.png.419d258a06870bfdf5cbde549170c74b.png

Not sure about the XR500 but did get this from one of the logs Sunday, June 09, 2019 22:56:29 [DumaOS] config write 'com.netdumasoftware.qos.settings',

And that 9mb speed I said I was getting in the last post, might have been when testing the R1 as its back to 35mb

Share this post


Link to post
Share on other sites

Well this sounds like something wrong with the new modem... Have you tried setting PPPoE on the modem instead of on the router?

Does the modem have a bridge mode?

I'd ignore the log personally because it's usually just full of red herrings. Lots of the language used (like DDoS and kill) make minor errors sound like a massive deal...

Share this post


Link to post
Share on other sites

Yeah have used PPPoE on the R1 and XR500 and get 35mb download on the  R1, 43mb on the XR500, the modem does have bridge-mode which is enabled,  but I use PPPoE on the TP-Link (with bandwidth control turned off) and get my full download of 56mb down, all 3 still get 18mb upload, so only the download is being throttled, and tested all 3 with nothing else connected.

Also with the HH6, don't need PPPoE enabled and have the same issues,

Also Should note I'm using the Vigor 130 and not the HH6,, and have reset all 3 modems back to factory settings, so its all fresh settings and haven't changed any settings.

 

 

Share this post


Link to post
Share on other sites

Using PPPoE on the router seems to slow it down for some reason. Is there a disadvantage to you having the TP-Link router installed permanently? If you can't put the PPPoE settings on your modem that is.

Share this post


Link to post
Share on other sites

I'm happy to have the TP-Link installed permanently to handle the PPPoE, as I've mentioned the setup's been modem > TP-Link > R1\XR500 and had no download speed issues until I put in the Vigor 130 then got issues with the R1, and then Sunday when I swapped the HH6 out for the HG612, used PPPoE on the XR500, then the download speed decrease.

I've just done a test where I enabled Bandwidth Control on the TP-Link, give the laptop an IP address outside the IP address range setup on the TP-Link (below) 

image.png.a913030af94d4407677f7dc2062b4641.png

And got the following speeds 

image.png.fb7a1c155675901c2e5032c3288bb2fe.png

 

Also gone through the link  http://support.netduma.com/support/solutions/articles/16000076586-dumaos-optimal-settings-guide-maxmimum-bandwidth-speeds

 

Not sure what more I can do and its not just PPPoE that's slowing the download speeds on the R1\XR500, if it's DCHP or PPPoE, Static, the download speeds on the R1\XR500 are the same

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...