Jump to content

double NAT with VPN

Recommended Posts


first I am sorry for my bad English I will try my best. I have a netduma r1 and would like to use it with a VPN. I had no problem with double NAT on my R1 before. Always it was open on my Xbox. My settings are:

* Netduma R1 with v1.03.6j (also test it with Netduma OS)

* connection via PPPoE with a Frtizbox router/modem (I test it with a allnet Modem as well)

* UPnP is active

* plattform I use is Xbox one X

* VPN Express  is used (have any kind of NAT Firewall)

=> reason for using VPN: I have a bad routing offered by my internet provider. VPN helps but with sideeffects mentioned here.

I experiance package lost and double NAT with this setting. With Netduma OS I recived also package lost without VPN connection, so I switch back to the original Firmware. I have tried everything I didn´t find any solution. I have some vids playing Battlefield V, where the netgraph could be seen. It shows massive lost and jitter. Never experiance it before. I didn´t know where the problem is and what course the double NAT.

Thanks and Regards



Link to comment
Share on other sites

  • Administrators

Hi Neo,

  1. How are you measuring packet loss? Is it the in-game measurement?
  2. Are you playing wireless or wired?
  3. What are your bandwidth speeds
  4. With VPN disabled, you do not have packet loss, is this correct?
  5. Have you setup any Port Forwarding rules?
  6. Is UPNP enabled (please make sure it is)?
Link to comment
Share on other sites

Thanks for the fast request.

yes, I have tried different setting. First with Upnp enabled in the Fritz. Then open all Ports manuel and last option was use the netduma as exposed host. Than I switched to PPPoE connection and tried it then. When I use netduma only without VPN then the NAT is open. Just with the VPN connection I have double Nat and package lost.

1. Yes in the Battlefield V and 1 Netgraph settings. That just not a moment, every 30sec it happens.

2. I have connected my xbox via LAN cable

3. 27000 to 32000 k/bit per second upload and 5000 to 6000 k/bit per second

4. Yes thats right.

5. Yes, I tried it in the netduma and Fritzbox. But without the VPN connection the NAT is open. So the VPN connection course the double NAT I guess.

6. Yes, I checked it is marked. I tried to open all Ports by myself but the situation doesn´t changed.

I tried Modem + Netduma setting without the Fritzbox, but I had the same problem. It must be the Netduma + VPN setup which leads to the double NAT and the package lost. I haven´t changed the VPN provider, that would be my next step but I guess it want change the situtation.



Link to comment
Share on other sites

  • Netduma Staff

Hi, welcome to the forum! First off, I'd highly recommend using something different to test your connection. Don't use the Battlefield V netgraph to test it. I'd recommend downloading Pingplotter and testing on a wired PC for jitter / packet loss.

Secondly, since this is a NAT issue it's probably worth going through the usual solutions. I'd recommend staying on DumaOS for this. Try disabling UPnP and Port Forwarding on your modem. Then make sure to try UPnP on your R1, and if it isn't working use Port Forwarding.

If that doesn't work, try putting your R1 in the DMZ of your Modem. If you need a hand doing this just let us know.

Link to comment
Share on other sites

  • 2 weeks later...


sorry it takes my a lot of time to prove it. I have switched back to netduma os. Now, the network test on the Xbox register a wrong MTU. I contact my VPN and ajust the MTU size in the R1. I doesn´t change the situation. At the Xbox I can´t test the connection via Pingplotter so try it with dslreports.com. It shows alot jitter and form time to time the test doesn´t start at all.

I can´t disable the UPNP on the ISP Router because I briged it. I use an PPPOE connection. So I start to test this setting:

1. ISP router (briged) <=> netduma (own connection via PPPOE ) and 2. ISP router (Exposed host) <=> netduma (use ISP router connection via LAN)

I test two szenarios. First with the ISP Router briged and then settig the netduma as exposed host. I get packagelost and a lot jitter. I test it on the xbox with dslreports.com and on pc with DOS console and dslreports.com as a referenz. I have varied all possible UPNP varants on each setting, with same results.

1A. ISP (UPNP disabled, no portforwarding) and netduma (UPNP disabled, no portforwarding)

1B. ISP (UPNP disabled, no portforwarding) and netduma (UPNP enabled, no portforwarding)

1C. ISP (UPNP disabled, no portforwarding) and netduma (UPNP enabled, portforwarding)


2A. ISP (UPNP disabled, no portforwarding) and netduma (UPNP disabled, no portforwarding)

2B. ISP (UPNP disabled, no portforwarding) and netduma (UPNP enabled, no portforwarding)


I contact the ExpressVPN support for some help and they just advice my to test it with diffrent vpn servers. So I try it without positiv result. I fund two no VPN provider cyberghost vpn and surfshark vpn. Cybergost doesn´t support netduma and surfshark vpn couldn´t connet to a vpn. I have contact surfshark vpn because the netduma connects to the vpn and disabled the connection after some seconds. I try to solve the problem with the shark support. After 4 hours we gave up. I not sure what is wrong.

I am not concerned about the dobble nat with the vpn connection but I does not make sense for me. My problem is the bad conneciton. It is not usefull or playable at all. Maybe it is a problem with Fritzbox (router) or my ISP provider but this also don´t make any sense to me. IS HERE ANYONE WHO USE A VPN CONNECTION FOR GAMING AND HAVE POSITV RESULTS OR HAVE TRY IT WITHOUT PROBLEM.



Link to comment
Share on other sites

I did´t know if it is a bug. But after changing the original Firmware to netduma os I couldn´t change or delete portforwarding rules I have made in the orignial firmware. It gave my a skript error. I have to recover the firmware back delete the rules and go back to netduma os. I couldn´t change any rule because of the skript error and to delete all I needed to go back.

Sorry I am not the fan of netduma os I have to be honest here. For my the Qos in the old firmware was much better. Just for the reason that you can change the algorithm in the qos. I didn´t know it is a placebo but it makes a differenz in some games on my connection. Also the network settings where much wider and more ajustable for my purpose. I think it goes the wrong way. It seemed  that with the netduma r1 and the old firmware you can optimize your connection (which is in most cases not the best). Now with netduma os it seemed that you need a good connection at all and the netduma is just a fine tuning like making a porsche car fester insted of making a golf running stable.

Link to comment
Share on other sites

  • Administrators

Thanks for the update -so on the oringal R1 firmware, what is your exact problem? Is it still that you have double NAT only when the VPN is applied? But without the VPN, NAT is open?

I'm not sure what the cause of this would be, really I would think it's down to the VPN provider as I've not heard of this problem before.

How are you measuring the NAT by the way, through thein-game network testing?

Link to comment
Share on other sites

I am a little bit confused. I have explained my problem in the top section of this tread or is there a missaprehension? In general, yes without vpn there is no double NAT, any package lost and jitter in the connection. Express VPN isn´t using any firewall. I am connected with Xbox one X and so the double NAT is detected by the system. The problem is between Xbox, Netduma + ISP Modem/Router and the VPN provider and I try to solve this problem. If I test the connection with PC this isn´t aiming the problem. As I mentioned above with other VPN provieder for example surfshark I had problems to. 

I hope to finde a solution here but if there is any experiance with this problem here, then it doesn´t make sence to invest the time to post. This is waste of your and mine time.

Link to comment
Share on other sites

  • Administrators

Thanks for confirming - I asked you to do this because it was a bit confusing as to whether you had solved the original problem or not.

Unfortunately this is not something we have seen before. It may be the modem, or the Xbox could be confused when going through the NAT test. Or of course the router has a misconfiguration. It is very hard to know.

Are you still having the other issues e.g. with packet loss? I would expect these when going through a VPN, but they should not happen when not using the VPN.

Link to comment
Share on other sites

  • 2 years later...

Have you considered that your ISP can be detecting a VPN (for example port 1194 UDP) and are throttling down your connection? There are a few ISP's that do that in Europe, cheapskates.

If possible try a VPN close to your location which doesnt use the regular ports, for example TCP 443 (usual https port).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...