Jump to content

Recommended Posts

I just received my XR500 and it is setup.

I am running Win 10, I have tried Firefox, Edge and IE and all get a security error when on GeoFilter.

 

Security Error: The operation is insecure.

Share this post


Link to post
Share on other sites

Hi Shane - the cause of this is most likely a firewall / anti-virus running on your PC. 

 

Which firewall  software do you have installed? Could you please try disabling it and then hard refreshing the Geo-filter page (Ctrl + F5) to hard refresh.

 

If this fixes the problem then it means there an issue with your firewall software so we will contact the developers of the firewall software to get them to fix it for you. 

 

Could you also try accessing the Geo-Filter on Google Chrome as well. 

 

Thank you. 

Share this post


Link to post
Share on other sites

Win 10 Pro edition, no extra firewall.

McAfee

And No cookies are being blocked. All Browsers are default settings.

 

Ok, thanks for the update. Could you take a screenshot of your Geo-Filter page, upload it to imgur and post it here. A developer will then take a look to assist further. Thanks.

Share this post


Link to post
Share on other sites

Hi Shane - one of the developers will be in touch with you in this thread today to arrange a 1-1 so we can take a closer look.

 

Please could you download TeamViewer onto your PC. This will allow the dev to view your PC and diagnose the cause.

 

Thanks

Share this post


Link to post
Share on other sites

I am sorry I did not see this until now.

I tried Google Chrome, issue still happened.

 

I disabled McAfee and that seemed to work. I will keep an eye on it but my AV is not going to stay disabled that long.

Share this post


Link to post
Share on other sites

I am sorry I did not see this until now.

 

I tried Google Chrome, issue still happened.

 

I disabled McAfee and that seemed to work. I will keep an eye on it but my AV is not going to stay disabled that long.

 

Great work figuring out the issue. What is the exact McAfee version/software that you're using? If you let us know we can then try to reproduce it and gather information on what exactly causes it to happen. We had the same thing with Bitdefender and they are going to implement a patch on their end to fix it. May be the same on McAfee. 

 

Meanwhile add routerlogin.net to the whitelist of McAfee, does that fix the security error?

Share this post


Link to post
Share on other sites

I just received my XR500 and it is setup.

I am running Win 10, I have tried Firefox, Edge and IE and all get a security error when on GeoFilter.

 

Security Error: The operation is insecure.

I have the same message.

 

In the header next to where it says routerlogin,there is an exclamation point.If you click that it say "your connection to this site not secure"

Share this post


Link to post
Share on other sites

I have the same message.

 

In the header next to where it says routerlogin,there is an exclamation point.If you click that it say "your connection to this site not secure"

 

That's something different fuzzy, it's because you're not using HTTPS to access the interface, what SHANE is getting is an actual error popping up when on the Geo-Filter page.

Share this post


Link to post
Share on other sites
2 hours ago, villejfv said:

I'm also going through the same thing, any fix? I would like a 1 on 1 too

 

 

Hi there - this thread was in the very early days of the router launch, so we would have done a 1-1 to find the cause. I think we can probably fix your problem via the forum. Could you answer these questions / do these steps please:

  1. What model do you have?
  2. Have you always had the error? Or has it only recently occurred? Does it happen all the time now?
  3. Could you take a screenshot of the error?
  4. What happens if you open your browser in incognito mode? Does the error go away?
  5. Do you have any specialist Anti-virus or firewall software running on your PC?

 

Share this post


Link to post
Share on other sites
1 hour ago, villejfv said:

I got the xr 450 and is not secured incognito on or off, i have always had the problem, got totalav running but tried turning it off one time and didn't change anything

 

20181112_170948.jpg

Type in https://routerlogin.net - we recommend doing this in Firefox. There’s an actual bug in Chrome which slows it to a crawl when in https

Share this post


Link to post
Share on other sites
On 11/12/2018 at 11:28 PM, Netduma Admin said:

Type in https://routerlogin.net - we recommend doing this in Firefox. There’s an actual bug in Chrome which slows it to a crawl when in https

If I try to use that URL in Firefox 63.0.1 I get the foillowing
'The owner of www.routerlogin.net has configured their web site improperly. To protect your information from being stolen, Firefox has not connected to this web site.' So thats not good... something is broken, its always done this on any Mac I have used.

 

Share this post


Link to post
Share on other sites
10 hours ago, Killhippie said:

If I try to use that UR in Firefox 63.0.1 I get the foillowing
'The owner of www.routerlogin.net has configured their web site improperly. To protect your information from being stolen, Firefox has not connected to this web site.' So thats not good... something is broken, its always done this on any Mac I have used.

 

I've just checked this and I am getting the same error. Thank you for letting us know. We'll report it to NETGEAR now.

Share this post


Link to post
Share on other sites

are you sure it's not just because it's using a self-signed ssl certificate (still works, but not verified)?

Is there an option when you see that message to go to Advanced, and Confirm security exception and proceed to the website anyway..? Same for chrome.

If it's a real ssl cert it may have just expired (on the actual routerlogin.net domain)

You could try https://192.168.1.1/  and confirm the exception there, it may work.

I tried this in Firefox a while back, it worked, but then it got stuck on https and always wanted to use https with that message when going to 192.168.1.1, I had to disable force https in firefox to get back into it without https.  I previously reported that there is no option in the firmware to tick "Always use SSL connection for remote management" but firefox seems to always want to use ssl after you do it once. Popping a similar message.

It would be nice to always use ssl, but without that message, but true ssl certs cost money, and it seems netgear doesn't want to spend for that, along with fixing all the issues that need to be addressed in a timely manner it seems

Share this post


Link to post
Share on other sites
1 hour ago, xr500user said:

are you sure it's not just because it's using a self-signed ssl certificate (still works, but not verified)?

Is there an option when you see that message to go to Advanced, and Confirm security exception and proceed to the website anyway..? Same for chrome.

If it's a real ssl cert it may have just expired (on the actual routerlogin.net domain)

You could try https://192.168.1.1/  and confirm the exception there, it may work.

I tried this in Firefox a while back, it worked, but then it got stuck on https and always wanted to use https with that message when going to 192.168.1.1, I had to disable force https in firefox to get back into it without https.  I previously reported that there is no option in the firmware to tick "Always use SSL connection for remote management" but firefox seems to always want to use ssl after you do it once. Popping a similar message.

It would be nice to always use ssl, but without that message, but true ssl certs cost money, and it seems netgear doesn't want to spend for that, along with fixing all the issues that need to be addressed in a timely manner it seems

You're right - you can proceed using advanced etc. But I don't believe this should be happening - should be a seamless experience.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×