Jump to content

WireGuard vpn setup


Recommended Posts

Hello, how can i setup a vpn through WireGuard. I use a configuration file with no success. Do i miss something?

Open vpn reduces my speeds a lot.

Thanks in advance!

Link to comment
Share on other sites

  • Administrators
1 hour ago, diafanos said:

Hello, how can i setup a vpn through WireGuard. I use a configuration file with no success. Do i miss something?

Open vpn reduces my speeds a lot.

Thanks in advance!

Who's your VPN provider? Have you downloaded their Wireguard VPN configuration files or are you trying to use the OpenVPN files? If so, unfortunately that won't work.

Link to comment
Share on other sites

28 minutes ago, Netduma Liam said:

Who's your VPN provider? Have you downloaded their Wireguard VPN configuration files or are you trying to use the OpenVPN files? If so, unfortunately that won't work.

vpn provider is SurfShark and i use the wireguard configuration file. If i use the OpenVPN file works but the speeds are too slow.

Link to comment
Share on other sites

  • Administrators
20 minutes ago, diafanos said:

vpn provider is SurfShark and i use the wireguard configuration file. If i use the OpenVPN file works but the speeds are too slow.

OK, can you paste the config file here so we can check it? Make sure you remove the Private key and the public key before posting it though.

Link to comment
Share on other sites

10 minutes ago, Netduma Liam said:

OK, can you paste the config file here so we can check it? Make sure you remove the Private key and the public key before posting it though.

#
# Use this configuration with WireGuard client
#
[Interface]
Address = 10.14.0.2/16
PrivateKey = ------
DNS = 162.252.172.57, 149.154.159.92
[Peer]
PublicKey = ------
AllowedIPs = 0.0.0.0/0
Endpoint = it-rom.prod.surfshark.com:51820
 

Link to comment
Share on other sites

  • Administrators

Try this instead please and see if it works :

[Interface]

Address= 10.14.0.2

PrivateKey= replace with your key

ListenPort =51820

dns = 162.252.172.57,149.154.159.92

 

[Peer]

PublicKey= replace with your key

AllowedIPs =0.0.0.0/0

Endpoint = it-rom.prod.surfshark.com:51820

Link to comment
Share on other sites

I added the device to the VPN Traffic tab. Strange thing: I rebbot the router and it seems that i connected to the server (I test it in "What's My IP Address") but now i have no inernet  🤪🤪🤪

Link to comment
Share on other sites

I tried a speedtest via my ps5 and shows that has internet but it can't connect to Playstation Network.

It fails to show my download speed but it shows my upload speed. how crazy is that...

Link to comment
Share on other sites

  • Administrators

Okay interesting, on the VPN Setup panel click the :menu icon and you should see options for DNS, for IPv4, enter your VPN DNS in there: 

162.252.172.57
149.154.159.92

then apply, and see whether everything then works please.

Link to comment
Share on other sites

Same result. There is room only for 1 DNS(i put the first one).

I reboot and noticed that the router puts the DNS to the IPv6 DNS Server(without dots.) I erase it but still the same... 

Link to comment
Share on other sites

  • Administrators

Given it is working for some websites/services I suspect that others have blocked the VPN IPs and that is why you cannot access the services. Use another server and you'll have a new IP and that may work, otherwise it might be best to try another provider.

Link to comment
Share on other sites

  • Administrators
3 hours ago, faceman469 said:

Surfshark wireguard configuration file isn't working for me either 🫤 was able to use it on a travel router but not my R2. Just keeps saying "no vpn configured

Did you change it to match the template I provided above?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...