Jump to content

COD CW(PC): NAT Type: Strict


Kyusuke39
 Share

Recommended Posts

After following this video on port forwarding and following each step as mentioned, my NAT type is still Strict.
May someone please help me out, I'll actively be checking back on this post to see your replies. 
I'll try to provide as much information I can, thanks in advance.


Modem: Ubee DVW32CB

Router: Netgear Nighthawk XR1000

Download: 250mbps Upload: 25mbps

Settings that I changed in the Netduma 3.0 OS, anything not on the list below was not changed from default.

WAN Setup: NAT Filtering-Open

LAN Setup: Reserved IP Address for Computer

Wireless Setup: Enabled OFDMA for 2.4GHZ & 5GHZ

Wireless Settings: Enabled MU-HIMO

IPV6: Automatic

UPnP: Advertisement Period- 15minutes 

QoS: Traffic Prioritization- Turned off "DumaOS Classified Games"

 

Other

Time Zone: PST

Discord: Kyūsuke#5267 

Strict.png

Ports.png

Ubee Port Fowarding.png

Ubee Options.png

Ubee Firewall.png

Link to comment
Share on other sites

  • Administrators

Hey, welcome to the forum!

First of all, you need to get the XR WAN IP from the System Information page and enter that into the DMZ Host option on the Ubee. That will help you get an open NAT. You're unlikely to need those port forwards as well with the NAT option set to open but you'll definitely need to do the DMZ.

Link to comment
Share on other sites

Okay, I used the XR WAN IP(DHCP) from the System Information page and entered that into the DMZ Host option on the Ubee. Right after applying the settings I checked my NAT Type in game and it was still "Strict". I then restarted my Modem & Router and lo and behold it was "NAT Type: Open" 
I've actually researched before posting this and tried many methods but it never occurred to me was to reset the Modem after changing settings. 
Lesson Learned: Restart Modem and Router after making changes to make sure they went through.

Will my XR WAN IP one day change since it has a DHCP connection type and cause problems with the DMZ Host option on the Ubee?

Now, I have NAT Type: Open when using a LAN/Ethernet cable on my computer. I tried to see what would be my NAT type on a wireless connection and the results were NAT Type: "Moderate" on both 2.4GHZ and 5GHz channels. I also checked the NAT type on Cold War(PS4) and it was also "Moderate". The PS4's "Test my internet connection" said it had a "Type 2" connection. According to the Owner/User of the PS4 Cold War(PS4) had NAT Type: "Open" before when connected to the Modem 2.4GHz and 5GHz channels. I just now tested the Modem channels and they show up as NAT Type: "Moderate".
(PC & PS4) How can I have the NAT type: "Open" while on a wireless connection?

Moderate.png

Link to comment
Share on other sites

  • Administrators

Yes that is possible so on the Ubee I would suggest setting that IP for the XR as static/reserved to prevent that. So just to clarify, one device is getting open and one gets moderate? So it's not specifically linked to being on WiFi? Did you remove those port forwarding rules and instead change NAT from Secured to Open in WAN Settings?

Link to comment
Share on other sites

On the Ubee's "DMZ Host" there is only a box for the IP and a "Apply button". So I'll have to make the WAN IP "static" through the XR1000 OS.

When the PC is the only device playing Cold War and it's on a  LAN/Ethernet Cable connection, then the NAT Type would be "Open".

However if the PC is the only device playing Cold War and it's on a Wifi connection then the NAT Type would be "Moderate".

When the PS4 is the only device playing Cold War and it's on a Wifi and "Type 2" connection then the NAT Type would be "Moderate".

Note: I haven't tested LAN/Ethernet Cable PS4 since realistically that device won't have that type of connection normally.

When the PC & PS4 are playing Cold War at the same time then no matter what kind of connection the devices are on, both will always get a NAT Type: "Moderate"

 

I haven't removed the Port Forwarding rules that I made to the XR1000 OS.

In the WAN setting, I been having NAT Open 👍

Link to comment
Share on other sites

I believe I correctly made the XR1000 WAN IP static through Ubee.
I first gathered the MAC Address by going to "Basic->DHCP" and looking for the MAC Address that was on the same row as the WAN IP.
The went to "Basic->Static Lease" and inputted the MAC Address and WAN IP I gathered earlier and checked off the "Enable" box and clicked "Apply"
I then restarted my Modem and Router.

Note: Sample Images attached 

I removed the port forwarding rules I made in the XR1000 and rebooted the router. 
I tested my NAT Type on Cold War(PC) and it resulted as "Moderate" both on a LAN/Ethernet Cable and WIFI connection.
It's worse than before seeing how before I achieved a NAT Type: "Open" when on a LAN/Ethernet Cable connection on PC whilst being the only one playing Cold War.

MAC WAN.png

Static Lease.png

Link to comment
Share on other sites

Turning off the Ubee's IPV4 &IPV6 Firewall settings and disabling port scan detection didn't change the outcome, since I tested my NAT Type on Cold War(PC) and it resulted as "Moderate" both on a LAN/Ethernet Cable and WIFI connection.

Link to comment
Share on other sites

  • Administrators

Hey,

Could you just double check that UPnP is enabled on the XR1000?

Could you also please confirm that disabling Geo-filter on the XR1000 doesn't have any affect, just so we can rule that out?

Occasionally Geo-filter can block a server that it used to determine your NAT type.

Link to comment
Share on other sites

  • Administrators

That is very odd. Okay take it out of the DMZ and apply a manual port forwarding rule on the Ubee 1-65535 TCP/UDP to the XR and see if that works, reboot the R2 after these changes are done / do it now if you didn't do it after setting the DMZ previously and see if that changes the outcome.

Link to comment
Share on other sites

  • Administrators
12 minutes ago, Kyusuke39 said:

Okay, I will try to do that once I get home.

Do you think Enabling "UPnP Enable" on the Ubee's options would change anything for the better?

Unlikely because it would conflict with the port rule that we're trying to create to pass everything straight onto the router.

Link to comment
Share on other sites

Removed the XR1000 WAN IP from the Ubee's DMZ Feature.
Created a Port Forwarding rule on the Ubee,  IPV4: 1-65535 TCP/UDP to the XR1000's WAN IP
Reset Router and Modem.

Sadly, didn't change the outcome, since I tested my NAT Type on Cold War(PC) and it resulted as "Moderate" both on a LAN/Ethernet Cable and WIFI connection.

The only time I've gotten a NAT Type: Open is when the XR1000 WAN IP is added to the Ubee's DMZ Feature and had the Port Forwarding Rules I created on the XR1000 whilst on Wired connection and being the only one playing COD CW.

If on a WIFI connection or someone else is playing COD CW at the same time, then the NAT Type would result as "Moderate" no mater the connection type.

Link to comment
Share on other sites

Things I've tried independently but to no avail.
XR1000 WAN IP added to the Ubee's DMZ Feature 

Using the XR1000 WAN IP, added Port Forwarding Rules on the Ubee  as seen in the video 

Enabled "UPnP Enable" on the Ubee's Options

Tested the NAT Type whilst on Wired connection and being the only one playing COD CW.
Results: NAT Type: Moderate 

☠️

Link to comment
Share on other sites

I would have to check all devices that are IPv6 capable, for sure the PC is getting a IPv6 address assigned.

I'll try to turn off IPv6, if that doesn't help I'll change it from "Automatic" -> "Forwarding" 

Honestly, it's so odd. I make sure to follow your steps to heart. I hope we come to a resolution soon.

Link to comment
Share on other sites

Why is the duma os so glitchy and buggy? The AX11000 is able to translate NAT effortlessly without having to do all this technical port forwarding, DMZ, Upnp crap. I think the guys at Duma need to go over and talk to the Asus guys to figure out how to make their software run better

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...