Jump to content
Sgt-Greco

Can't make this work. Please help.

Recommended Posts

This is what I'm trying to do:

setup.thumb.jpg.0bc5f450651897445153b519a67923fd.jpg

I believe the pic above is self-explanatory. I am willing to start from scratch to make this puzzle work. If you have any advice  I'd appreciate.

 

Share this post


Link to post
Share on other sites

Hi Fraser, thanks for jumping in. My issues:

a) I can't figure out how to turn off NAT on R1

b) Not sure about DHCP. What device should have DHCP on. Primary router or R1 ?

c) IP addresses. Should all of these devices must be under the same range (192.168.1.x for example) or it doesn't make any difference ?

d) Which device gives an IP on PS4 ?

 

Share this post


Link to post
Share on other sites

Sorry to put my two cents in but you cannot turn off dhcp on the R1 and still have the geofilter work.  If I recall you can disable the congestion control though.  You are going to have to some how place the IP address given to the R1 by the Open Source router into the DMZ of the Open Source router. This should help with any NAT issues but i can't guarantee it.  

Share this post


Link to post
Share on other sites
9 minutes ago, PharmDawgg said:

Sorry to put my two cents in but you cannot turn off dhcp on the R1 and still have the geofilter work.  If I recall you can disable the congestion control though.  You are going to have to some how place the IP address given to the R1 by the Open Source router into the DMZ of the Open Source router. This should help with any NAT issues but i can't guarantee it.  

Exactly. I have tried it an had double NAT. Here is the best workaround I had been prompted to do so far. But this is to much for me as VLAN is involved. My network knowledge is very limited.

I would appreciate if someone could break this down for me.

 

solution.png.411d3b7bc2055a39430e7fa14e40f471.png

Share this post


Link to post
Share on other sites

You likely still have a double NAT as the openwrt router will probably have UPnP enabled so if you disable that it should work. Then to answer your questions:

a) You can't
b) Both
c) Makes no difference, they will be under different ranges 192.168.x.x
d) R1

For VLAN etc I'd recommend looking at the manual or forums for how to do it with that specific router, looks quite complicated for not much benefit in my opinion.

Share this post


Link to post
Share on other sites

You're overcomplicating this. You can't turn off NAT on the R1.

 

You hook it up as you put it in your drawing.

 

Then you go into the first router. You put the IP adress it assigned to your R1 into the DMZ. And that should be all.

 

All other configuration in your first router as per normal.

 

On the R1 just switch off wifi and QoS.

Share this post


Link to post
Share on other sites

OK, everything is set as you explained.

 In my first router I reserved an IP address based on R1's MAC address and put it into the DMZ, then rebooted both. Everything seems fine so far , PS4 goes online, I can connect to the Internet but I can't access R1's web page from my PC. What am I doing wrong?

Share this post


Link to post
Share on other sites
57 minutes ago, Sgt-Greco said:

OK, everything is set as you explained.

 In my first router I reserved an IP address based on R1's MAC address and put it into the DMZ, then rebooted both. Everything seems fine so far , PS4 goes online, I can connect to the Internet but I can't access R1's web page from my PC. What am I doing wrong?

The PC that is directly connected to the R1? I assume it doesn't share the same LAN IP as the OpenWRT?

Share this post


Link to post
Share on other sites
23 minutes ago, Netduma Fraser said:

The PC that is directly connected to the R1? I assume it doesn't share the same LAN IP as the OpenWRT?

Yes, that PC. It is 0.105 while R1 is 0.188

ip.png.9e5fc13487124ada2a5a09dce3aebc1e.png

 

Share this post


Link to post
Share on other sites
27 minutes ago, Netduma Fraser said:

What happens if you try to access either http://r1 or http://dumaos ?

"site can't be reached"

Share this post


Link to post
Share on other sites
8 hours ago, Netduma Fraser said:

If you use Command Prompt and type ipconfig and press enter, what IP is the PC getting and what does it say the gateway is?

The PC gets 192.168.0.105

The Gateway is my main router 192.168.0.1  Here is what the command returned:

gateway.png.c7b0e3915a285d5d63a13a72e2423fac.png

Shouldn't the gateway IP be 0.188 ?

Share this post


Link to post
Share on other sites

If the PC is directly connected to the R1 then it should be getting 88.x and the gateway should be 88.1. It seems to be bypassing the R1 completely, try setting a static IP on the PC for access to the R1:

IP - 192.168.88.105
Subnet - 255.255.255.0
Gateway - 192.168.88.1

and see if you gain access then. If not you will need to do a factory reset on the R1.

Share this post


Link to post
Share on other sites
3 hours ago, Netduma Fraser said:

If the PC is directly connected to the R1 then it should be getting 88.x and the gateway should be 88.1. It seems to be bypassing the R1 completely, try setting a static IP on the PC for access to the R1:

IP - 192.168.88.105
Subnet - 255.255.255.0
Gateway - 192.168.88.1

and see if you gain access then. If not you will need to do a factory reset on the R1.

I have access to R1 page but no connection to the Internet on PC. Network status says WAN IP disconnected. This is reasonable because 88.1 is not the gateway. 192.168 0.1 is. 

Share this post


Link to post
Share on other sites

I have done it.

After numerous factory resets/reboots on both routers I finally connected everything as OP drawing. PS4 and PC take IP from R1, I have access to R1 page and the internet.

The only problem is (as I suspected) I have double NAT (Tracert anything returns two internal IPs). Maybe I should put everything under the same subnet because there is no way I can DMZ an IP on a differnet subnet.

 

Share this post


Link to post
Share on other sites

If modem is bridged and R1 is in DMZ of OpenWRT then you shouldn't have double NAT, turn UPnP off on OpenWRT. Gateway just refers to the router address that device is receiving internet from which would be the R1 IP. Well done for getting it working.

Share this post


Link to post
Share on other sites
5 minutes ago, Netduma Fraser said:

If modem is bridged and R1 is in DMZ of OpenWRT then you shouldn't have double NAT, turn UPnP off on OpenWRT. Gateway just refers to the router address that device is receiving internet from which would be the R1 IP. Well done for getting it working.

Thanks Fraser but I can't DMZ R1. DD-WRT won't let me DMZ an IP outside the 192.168.0.x range. UPnP is already disabled.

dmz.png.2387ca3ab4b9186f03b2a076ae5b5227.png

As I said before I should try to put everything under the same range

Share this post


Link to post
Share on other sites

The bridged modem is a VDSL gateway but in a "passthrough" mode (bridge).

Again thank you so much for your support. Feel free to drop out of the thread at any time, as I know your time is precious.

Here is an updated pic of the setup. Notice how R1 behaves with different IP addresses assigned.

Hope this makes sense.

setup-1.thumb.jpg.728b0037691bfb7440e5b62a74f10d42.jpg

 

 

Share this post


Link to post
Share on other sites

Do you have port forwarding rules on the OpenWRT to make up for UPnP being disabled? That is the only reason I could think why double NAT would be a problem. Did you change the LAN IP on the 0.188 when you received no internet? If so, as you've noticed that wouldn't work.

Share this post


Link to post
Share on other sites

I run a 2 router setup similar to this and i only use upnp. No DMZ or port forwarding needed with my routers and dont have any problems with NAT types etc.

Remember for accessing both router interfaces do it all from the PC connected to the R1 as you wont be able to see the R1s lan IP (192.168.88.1) from the openwrt network.

The R1 should have a 'device' IP address on the the openwrt router (192.168.0.188) and on the R1 itself the LAN IP will be 192.168.88.1. and the WAN IP will be 192.168.0.188.

So looks like you pretty much got it figured out. Try setup without dmz and port forwarding. I cant remember the openwrt settings as mine has been in the cupboard for months but i had mine working fine when it was setup like you have.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...