Jump to content

Recommended Posts

So after our super long thread a couple of weeks ago my issues have once again resurfaced, I even had a BT engineer round (that may have been the cause of the problems before), however speeds are good again now. 43 down 10 up. IPV6 is disabled. My game of choice is fifa 20 at the moment and that's where I am noticing issues.  I removed all the traffic pritisation rules, and only had duma OS classified on, but it was not properly picking up the playstation so set it as a games console which resolved that problem in terms of detection but not for connection. On the modem my SNR margin was 21 DB my line actuation was 11.2 DB. On DSL report I scored 100/100 for a line quality test. 

I've tried everything now it feels like. I also lag on PC games as does my brother, so it's not a fifa issue. Flower i've tried having it on default, PS4 on 50% and 25% but nothing seems to help. Duma is on PPoE connection. Don't know if there are any settings that can be changed on the Bt Hg 612 echolife to improve it. Any suggestions would be appreciated. Network usage was minimal with only me and my brother home, I was on discord and playing fifa, he was on his phone and it was using about 5mbps download. I've tried having all ports to PS4 as high priority but still had problems. I also noticed that having any youtube video on at any quality while playing would cause lag even when home alone so bandwidth is not an issue.

I'm wondering if it's either a problem with 2 things, either the power line adapters (which come from the Netduma) or the duma itself. If either could be an issue then I'd be happy to buy soemthing that may fix it (I can always return it if it doesn't), maybe a Nighthawk router or a mesh wifi system? Any help would be appreciated.

Another thing, what is the benefit of a nighthawk over the R1 if I was going to get one?

Share this post


Link to post
Share on other sites

I think the issue here is PPPoE which will cause QoS to not work effectively (that's something we're working on improving). So what I would suggest is see if you can put another router between the BT hub & the R1 so it can handle PPPoE and pass everything through to the R1 and then QoS should work effectively and resolve those issues. It's not ideal I know. Well the Nighthawks have much more powerful hardware, can handle higher speeds and also their WiFi is much better AC compared to b/g/n on the R1.

Share this post


Link to post
Share on other sites

The only router I’ve got is the bt smart hub 2, I don’t know if that will do as it cannot be placed into modem only mode. Currently it's the Hg612 Modem to the Netduma R1. Would HG612 to smarthub2 to R1 work?

Are there any setting that I can change on the modem to allow either static or DHCP connection?

Share this post


Link to post
Share on other sites

That should be fine actually do modem > smarthub, setup the smart hub with PPPoE - disable its' WiFi and connect the R1 to the smart hub and put that in the DMZ. Can leave the other settings as they are. Then try with the normal QoS settings you would use on the R1 and see if it has improved.

Share this post


Link to post
Share on other sites

So to recap it should be Hg612 Modem > smart hub 2 > R1

Modem = Standard nothing changes here

Smart Hub 2 = Set it up to handle PPPoE, disable WiFi, enter R1 WAN IP into DMZ

R1 = Remove PPPoE details and leave everything else normal

If it's not working after that, reboot everything starting with the modem, wait for it to boot up then hub etc.

Share this post


Link to post
Share on other sites

Yes that’s how it is. I’ll reset the modem settings to factory default. I’ll reboot everything, and have the WAN mode of the R1 in DHCP mode. And I’ll report in a few minutes.

Also from the hub the R1 isn’t on the ip ending 88.1 it’s something else entirely is that normal?

Share this post


Link to post
Share on other sites

Ok, re booted everything several times including my PC. No change. 
I think it may be the smart hub 2 as I can’t seem to configure a PPoE input for it. Should I get a cheapo router from amazon to go in its place? Is there a way I can set it up for the smart hub2 ? I do get a connection when setting R1 to PPoE with the previously used settings in this current configuration (with the smart hub).

If you think a second router would be the only way, could you tell me which one I could get from Curry’s? It’s on my way to work tomorrow so can easily pick one up and return if necessary.

Share this post


Link to post
Share on other sites

The IP to access the R1 would be 88.1 but the WAN IP for it would be different and thats fine. There are no PPPoE settings in WAN Settings? Does it ask if you want to use a login for WAN as that would be it as well. Any cheap router would do, I don't have any specific recommendations but any third party router not provided by the ISP should have PPPoE functionality.

Share this post


Link to post
Share on other sites

R1 has no PPoE settings inputted. WAN is set to DHCP which was the default. On the smart hub there are no WAN settings only a Broadband username and password which doesn’t seem to connect if I put in the standard BT PPoE username and password.

Share this post


Link to post
Share on other sites

Very odd, I got that information from the BT forum to use that in their hub. If the usual information you used worked in the R1 then try and get another router tomorrow and see if it works with that information.

Share this post


Link to post
Share on other sites

Ok new router. Tp link c60. Works with DHCP WAN on R1. I can’t seem to find a way to set the R1 as a static IP on it, but I’ve put the first assigned IP in the DMZ and disabled the firewall and WiFi etc, I’ll monitor to see if it changes, or if there’s a way to manually do it that you know if I can do that. I’ll update tonight how the connection is, I’ll just leave DUMA OS classified as the only thing checked as well as 70% anti bufferbloat when high priority is detected as recommended. I ran a speed test with QOS disabled and I get full speed through the Duma. So hopefully everything will work and I’ll update later (probably about 8-9pm)

Share this post


Link to post
Share on other sites

You can set the static WAN IP on the R1 instead and that will work. Great to hear that, keep us posted. Hopefully now QoS will be able to efficiently eliminate those issues you've been having.

Share this post


Link to post
Share on other sites

Ok the issues are definitely way way reduced. Still ping spikes but much better and not constant lag like before. Found that PS4 needed manual inputting to pick up fifa properly. But after that and removing all rules for overwatch on my brothers PC and just having the pre set running the connection was better. I’m wondering how many packets should be high priority and how many background. At the moment it’s about a 50/50 split.

Would static be preferable over DHCP? The tp link has the ip 192.168.0.1 . The modem is 192.168.1.1 . What would I put in the R1?

I could also try the QOS on the tp link if this (or anything else you suggest I try) doesn’t  seems to fix it to see if it’s the duma that could be the problem.

reducing anti bufferbloat to 60% seemed to help also and having it set to always rather than high priority only.

Any ideas on how to iron out these would be appreciated and I can try them straight away tonight? I could try a factory reset as a last resort if no settings changes help

Share this post


Link to post
Share on other sites

Actually just checked me and my brother were the only ones on internet (phones on data) , we were both playing games and on discord that’s it. Parents were just watching tv, now they’re on their iPads browsing the internet or BBC sport etc. Not YouTube, it’s much worse connection, still a slight improvement on yesterday though.

 

 

Share this post


Link to post
Share on other sites

Sounds like Traffic Prioritization is prioritizing too much. You shouldn't have needed to add the console manually, either have it on DumaOS Classified Games or add it using the console service so remove any custom rules other than this. Background packets should be a lot more than prioritized. Static will just ensure the IP doesn't change and prevent you from needing to update the DMZ if the IP changes, up to you really but won't have an affect on connection other than this.

I would suggest now it's working better that you run through this guide while saturating the connection and try different Anti-Bufferbloat percentages and see what gives you the lowest ping/most stable: http://support.netduma.com/support/solutions/articles/16000074717-how-to-test-your-internet-ping

Share this post


Link to post
Share on other sites

I’ve followed the guide completely, even bought a whole new set of cat6 Ethernet cables, and I’m still having ping issues. That was to google.co.uk with a download on my phone happening, at 2.5 second intervals. I disabled the power line adapters in case they were causing issues and my phone was on the netduma WiFi. I tried anti-bufferbloat on always and went down in increments of 10% down to 30% but I still had spikes up to 40-120ms every 30 seconds or so.  Maybe I should try QOS on the TP-Link pass through router to see if it’s the netduma causing problems? I know it’s not the line now as the engineer came and fixed the problems and the modem is recording the correct speeds, as is a speed test done from the Duma with anti-bufferbloat disabled. I’m at a bit of a loss now. Do you have any ideas?

Share this post


Link to post
Share on other sites

TP link QOS produced slightly worse results than that seen on the Netduma. I'm still unsure on how to proceed from here. My R1 is still under warranty for a couple more months, and I’m thinking there’s a possible hardware issue? I do often see 100% cpu usage so that may be an issue. In terms of prioritisation there was about 2.3mil background download packets and about 200k high priority packets I think over an evening or two. I'm thinking that something is going wrong with this to cause the issues, only Duma classified is enabled. The line is fine and when there’s nothing on it, the ping is rock solid at 9-10ms to google.co.uk.

Another bit of information that may be of use is that devices connected through the power line adapters (which is coming from netduma) appear offline on device manager even in use (I think anyway). However the ping plotter tests were done on the netduma WiFi with the power line adapter disabled. I’m honestly leaning towards a hardware fault and returning it and replacing it with the Xr 500 and signal booster as the all in one package should allow for effective QOS and capable and reliable hardware, with the greatness of duma OS (it’s soooooo good)

Share this post


Link to post
Share on other sites

Could you try setting Anti-Bufferbloat to Always and turning off DumaOS Classified Games and any other rules you have?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...