Jump to content
SaintFinnigan

Getting stuck on same peer host/dedicated host.

Recommended Posts

Hey all, 

I am absolutely struggling to get my geo-filter to deny connects and keep them denied. I’ve done that will several, left them on my black list, and I still connect to them. I have the filter set to 800 miles, and I sometimes see the LA server. It only rarely connects there, but even when I do it’s still 50-70ms ping. 

So, if you need more info, let me know. Currently trying to figure out a way to find a wildly great host and keep my ping down to 20-30ms for every game, but it always picks either another crappy 70-90ms one, or one I’ve already denied for being a turd. 

 

Love your product so far, but there’s just a bit of tidying up my settings to really be able to be on a level playing field with other players. So far, it’s not horrible being truly connected the same/better than others, but it’s only about 5 out of 10 games. I’d like to make that number better so I can actually become decent at the game based on the talent I have (I think hahaha) and not because I’m pinging behind some of these guys always at 10-20ms ping. I’d like my streaming content to be a lot more interesting to watch. 

 

Thanks all! 

SaintFinngan. 

 

P.S. Check me out on Facebook when I get this fixed :D 

Share this post


Link to post
Share on other sites

Hi there and welcome to the forum! A couple of questions for you:

  1. Which router do you have?
  2. What firmware version are you on? Click the 'i' icon in the top right corner

Finally, I think there is a great solution for you here which is to use Ping Assist as a Ping Filter. This will guarantee the server for your game is below your desired ping. See the bottom half of this guide on how to set this up:

http://support.netduma.com/en/support/solutions/articles/16000087579--dumaos-optimal-settings-guide-ping-assist

Let us know how you get on after trying this!

Share this post


Link to post
Share on other sites

Hello,

Thank you for the quick reply! 

I have the Netgear XR500. My firmware is currently: (photo attached) 

I’ve also tried using the ping assist as a direct connection method. I’ve dropped the pin in the middle of the ocean and tried to force it to choose a host that way, but I still connect to the same host I’ve alrzady denied. Any other tips or hints? 

CD81ECD0-DEB5-44F1-A1B2-47A1BDF93223.jpeg

Share this post


Link to post
Share on other sites

Are you certain it is the exact same server/host? There are many servers located in the same place, if it is in the same place but not the exact same ID then it'll be a different server and you'll need to deny that as well.

Share this post


Link to post
Share on other sites

I’ve just realized I’ve sent the wrong photo, correct one attached. 

I name the denied hosts each time I deny them, so I can clearly tell when I have connected to them again. But when I then reconnect to the same name host, I can’t “detach” from it. It won’t search for a new, better host/server. So I’m at a loss. Spent $300 on this and it’s not really helping my connectivity any more than random chance was. 

 

_SF

E2FB8FFB-68A6-409C-8438-89527C8BB491.jpeg

Share this post


Link to post
Share on other sites

Okay what I would suggest is removing all the hosts from deny/allow and redoing them. There was a case where they didn't properly apply until they were all removed first. Hopefully that'll be the same for you but the issue is being looked into.

Share this post


Link to post
Share on other sites

Thanks for the video, I don't think that one is actually your server. I think the dedicated server on the left is your actual game server. I would ignore the one you're seeing as I think thats a routing IP that is showing up for some reason. Block the actual server and once you've disconnected, wait for 2 minutes and see if you don't get it again.

Share this post


Link to post
Share on other sites

Hello again, 

I have tried multiple times to deny that host, and even when I am not in or searching for a match it still gets stuck on that person. Denied several times and it like auto-picks it every time I login to the geofilter. 

Is there a way I can manually “force” connect to the dedicated server with auto-ping off and just manually pinging it? Almost, effectively, always connecting to that dedicated server, and not auto-pinging that on in Nebraska/Oklahoma?

Thank you, _SF 

Also, is there a way for me to actually deny bad hosts/servers? My auto ping always picks the SAME host, and when I hit deny it doesn’t actually strike through that icon, it thinks for a second and just reconnects to that same OK/NE thing. That icon is always 2x as big as the other icons. I thought once I denied a connection it would strike through that icon, and then pick another host that I could either allow or deny if I like the ping. 

Can I actually “force” the geofilter to always connect to a preferred server (or host if they’re online) every time I play? 

Sometimes when I first login for the day of my streaming I can turn off auto-ping and ping the LA server itself and my ping is AMAZING at 30-45 ping, BUT that only works for about 3-4 games and then the geofilter freezes and pretty much crashes my Firefox browser. I need so much help. I don’t have any idea why that NE/OK, larger icon always locks on to my Xbox. And I say that because even sitting at my home screen on it, when I check the geofilter it’s already stuck on my auto-ping window. 

Please help :( I spent $300 on this router for a last-ditched effort to drastically lower my ping from always jumping from 80/90 to spikes of 120-130, then with the luck of the draw getting a game or two of 40-50ms ping (WHICH I LOVE BEING AT, it’s always a great playing match!!) How in the world can I make this router/geofilter ALWAYS keep me in the 40-50ms range for all my matches? 

Sorry for the lengthy post. I am just so frustrated I nearly, almost return this router and give up streaming and playing any multi-player games. 

Thank you, 

_SF

Share this post


Link to post
Share on other sites

Just disable Auto Ping and you can ping whichever server you want, the ping method doesn't decide what game you get into. The way to force is to have auto ping disabled with strict mode enabled and the radius over the location of the server and the distance small enough that it doesn't encompass any other servers.

Denying won't cut the connection immediately. The connection has to be dead for 2 minutes then you can research and it shouldn't allow you to rejoin the server.

I'd recommend you use the Chrome browser as it's the most optimised for the interface and see if that issue goes away. Spiking connection is usually indicative of local congestion issues so you need to have the correct QoS settings as well and use that in conjunction with the Geo-Filter for the best connection possible.

Share this post


Link to post
Share on other sites

As I mentioned before that doesn't appear to be a dedicated/game server, this is backed up by the fact that you have it even when you're not searching/in a game, I would hazard a guess that something else is happening on the console in the background which is why auto ping thinks that is the game and it is required to be connected, it's likely whitelisted on our cloud which is why it can't be denied/keeps being connected to. Can you please provide a screenshot of the Geo-Filter when you're actually in a game please?

Share this post


Link to post
Share on other sites

That's when you're actually in game playing? Was that with spectating mode on/off? Do you have ping assist on/off? They are appear to be peers for some reason which indicates your cloud isn't up to date properly, could you flush the cloud please and then try again

Share this post


Link to post
Share on other sites

Yes, while I’m in the staging area for Blackout. Spectating was off, filtering mode was on. Auto-ping was off as I was trying to directly ping the LA dedicated server, but it wouldn’t stay. 

I will flush the cloud and send a video of what pops up. 

Share this post


Link to post
Share on other sites

Is Ping Assist set to 0ms in that video? If so, I think the problem is it's not disabling even when set to 0ms.

There's a solution here, downgrade back to the previous version and then upgrade back again. 

Here's the previous firmware: https://kb.netgear.com/000060127/XR500-Firmware-Version-2-3-2-32

Please install that, then once it has installed, you can reinstall the latest one: http://www.downloads.netgear.com/files/GDC/XR500/XR500-V2.3.2.40.zip

Make sure Ping Assist is set to 0ms when you retest. Thanks.

Share this post


Link to post
Share on other sites

I did all that and this still pops up on auto ping. 

I deleted my allow/deny list and re added my Xbox as a geofilter. Don’t know what else to do. 

A05FDF07-6833-412B-8723-E056D96518F8.jpeg

Share this post


Link to post
Share on other sites

Ping assist is still turned on. The reason this one got through is probably also because fast search is enabled. In this mode, the router won't be as accurate at detecting pings before it connects.

Please disable Ping Assist (set to 0) and also disable Fast Search

 

Share this post


Link to post
Share on other sites
On 5/8/2019 at 11:33 AM, Netduma Alex said:

Disable Fast Search

 

Please do this. It's the likely cause of your problems

Share this post


Link to post
Share on other sites

Look, something else is clearly wrong here. I’ve deleted and re added my Xbox to the geofilter each time you’ve asked me to change any settings. I’ve tried manually pinging the dedicated host that is around 28-40ms. Sometimes I can grab it, but only as if by chance and not my actual doing. What else is there that I can change that will allow me to connect to that host every time, for every game? 

Now that I disabled fast search, I am lodged into games of 100-140ms ping every game. 

Share this post


Link to post
Share on other sites

Do not pay attention to the in game ping, that includes things like processing delay etc which is present in every game you play. You can't do anything about those factors, only the ping to the actual server which is what you can control, you're getting 30ms to that server which is a great ping. 

Ping Assist still seems to be active, did you wait for the map to be completely clear after disabling it before retesting? Otherwise those connections will still be active. Allowing the server via the allow button just allows you to connect to it if your regular Geo-Filter settings would block it, it doesn't mean you'll connect to it every time. The only way to force a server is to have the radius small enough that it only has that server within it (but even then there are multiple servers clustered in one location) with strict on and ping assist off completely. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...