Jump to content

HomePod Mini Not Working With HomeKit Devices


Recommended Posts

Hi,

I'm having an issue at the moment where my HomePod Mini's won't speak to any other HomeKit devices. I can control these fine from my phone. I followed all the steps in this thread with no success. It's been extremely frustrating to debug the issue. There's nothing appearing in the logs when a command fails so it's hard to debug what's causing the issue. Not sure if anyone else has had similar issues and resolved them? Can find countless threads online around HomeKit issues and no troubleshooting steps have worked so far. Been at this for 3 weeks including numerous calls to Apple with no luck still. Any help would be much appreciated.

Router: Netgear XR1000

Key Settings:
IGMP Proxying (Doesn't work enabled or disabled)
NAT (secured)
Implicit Beamforming, MU-MIMO, Smart Connect and AX all disabled.
IPv6 Disabled.
5Ghz mode set to 2165mbps.
2.5Ghz mode set to 400mbps.
20/40 Mhz Coexistence enabled.

UPnP seems to have a bug where it shows as disabled, however, if I turn it on, click apply, it just reloads the page with it disabled rather than applying the setting. I figure it must be enabled as all other devices are connecting and working without issues. I tried resetting the router back to factory and still doesn't work. Not sure why?

Edit: Applying UPnP with the box unticked did apply the setting so I reapplied it ticked. It still shows unticked in the setting but assume it's still on. I saw in the thread I linked that changing the Advertisement period or time to live can work. Is this recommended? If so, any recommended settings for that?

 

Link to comment
Share on other sites

  • Administrators

There is a bug with the UPnP check box but it is actually enabled by default and will be working in the background.

I would say to switch NAT to Open in WAN Settings as that will relax the firewall, also toggle SIP ALG as well, see if either of those make any difference.

Link to comment
Share on other sites

@Netduma Fraser I switched NAT to open, didn't make a difference. Turned off SIP ALG with NAT open and it works - Siri says its taking awhile to respond but works after 15 secs or so which is a big improvement! Thanks very much for that. I'll try rebooting the router to see if that helps - notice the change of settings didn't do that. What impact does turning off SIP ALG cause? Could it cause issues with other devices that I'll need to test? Conscious that people are working from home so don't want to affect video conferencing stability, etc

Link to comment
Share on other sites

  • Administrators

Ahh that's great to hear! Basically SIP ALG was brought in quickly when VoIP started to take off to help it pass through the firewall but it can actually corrupt packets and so some devices/applications work better with it disabled. You should not notice any issues with it disabled, in general it's recommended to disable it. 

Link to comment
Share on other sites

@Netduma Fraser Weirdly, after the reboot, the HomePod couldn't find HomeKit accessories again. Now that I've enabled SIP ALG again, it's worked ok for a few minutes but stopped working again after that. Any ideas?

Link to comment
Share on other sites

  • Administrators

If you disable it again does it work? You could try making a guest WiFi network for the devices and enable the option there to allow them to communicate with each other

Link to comment
Share on other sites

I disabled it and it's not working still. Whatever happened with those settings only seemed to work for a few mins which is odd. Why would it work on a Guest Network and not on my current network? I share the network with several people who have devices, I don't think I'll be able to get everyone to agree to switch all HomeKit devices to a Guest network unfortunately.

 

Edit: Disabled IGMP Proxying - lights taking awhile to respond but now working. Will try again in a few mins to see if they become unresponsive again.

Edit 2: Yep, they've become unresponsive again after a few mins. Feels like the router is definitely blocking something?

Link to comment
Share on other sites

One other issue I'm seeing is that a lot of devices on my network have multiple IP addresses listed. I've turned off 'Private IP' on all my Apple devices so not sure why this is. In the meantime, I'll enable debug logging to see if there's anything I can find when making commands to see if there's anything obvious

Link to comment
Share on other sites

  • Administrators

As the Guest Network specifically has that option for you to enable there is a good chance it would work but understandably it's not ideal. Are you using Armor/Adblocker at all? You could try making a Traffic Controller rule and allowing ALL traffic to those devices. Give the devices a static/reserved IP in LAN Settings, that could be part of the issue if they're trying to communicate with out of date IPs. Once you've set them restart the router.

Link to comment
Share on other sites

@Netduma Fraser No I'm not running Armor or Adblocker. Static IP's are a good shout, I'll try setting that up and see how it goes with Traffic Controller rules. Thanks very much for that!

Link to comment
Share on other sites

Just tried setting a Traffic Controller rule - seemed to stop my HomePods getting an internet connection even though I set everything to allow. I went to add the Devices to 'Traffic Prioritisation' just to experiment and got this error back, is this a known bug as well?

image.png.69b0bf6935fd5cc7b719648e01120fb2.png

Link to comment
Share on other sites

  • Administrators

Could you provide a screenshot of the Traffic Controller page?

I've never seen that error before, what was the rule that you tried to make exactly?

Link to comment
Share on other sites

Just noticed the error isn't occurring any more. I was just clicking on 'Add Device' in the QoS page for Traffic Prioritisation when it brought up that error rather than setting any rules.

Traffic Controller rules below:

image.thumb.png.534d148f8633fef43871291955a365d0.png

Traffic Controller Page

 

Link to comment
Share on other sites

@Netduma Fraser Thanks for that, I was aware of the update but I've seen people quite a few posts highlighting various issues with it so Im waiting for the next update in the hopes that those issues are ironed out. Thanks for your help so far, I'll keep tinkering in the meantime and see if anything can be sorted

Link to comment
Share on other sites

@Netduma Fraser If I did upgrade the firmware and ran into issues, is there any risk with rolling back to a previous version? Also, the beta firmware that you had to allow multiple xbox's on the same network with an open NAT, has this been rolled into any official releases?

Link to comment
Share on other sites

  • Administrators
38 minutes ago, TheJam said:

@Netduma Fraser If I did upgrade the firmware and ran into issues, is there any risk with rolling back to a previous version? Also, the beta firmware that you had to allow multiple xbox's on the same network with an open NAT, has this been rolled into any official releases?

You can absolutely do that, would suggest doing a factory reset if you do end up downgrading. I'm not quite sure, their change logs are quite vague, it should be in there.

Link to comment
Share on other sites

21 hours ago, Netduma Fraser said:

You can absolutely do that, would suggest doing a factory reset if you do end up downgrading. I'm not quite sure, their change logs are quite vague, it should be in there.

Thanks very much. I did upgrade last night, no issues observed which is good. I did panic for a minute as the reset button on the router wouldn't work - had to reboot it and try again which was successful. The UI took a very long time to load up afterwards, a few minutes at least for it to download all the .js files but after that it was fine.

Got to the bottom of the HomeKit issue which there were 2 things at play. One was that the HomeKit hub kept changing to a HomePod mini rather than the Apple TV. Apple TV performs flawlessly with HomeKit functionality, the HomePod's are a nightmare but it's assigns the Hub automatically which is a real pain. No functionality I can see to stop the HomePod's being assigned as a hub.


Other issue was permissions related; even though I was invited to the Home in the HomeKit app, there seems to have been a bug or something that went wrong at some time. After I was deleted and re-added, it worked again. Thanks very much for your help though @Netduma Fraser, it's much appreciated. 

Next step is making sure my Nest Camera's have consistent quality. I noticed in QoS there's no category for Camera's in there or would it fall under something like VoIP or Live-streaming? I'll need to find the ports it needs to give it traffic prioritisation if there are no categories for it.

Link to comment
Share on other sites

  • Administrators

Well done on getting it sorted! I don't believe we have cameras like that specifically categorized at all so you would just need to prioritize with ports and allocate by device if needed but Share Excess on should make sure it gets the bandwidth it needs.

Link to comment
Share on other sites

7 hours ago, Netduma Fraser said:

Well done on getting it sorted! I don't believe we have cameras like that specifically categorized at all so you would just need to prioritize with ports and allocate by device if needed but Share Excess on should make sure it gets the bandwidth it needs.

Cheers, although I spoke to soon because I woke up the next day with the issue again :( Back to the drawing board

Link to comment
Share on other sites

20 hours ago, Netduma Fraser said:

Ahh that's annoying, it may seem like a simple option and you may have already tried it but does signing out and in of iCloud help at all?

I did try that and it didn't work, I also tried deleting the Home and setting everything up from scratch which didn't work either. Currently doing research on how Bonjour/ mDNS works along with all individual settings for the XR1000 to see if anything clicks. 

Link to comment
Share on other sites

56 minutes ago, Netduma Fraser said:

You do some research, I'll do some research and we'll meet back here and hopefully one of us will find a solution!

Cheers! I turned off 'Enable 20/40 MHz Coexistence'. I was wondering if it's switching between 20/40MHz and causing issues with HomeKit. My HomeKit devices are now showing responsive around 12 hours later (might be some Cloud sync issues getting resolved on Apple's side 🤷‍♂️). Is there a way to force the 2.4GHz band to 20 MHz?

Noticed Apple recommends that as part of their docs here: https://support.apple.com/en-gb/HT202068#channelwidth

Is there a way in the XR1000 to change DHCP Lease Time? Curious if that might be a factor as well, might explain why it had worked in the evening, then stop when I woke up in the morning depending on how long or if it renews at a given interval?

Link to comment
Share on other sites

  • Administrators

Well done! I believe by disabling the option it will use 20MHz by default, there are no other options relating to this that I am aware of. 

No there isn't but if you assign static/reserved IPs outside the DHCP range and that is an issue then it will prevent that happening.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...