Jump to content

Nord VPN Not Connecting


Recommended Posts

I'm trying to connect to Nord VPN for the first time and it doesn't want to connect.

I am on Firmware version R1 2.1.3.29.

This is the log shown on the VPN page

Mon May 31 19:37:31 2021 OpenVPN 2.3.4 mips-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Nov  4 2018
Mon May 31 19:37:31 2021 library versions: OpenSSL 1.0.1h 5 Jun 2014, LZO 2.06
Mon May 31 19:37:31 2021 WARNING: --ping should normally be used with --ping-restart or --ping-exit
Mon May 31 19:37:31 2021 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Mon May 31 19:37:31 2021 Control Channel Authentication: tls-auth using INLINE static key file
Mon May 31 19:37:31 2021 Outgoing Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Mon May 31 19:37:31 2021 Incoming Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Mon May 31 19:37:31 2021 Socket Buffers: R=[163840->131072] S=[163840->131072]
Mon May 31 19:37:31 2021 UDPv4 link local: [undef]
Mon May 31 19:37:31 2021 UDPv4 link remote: [AF_INET]194.35.233.51:1194
Mon May 31 19:37:31 2021 TLS: Initial packet from [AF_INET]194.35.233.51:1194, sid=b0ac8bf9 e0cc872f
Mon May 31 19:37:31 2021 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Mon May 31 19:38:31 2021 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon May 31 19:38:31 2021 TLS Error: TLS handshake failed
Mon May 31 19:38:31 2021 SIGUSR1[soft,tls-error] received, process restarting
Mon May 31 19:38:31 2021 Restart pause, 2 second(s)
Mon May 31 19:38:33 2021 WARNING: --ping should normally be used with --ping-restart or --ping-exit
Mon May 31 19:38:33 2021 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Mon May 31 19:38:33 2021 Socket Buffers: R=[163840->131072] S=[163840->131072]
Mon May 31 19:38:33 2021 UDPv4 link local: [undef]
Mon May 31 19:38:33 2021 UDPv4 link remote: [AF_INET]194.35.233.51:1194
Mon May 31 19:38:33 2021 TLS: Initial packet from [AF_INET]194.35.233.51:1194, sid=c7dc19f0 2936e08a
Mon May 31 19:39:33 2021 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon May 31 19:39:33 2021 TLS Error: TLS handshake failed
Mon May 31 19:39:33 2021 SIGUSR1[soft,tls-error] received, process restarting
Mon May 31 19:39:33 2021 Restart pause, 2 second(s)
Mon May 31 19:39:35 2021 WARNING: --ping should normally be used with --ping-restart or --ping-exit
Mon May 31 19:39:35 2021 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Mon May 31 19:39:35 2021 Socket Buffers: R=[163840->131072] S=[163840->131072]
Mon May 31 19:39:35 2021 UDPv4 link local: [undef]
Mon May 31 19:39:35 2021 UDPv4 link remote: [AF_INET]194.35.233.51:1194
Mon May 31 19:39:35 2021 TLS: Initial packet from [AF_INET]194.35.233.51:1194, sid=40fd7192 492067a1
Mon May 31 19:40:35 2021 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon May 31 19:40:35 2021 TLS Error: TLS handshake failed
Mon May 31 19:40:35 2021 SIGUSR1[soft,tls-error] received, process restarting
Mon May 31 19:40:35 2021 Restart pause, 2 second(s)
Mon May 31 19:40:37 2021 WARNING: --ping should normally be used with --ping-restart or --ping-exit
Mon May 31 19:40:37 2021 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Mon May 31 19:40:37 2021 Socket Buffers: R=[163840->131072] S=[163840->131072]
Mon May 31 19:40:37 2021 UDPv4 link local: [undef]
Mon May 31 19:40:37 2021 UDPv4 link remote: [AF_INET]194.35.233.51:1194
Mon May 31 19:40:37 2021 TLS: Initial packet from [AF_INET]194.35.233.51:1194, sid=41bb860b 493954d9

This is the configuration for uk2091.nordvpn.com

I have also tried TCP as well as other server regions, but none of them will connect.

Link to comment
Share on other sites

I thought I provided it in the initial post, but it doesn't appear to be there.

I have attached the ovpn being used to connect.

This is the current Log shown in Hybrid VPN

Wed Jun  2 07:25:56 2021 OpenVPN 2.3.4 mips-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Nov  4 2018
Wed Jun  2 07:25:56 2021 library versions: OpenSSL 1.0.1h 5 Jun 2014, LZO 2.06
Wed Jun  2 07:25:56 2021 WARNING: --ping should normally be used with --ping-restart or --ping-exit
Wed Jun  2 07:25:56 2021 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Wed Jun  2 07:25:56 2021 Control Channel Authentication: tls-auth using INLINE static key file
Wed Jun  2 07:25:56 2021 Outgoing Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Wed Jun  2 07:25:56 2021 Incoming Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Wed Jun  2 07:25:56 2021 Socket Buffers: R=[163840->131072] S=[163840->131072]
Wed Jun  2 07:25:56 2021 UDPv4 link local: [undef]
Wed Jun  2 07:25:56 2021 UDPv4 link remote: [AF_INET]194.35.233.51:1194
Wed Jun  2 07:25:56 2021 TLS: Initial packet from [AF_INET]194.35.233.51:1194, sid=2fd9315d 79ce13d3
Wed Jun  2 07:25:56 2021 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Wed Jun  2 07:26:56 2021 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Wed Jun  2 07:26:56 2021 TLS Error: TLS handshake failed
Wed Jun  2 07:26:56 2021 SIGUSR1[soft,tls-error] received, process restarting
Wed Jun  2 07:26:56 2021 Restart pause, 2 second(s)
Wed Jun  2 07:26:58 2021 WARNING: --ping should normally be used with --ping-restart or --ping-exit
Wed Jun  2 07:26:58 2021 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Wed Jun  2 07:26:58 2021 Socket Buffers: R=[163840->131072] S=[163840->131072]
Wed Jun  2 07:26:58 2021 UDPv4 link local: [undef]
Wed Jun  2 07:26:58 2021 UDPv4 link remote: [AF_INET]194.35.233.51:1194
Wed Jun  2 07:26:58 2021 TLS: Initial packet from [AF_INET]194.35.233.51:1194, sid=abec0f10 48ed8cbf

 

uk2091.nordvpn.com.udp1194.ovpn

Link to comment
Share on other sites

Just in case I notice a couple of month ago that when you setup a manual connection to the VPN Nord lices you to use a pre-generated username and password that they assign to your account. This can be found by going to the site https://my.nordaccount.com/dashboard/nordvpn/

On the bottom of the page under advanced configuration you will find "Service Credentials" (manual setup).

I configured my VPN connection on the DumaOS using these credentials and not my standard username/password. 

If you move the mouse over the i (information button) it states these credentials are to be used form manual set ups on routers.

Hope this helps and please not that the username is nothing compared to the normail username. It looks to be over 22 random characters or more.

Nord.jpg

Link to comment
Share on other sites

8 hours ago, Netduma Liam said:

OK thank you, are you seeing the same issue with all ovpn files from Nord? Could you perhaps try a different one and see if you're getting the same issue?

On 5/31/2021 at 8:56 PM, Mario Vale said:

I have also tried TCP as well as other server regions, but none of them will connect.

Yes I tried a few different ones with both UDP and TCP and nothing worked.

1 hour ago, Nuyorrican said:

Just in case I notice a couple of month ago that when you setup a manual connection to the VPN Nord lices you to use a pre-generated username and password that they assign to your account. This can be found by going to the site https://my.nordaccount.com/dashboard/nordvpn/

On the bottom of the page under advanced configuration you will find "Service Credentials" (manual setup).

I configured my VPN connection on the DumaOS using these credentials and not my standard username/password. 

If you move the mouse over the i (information button) it states these credentials are to be used form manual set ups on routers.

Hope this helps and please not that the username is nothing compared to the normail username. It looks to be over 22 random characters or more.

Nord.jpg

21 hours ago, Mario Vale said:

All it ever says is "Status" "connecting" and yes the credentials are correct, they are copied directly from the Nord VPN configuration page.

Yes, these are the credentials.

Link to comment
Share on other sites

  • Administrators
5 minutes ago, Mario Vale said:

I'll get right on that, I think I saw a bit saying to contact them if there are issues connecting, was just hoping it was me doing something stupid on the router and not a deeper issue.

Let us know how you get on! I don't think you've done anything wrong!

Link to comment
Share on other sites

This is what they said, they are unable to support it.

Quote

I see that your router is using OpenVPN 2.3.4 version. Recently, most NordVPN servers were upgraded to use a newer version of OpenVPN. To be specific, your router needs OpenVPN 2.4 version support.

Therefore, my suggestion would be to upgrade your  router firmware to a newer one. 

Otherwise, there’s nothing much to be done. The only alternative would be to have NordVPN setup on compatible devices (phones, computers, tablets, etc.).

Does the latest test firmware support OVPN 2.4?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...