Jump to content

Wireless devices not obeying "Always" congestion control

Recommended Posts

Hello I have a XR1000 running firmware  I have upgrade to this version and did a factory settings reset of the device.

My maximum internet speeds have been set properly in the device at 460Mbps/24Mbps.

I have set congestion control to "Always" and have download set to 322mbps(70%) and upload set to 10.1mbps(42%).

When I run a speed test from a Wired LAN computer, the computer will obey the congestion control rule properly.  

However, when I run a speed test from a Wireless device, it will not obey the set Upload congestion control rule and will use all 24Mbps of the upload speed and cause buffer-bloat on the network.  I have tested this from an IPhone 8 and a Dell laptop.  Both devices support WMM QoS.  Both devices are connected to the 2.4Ghz band and are identified properly in the DUMA Device Manger (Phone and laptop)  

Wireless settings are set at default except for setting a SSID and password.

Thank you for your support.

Link to comment
Share on other sites

I do not have IPv6, VLAN, or PPPoE enabled. 

I disabled QoS entirely and ran speed tests from both Wired and Wireless devices.  Disabling QoS allowed both Wired and Wireless devices on the network to get full maximum internet speeds as expected.

After Enabling QoS back on, Wired devices obeyed the congestion rules set at 70%/42%, but Wireless devices did not.  

Can anyone verify that congestion control should work for wireless devices on the XR1000 and that this is an isolated incident?

Thank you for your support Fraser   

Link to comment
Share on other sites

  • Administrators

Okay great thank you, that indicates it should be a problem with the QoS settings.

Just before that, did you disable WMM in Advanced WiFi settings by any chance? If so you will need to re-enable that and it will work.

Put Congestion Control on Never, Reset Distribution for Bandwidth Allocation and make sure both Share Excess options are enabled and finally disable any Traffic Prioritization rules, then retest the speed please. If you get full speeds that's good, then just enable CC on Always and see if upload adheres to what you've limited it to.

Link to comment
Share on other sites

Hey Fraser,

the XR1000 with firmware does not have an option for enabling/disabling WMM in Wireless setup or Advanced Wireless settings.  I would hope and assume it is enabled in the code, but doesn't allow you to change it on the interface.   

The Netgear Nighthawk RAX43 however does allow you to enable/disable WMM in the QoS settings on firmware

An interesting note, I have noticed that configuring both the Netgear RAX43 and XR1000 QoS congestion controls have the same issue.  The wireless devices throughout the office do not obey the congestion rules, but the wired devices do.  

I followed your other suggestions as well such as toggling CC never/always, resting distributions, verifying Share Excess enabled, and disabled all Traffic Prioritization rules, which currently is only the DUMA classified games rule.  I also played around with just about every setting I could see, such as disabling AX, toggling settings such as MU-MIMO, OFDMA, disabling 2.4Ghz/5Ghz and trying each band separately etc.  Doesn't seem to change any behaviors on obeying the congestion rules unfortunately. Almost like the integrated Wireless access point in the device gets to ignore the rules entirely.       

Thanks Fraser

Perhaps if we could get a dev to try and replicate this in a lab environment for us.  If he can't replicate I would love to know. 



Link to comment
Share on other sites

  • 2 weeks later...

Hey Fraser

Has Alex had a chance to try and see if congestion control works for wireless devices? 

all of my wireless devices keep maxing out the connection and  ignoring the always on congestion control.  



Link to comment
Share on other sites

  • 1 month later...

Hey Fraser,

I got your PM message.  I was able to download the new firmware from the link provided.  I unfortunately seem to have the same behavior on the new firmware version as I did the old.  Wired devices follow the "Always" congestion rules, but Wireless devices do not. 

Here is a list of the steps that I took for the process:

Downloaded the XR1000 firmware from the DropBox Link.
Installed the firmware to the XR1000 router.
Reset the router to factory default settings.
Followed the initial setup wizard for automatic configuration.
Set Wifi SSID and password.
Set the Speeds to correspond with my Cable internet speeds 460 down/24 up
Went to QoS and enabled "Always" congestion controls and set 70% down (322Mbps) and 42% Up (10.1Mbps)
Ran a speed test from my Wired computer.  got 322/10 on results. (followed rules as expected)
Ran a speed test from multiple Wireless devices on network.  iOS devices, android devices, Dell laptops.  Wifi devices would not follow rules and hit speeds of 400/24.  ignoring the "Always" congestion control rules.

If we could get someone to attempt to replicate this behavior on their XR1000 or in a lab environment that would be very helpful.  Thanks guys.


Link to comment
Share on other sites

Hey Guys,

The first reset method I used was the software function under settings.  Today I tried the reset function using the physical button on the router.  Both reset methods worked with no issues. 

After testing "Always" congestion feature for firmware, I had the same results.  Wireless devices ignoring the setting.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...