Jump to content

Windows 10 Laptops Cannot Connect to Internet via Wi-Fi

Recommended Posts

I have several Windows 10  laptops running the latest updates.  These machines can connect to my Nighthawk XR450 once and then that's it.  Once they go to sleep, the next time I attempt to reconnect to the internet, I get the "Secured, No Internet" message.  Sometimes an ipconfig /release  and /renew works.  Sometimes it does not.  I've reset the connections completely and that worked, again, once.

The oddest part, or more frustrating part, every other wireless device connected to the Nighthawk has no issues.  Phones, tablets, Switch, Roku, etc. . .  However, none of those really "sleep" per se.  The Windows machines are the only ones that sleep.

I've attempted different settings in the Wi-Fi configuration.  Do not allow Windows to sleep the Wi-Fi card, changing channels on the router to avoid communication conflicts, turning on IPV6, etc. . .  To no avail unfortunately.

Also, I have an access point, a converted Linksys router that acts as an Access Point.  The Windows 10 laptops can connect to that just fine.  And then can connect to the internet.  Coming out of sleep or not.  They reconnect, and I'm golden.

Is there a handshake occurring between the Nighthawk and Windows 10 that does not happen again after the initial connection?  Windows 10 also increments the network every time I do manage to get it to connect.  Like it's the first time it's seeing the router/network.

While connecting to the Linksys Access Point is a solution, it's disappointing to not be able to connect to this fancy new router that I have.

Again, all other devices, wired and wireless have no issues.  Just Windows 10 wirelessly.

Any ideas would be welcome!

Thanks all!

Link to comment
Share on other sites

  • Administrators

Hey, welcome to the forum!

First I would suggest disabling Smart Connect in WiFi settings, it may be they're having trouble switching between 2.4/5GHz based on need so make them separate and then connect manually. If that doesn't help, have you made any changes to the Advanced WiFi settings in Advanced Settings? 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...