Jump to content
Buster

Double Nat XR500??

Recommended Posts

So i am on pppoe on the XR500,  After reading another thread about QoS issues regarding the XR500 and pppoe and seeing Fraser's advice to put a router in front of the XR500 that can handle the pppoe and vlan thats what i did, I'm using a Netgear DM200 which is in modem/router mode.

The DM200's dhcp has only my XR500 in it then my XR500 is doing the DHCP for all my devices.

However now when i boot up modern warfare im seeing moderate NAT type even though port 3074 is being logged in upnp. is this possibly double NAT?

I have tried putting my console in the XR500's DMZ, I have assigned my console a static IP address

I am unable to put the XR500 in the DM200's DMZ as it doesnt have a DMZ.  I am on the latest firmware for both devices.

Any and all help is appreciated 

Share this post


Link to post
Share on other sites

On the DM200 change the NAT Filtering in WAN Settings to Open. If that doesn't work then port forward ports 1-65535 TCP/UDP to the XR500 and that will be like a makeshift DMZ. Make sure to disable WiFi on the DM200 as well so you're just using it to connect the XR500 to the internet.

Share this post


Link to post
Share on other sites

Thanks for the advice, i tried changing the nat filtering on the DM200 to open and still no joy, then i opened the xr500's to open as well and still nothing.

I tried to forward the ports on the dm200 but i just get an error message saying ;

The specified port(s) are being used by other configurations. Please check your configurations of USB Readyshare, Remote Management, Port forwarding, Port Triggering, UPnP Port Mapping table, RIP, and Internet connection type

Share this post


Link to post
Share on other sites
49 minutes ago, Buster said:

Thanks for the advice, i tried changing the nat filtering on the DM200 to open and still no joy, then i opened the xr500's to open as well and still nothing.

I tried to forward the ports on the dm200 but i just get an error message saying ;

The specified port(s) are being used by other configurations. Please check your configurations of USB Readyshare, Remote Management, Port forwarding, Port Triggering, UPnP Port Mapping table, RIP, and Internet connection type

Likely UPnP enabled as it usually is by default. Disable that and then you should be able to do the ports.

Share this post


Link to post
Share on other sites

Upnp disabled, refreshed on XR500, DM200 has port forwarding but no upnp tab.  

Booted up dm200 interface again and still getting the same message

Share this post


Link to post
Share on other sites
Posted (edited)

So i have a similar setup, and was having the same error message. I have now kind of got it working by trial inputting ranges to see where the errors re from, because none of the above programs or tabs were either active or had a tab for them. I have a TCP range from 1-65534 (won't let you go upto 65535 for some reason) and it works fine, so it's not a TCP issue. I've managed to narrow it down on the UDP side that if you forward 1-120, 130-990, 1000-1890, 1910-65534 you don't get any issues, so the ports in use are somewhere within them, but I haven't bothered narrowing them down anymore than this

 

EDIT: Just tried booting modern warefare for the 1st time since doing this and my NAT has gone from moderate to Open

Edited by EnticingToaster

Share this post


Link to post
Share on other sites

Review the DMs user manual or contact NG support. There is a modem mode or router mode or NAT mode that you need to find. Enable the modem only mode or disable router or NAT mode on the modem. 

10 minutes ago, EnticingToaster said:

I'm not sure how to set that up 

 

Share this post


Link to post
Share on other sites
3 hours ago, e38BimmerFN said:

Review the DMs user manual or contact NG support. There is a modem mode or router mode or NAT mode that you need to find. Enable the modem only mode or disable router or NAT mode on the modem. 

 

Ah OK, I get what you mean, I did have this set up, but there is currently a bug/issue with the qos on the XR300 when you get the router to handle ppoe. 

 

But yes the modem does have a modem only mode in which it just acts as the connection to the internet and forwards it to the router, if there wasn't the qos issue that's how I would run it

Share this post


Link to post
Share on other sites
29 minutes ago, e38BimmerFN said:

Ok, Since you have the modem in router mode, use the modems DMZ for the XR router then. This should help with double NAT. 

This is the issue, it does not have the DMZ functionality, hence the need for this work around 

Share this post


Link to post
Share on other sites

I'd consider getting in to a different DSL modem. Something with more DMZ features or more recommended a stand alone DSL Modem with out a built in router. 


I would make contact with NG support regarding the XRs handling of PPPoE protocols. Send them your debug logs with the DM modem bridged and the XR router handling PPPoE. They should be able to correct that since the XR and DM are NG products. 

1 hour ago, EnticingToaster said:

This is the issue, it does not have the DMZ functionality, hence the need for this work around 

Share this post


Link to post
Share on other sites
19 hours ago, Netduma Fraser said:

Does it have Port Forwarding at all?

Yeah it does Fraser, what I've done as detailed above is basically do a makeshift DMZ but forwarding all the ports to the router. I have to say I've noticed a difference, and it seems to be working well now

Share this post


Link to post
Share on other sites
4 minutes ago, EnticingToaster said:

Yeah it does Fraser, what I've done as detailed above is basically do a makeshift DMZ but forwarding all the ports to the router. I have to say I've noticed a difference, and it seems to be working well now

That's great to hear! Keep us updated on your progress.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...