Jump to content

DumaOS Version   3.3.157 Issues - latency Spikes


Recommended Posts

As asked here https://forum.netduma.com/topic/53546-fixed-cpu-usage-spike-issue-coming-next-week/#comment-395251 I have started this topic because I too have experienced similar issues with what feels like latency spikes/Stuttering in online games, while using internet optimiser on the Telstra smart modem Gen 3.

My Smart Modem Gen 3 is (Was) running.

DumaOS Version    3.3.157

Now among other issues as posted on other threads by me, there seems to be something causing this version of DumaOS to not run well at the moment.

I can now confirm that I do not see CPU usage spikes that reach 100% like in the thread linked above.  I experience these spikes while playing MW3 and I do see CPU usage getting readings of 60% but that seems normal when underload.

After testing over many days resetting modem, resetting DumaOS, factory resets nothing seemed to fix it, I know it's not MW3 server side as my children experience this also on fortnite and other online games.

What I have discovered is, that when I disabled internet optimizer my issues with latency spikes went away, I have no issues and it feels all smooth again.

I have FTTP 250/22 connection, with DumaOS activated, I get latency spikes 2 - 3 times per online match. with it deactivated I get no spikes.

Not sure what's causing this and other issues plaguing this version of DumaOS on Telstra modems atm, but it's enough for me to stop using it until a new version is released.

 

Link to comment
Share on other sites

  • Administrators

How big are the latency spikes exactly? If CPU isn't going to 100 then I would lean towards Congestion Control needing to be fine tuned. Now that you have Upload Congestion Control it should be much easier to eliminate this. How do you have CC setup?

Link to comment
Share on other sites

8 hours ago, Netduma Fraser said:

How big are the latency spikes exactly? If CPU isn't going to 100 then I would lean towards Congestion Control needing to be fine-tuned. Now that you have Upload Congestion Control it should be much easier to eliminate this. How do you have CC setup?

My CC setup was to have both sliders to 70%. but it's not a congestion issue, this morning I reactivated Internet optimizer and played MW3 early in the morning in Australia had 18 ping 0% Packet loss in every game, game server would not be crowed at that time in the morning, and everyone else in my house is asleep, so its jut me using the bandwidth with a 250/22 Fibre connection.

It my very first game I experienced what I call latency spike. Even though the in-game ping does not show a spike as it remains steady at 18, and there is no visible Packet loss in game, I get the 1 second spike that feels like lag, as soon as I deactivate Internet Optimizer, this does not occur.

I played about 4 full games and experience this 2 times, but sometimes it 2-3 times every game. I have uploaded logs of the 2 games that I experienced this in. I did not witness any CPU 100% usage as I was monitoring this while playing.

Now, the only difference is the in Dec 23 I went from FTTN 100/20 to FTTP 250/22, I never had this issue when on FTTN, with same modem. It's not my connection, as everything runs smooth when Internet Optimizer is disabled. The only reason I use Internet Optimizer is so I can control the usage better when gaming, since I have 3 gamers in the Houshold, and I just like the extra features that it comes with.

Anyway, I am not sure what else I can do, if there is a new version of DumaOS for the Telstar smart modem that I could test, would be happy to try it, but for now I will leave it off unless you have a solution.

 

 

log-1705948848301.txt log-1705950648336.txt

Link to comment
Share on other sites

25 minutes ago, Netduma Fraser said:

Does both the Geo-Filter ping and in game ping stay stable when that happens? Could you provide a clip of what you're seeing as well if possible please?

Ok, I'll try and capture a clip, and monitor Geo-Filter ping as well and get back to you.

Link to comment
Share on other sites

Ok, I did a quick test before my household wakes up and was lucky it happened at the very beginning of the game, you will see like stuttering at the very end of the 15 sec clip. this is what I experience in game when internet optimizer is enabled. it can happen any time during match.

Now I don't normally use geo-filter, and not sure if I did this right, but I added my device (Xbox) to Geo-Filter and then monitored the ping of the server I connected too this during this clip, and there were some spikes in the ping but not in game. It was difficult to monitor this his while playing, so not sure if it was at the same time I experienced the stuttering in game. Even after that clip I could see spikes in Geo-Filter and not game but did not experience stuttering.

Also, I want to point out this happens on all online games (MW3, Fortnite, Rocket League) on several devices (Xbox & PC) so I am certain it's not a MW3 server-side issue or is it a home network issue, as it all is fine when DumasOS is not enabled.

Hope this helps.

Link to comment
Share on other sites

  • Administrators

Thanks for that! Doesn't look like it's a server issue unless it was so brief it doesn't register but what spikes did the Geo-Filter show, was it small or one massive one?

Link to comment
Share on other sites

49 minutes ago, Netduma Fraser said:

Thanks for that! Doesn't look like it's a server issue unless it was so brief it doesn't register but what spikes did the Geo-Filter show, was it small or one massive one?

From what I witnessed the Geo-filter spike was not that massive maybe 70 ping max.

Link to comment
Share on other sites

58 minutes ago, Netduma Fraser said:

I know you said it doesn't happen with optimizer disabled but could you heavily throttle Congestion Control down and then see if it happens again?

By heavily do you mean drop sliders down to 50%

Link to comment
Share on other sites

Ok I have reset DumaOS again and let it auto setup CC and it set it to 93% Download limit and 85% Upload limit. I'll run that and adjust if needed. I'll get back to you with an update.

Do you have any idea on what may be causing this yet?

CC.jpg

Link to comment
Share on other sites

  • Administrators

50% or lower yes, have you always been using it on Auto Enable or were you using Always? If Auto Enable, how was Traffic Prioritization set? Was it triggering when playing?

I'm not sure yet, still could be settings based on what you answer

Link to comment
Share on other sites

5 hours ago, Netduma Fraser said:

50% or lower yes, have you always been using it on Auto Enable or were you using Always? If Auto Enable, how was Traffic Prioritization set? Was it triggering when playing?

I'm not sure yet, still could be settings based on what you answer.

I have tried it on both Auto and Always, same result. I really am lost with this. I thought it may have been my sons Laptop Killer Control settings causing the issue as his device is not always detected, I disabled the killer control settings, and it did prevent him from getting packet loss when I was online with Xbox, but I still experienced the latency spike in game as like in the above clip. Note* I did add his laptop to the priority list, and you can see 2 Xbox and his laptop activated. (Blue Lights) while testing But still same issue. 

This is very strange. Really am at a loss on this.

Edited by MuRF FuRY
Link to comment
Share on other sites

  • Administrators

I realize this might be a hard one to check but if possible, have the network activity up while you play and if you experience the issue, check to see if you get a big spike or drop in usage briefly and try to identify if there is one what device it came from

Link to comment
Share on other sites

Before I do more testing can you please confirm if this setup is ok.

I will start with Auto Enabled and sliders at 70% (as this is what I have used in the past with no issues) and is my prioritization device set up look correct?

Note* no device was being used at the time of this pic.

pc.jpg

Edited by MuRF FuRY
Link to comment
Share on other sites

  • Administrators

So generally it's fine, a couple of points and you can decide from there:

  1. DumaOS Classified Games will prioritize all consoles so if you want to go with this you could delete the rules you added
  2. Cloud Gaming can be disabled if you're not doing any cloud gaming e.g. streaming games 
  3. Gaming/Voice is for WiFi, Normal (Default) is if it is connected via ethernet
  4. Keeping DumaOS Classified Games and the manual rules would be essentially making the router try to prioritize everything twice so would be best to choose one way or the other. In theory it could create the issue you're having if it's trying to double prioritize.
Link to comment
Share on other sites

9 minutes ago, Netduma Fraser said:

So generally it's fine, a couple of points and you can decide from there:

  1. DumaOS Classified Games will prioritize all consoles so if you want to go with this you could delete the rules you added

When I have this activated and no rules, it does not pick up Laptop when gaming.

Link to comment
Share on other sites

11 minutes ago, Netduma Fraser said:

So generally it's fine, a couple of points and you can decide from there:

2. Cloud Gaming can be disabled if you're not doing any cloud gaming e.g. streaming games 

For some reason this still activates when playing games that are not cloud based game, its normally from the laptop that triggers this.

Link to comment
Share on other sites

15 minutes ago, Netduma Fraser said:

So generally it's fine, a couple of points and you can decide from there:

4. Keeping DumaOS Classified Games and the manual rules would be essentially making the router try to prioritize everything twice so would be best to choose one way or the other. In theory it could create the issue you're having if it's trying to double prioritize.

I have had this issue when only using DumaOS Classified Games as well.

Link to comment
Share on other sites

  • Administrators

Sorry for the delay, use manual rules then if Classified Games isn't catching anything. If cloud gaming was detecting something prior to you disabling it then it'll continue to prioritize until that connection has been severed for a few minutes.

Any luck on this?:

On 1/23/2024 at 10:29 PM, Netduma Fraser said:

I realize this might be a hard one to check but if possible, have the network activity up while you play and if you experience the issue, check to see if you get a big spike or drop in usage briefly and try to identify if there is one what device it came from

Link to comment
Share on other sites

I'm at a loss, I've tried what feels like everything I could. There is something NQR with internet optimizer at the moment, I get better results without it. I give up.

 

Link to comment
Share on other sites

The issue is very strange, I ran my Activity high yesterday, Son was streaming and playing Fortnite on New Gaming PC (replaced Laptop in previous test, as that was having issues) I was playing MW3 on Xbox Series X Other son was playing Fortnite on Xbox Series X, Kids mum was watching a streaming service, I was uploading to OneDrive (with limited bandwidth on), so it was quite active, With optimizer on, it gave be so much stuttering (lag) in MW3 but no visible spikes or readings both in game or on DumaOS, everyone else seemed ok, BUT, with optimizer disabled it seems to run ok. MW3 is very buggy atm (I have reinstalled that as well) so I believe it's one of the following.

MW3 - Aussie COD Servers are the issue, or I'm running into a lot of Cheats using lag switches. or my Telstra Gen 3 modem is failing, as it did lose 5GHz Wi-Fi the other day for no reason. But I play using Ethernet anyway.

Also, it's like DumaOS does not like my FTTP NBN upgrade and speed upgrade, on FTTN 100/20 No issues with Optimizer and running heavy activity like above, but with FTTP 250/22 I have nothing but issues, remember without is enabled ...no issues, so it's not my connection.

Today I have changed to a new Telstra Gen 3 modem, as I was lucky to have a spare to see if that makes a difference. failing that I just don't know what else to try.

Link to comment
Share on other sites

  • Administrators

Let us know how you get on with the new modem. Do you play any other games at all so you could compare your experience? I will get the team to have a look but may be hard to identify the cause based on the info

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...