Jump to content
xMako3

Question on high latency in Parsec and fix inside

Recommended Posts

So I was getting 1-4k ping latency on parsec and I had absolutely no clue why. Had parsec ports prioritized and everything with source 1-65535 and destination 9000-9040. Qos on. Laggy as ever, even on a wired connection. Deleted my parsec config and restarted and still had the same issue with default settings. Found a reddit thread that suggested to disable qos and that instantly fixed it. Why is this? Usually qos is suppose to help with gaming. I had it to 70/70 anti bufferbloat to always and it works with all games. I guess parsec is different cause its a streaming type thing? No idea, but now I can sit at 50 ping comfortable. If anyone knows why this is the case, please let me know. But anyways, try disabling qos if your ping is iffy in certain programs.

Share this post


Link to post
Share on other sites

 

Still very high ping, as soon as I completely disable qos it fixes the issue. Usually this is never the case in games like cod, fortnite, etc. the ping is completely fine. Not sure, disabled traffic prio duma game classifications, and deleted my own custom 1-65535 src and destination rule and still had the same issue. I tried actually crossing all options and setting anti bufferbloat to never but it got the same result but to a less extreme version.

 

 

 

 

909220896_netdumahighpingnotrafficprio.thumb.PNG.2c8400984f9dab29fa2f228710c59d3d.PNG2106533435_parseclowpingqosdisabled.thumb.PNG.29f0230551c270490b20049a41100283.PNG

Share this post


Link to post
Share on other sites

Thanks for the information, QoS must be dropping packets, I will get the team to investigate this but just to double check, it's https://parsec.app/ right? Are there any specific games/applications QoS causes the issue on or is it anything through parsec?

Share this post


Link to post
Share on other sites

I haven't noticed it in any other games, my games perform perfectly. Yeah the parsec app, then go to the Arcade and join any of the random games, preferably find one within your own region. Some of the hosts may or may not be the hosts of your region so your ping could be 150-300 instead of 50-90 so just rejoin different hosts. Also, reload the parsec app every time you want to join a new host to get the most up to date rooms instead of already joined rooms that seem empty.

Share this post


Link to post
Share on other sites

Factory default reset must of fixed it. Messing with the wan setup settings seems to have messed something up but now I've got qos up and running along with parsec playing along nicely!

Share this post


Link to post
Share on other sites

Thank you very much I love the work you and this team do. Keep it up this company is something else!

Share this post


Link to post
Share on other sites

@Netduma Fraser I have been busy but it seems like qos still gives me high ping until I disable it. Sorry for the confusion, I hope you can let the team know. Even with traffic prioritization unchecked, or checked, and even trying anti congestion to never with qos and traffic on and off. Still no go. As soon as I disable qos, it's fine. My theory is that parsec runs off of a lot of mbs internet speed, so when you try to limit it, the entire game will lag. Anyways, let me know. Sorry for the confusion. I wanted to make sure it was 100% an issue before actually giving my stance on it and I didn't have time to test it out thoroughly until recently.

Share this post


Link to post
Share on other sites
14 hours ago, xMako3 said:

@Netduma Fraser I have been busy but it seems like qos still gives me high ping until I disable it. Sorry for the confusion, I hope you can let the team know. Even with traffic prioritization unchecked, or checked, and even trying anti congestion to never with qos and traffic on and off. Still no go. As soon as I disable qos, it's fine. My theory is that parsec runs off of a lot of mbs internet speed, so when you try to limit it, the entire game will lag. Anyways, let me know. Sorry for the confusion. I wanted to make sure it was 100% an issue before actually giving my stance on it and I didn't have time to test it out thoroughly until recently.

That's odd, are the rules you've added yourself detecting traffic? Could you provide a full screenshot of Traffic Prioritisation perhaps?

Share this post


Link to post
Share on other sites

I've just reverted to factory defaults, and the only thing I changed is the dns servers, geofilter (obviously spectating mode for parsec), and qos is on and working. Not sure but my setup is working now! I didn't add a rule for traffic prio, that I left default to on. I realize it also depends on the host you join. Not all connections are equal even though the host has low ping doesn't mean he won't have packet loss on his side or something bad with his connection (host may be on wifi etc). Played for a solid hour with no problems with a certain host so it seems solved!

Share this post


Link to post
Share on other sites
10 hours ago, xMako3 said:

I've just reverted to factory defaults, and the only thing I changed is the dns servers, geofilter (obviously spectating mode for parsec), and qos is on and working. Not sure but my setup is working now! I didn't add a rule for traffic prio, that I left default to on. I realize it also depends on the host you join. Not all connections are equal even though the host has low ping doesn't mean he won't have packet loss on his side or something bad with his connection (host may be on wifi etc). Played for a solid hour with no problems with a certain host so it seems solved!

That's interesting, thanks for reporting back! I'll mark this as resolved for now but if you have any further issues please feel free to raise a new topic!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...