Jump to content

QOS question

Recommended Posts

Edit: I only use wifi for my phones. Everything else is wired. 

I have been messing around with the QOS settings trying reduce bufferbloat and I dont think I am doing it right or something else is going on. 

My question is: is this a problem with my network, and is this evidence to share with the ISP as evidence of congestion in their network? The congestion starts on hop 2, so I assume its my network. 

I get a B on this test with QOS on: https://www.waveform.com/tools/bufferbloat?test-id=9dec4183-eb18-430a-b1a2-4c6285536c66
VS the same test with "disable QOS" checked: https://www.waveform.com/tools/bufferbloat?test-id=e412876f-398c-452f-8e1f-eab5f8347340

I also see significant congestion signaling on ping plotter when running the test (this is to 2.5 second ping, the spike is when I ran the test with QOS enabled. 


I just updated to and factory reset (I "pay for" 400 down and 10 up and get about 470 down, 12 up, as confirmed through the setup wizard providing the following bandwidth) I think the bandwidth I am getting to my PC is OK now (282 with QOS- 290 without QOS), but still low (must be a cable issue). (If I connect directly to my modem, I get about the same bandwidth, but I get better results on bufferbloat than with the router https://www.waveform.com/tools/bufferbloat?test-id=eb1cf4e0-a767-4611-b641-f2642688c892). 

When I setup QOS I use 70% up, 70% down, even distribution, shared excess up and down, and set up my PS5 as a games console, apply to wan checked. FXRNKXG.png

Obviously my core issue is I will consistently get 250ms-1000ms latency on my connection while playing games, and have never been able to get this QOS to change anything that I see in Pingplotter or any other ping test (cmd, waveform, et al). 

A problem that may be causing it is that I have two PCs, and several Smart home devices, as well as two phones for a total of 8 or 9 active devices at any time, but I never get close to saturation, and I get the problem even when no one is using any other devices, and I disconnect the rest of the online devices. 

Link to comment
Share on other sites

I have an mb8600 Motorola. Everything is connected to the XR500. The modem has one Ethernet out. 

For reddit.com and bungie.net I get a relatively stable 10-18ms PZoBOlm.pngxI8Xc6W.png

When I run the bufferbloat it shows as: 


Link to comment
Share on other sites

So, I cannot get above a "B" with QOS on, regardless of how I manipulate the settings. I did get it down to a C by disabling share excess... So I guess that setting works. Every other setting produces very similar results. 5%, 50%, 70% 90%, 95% 100% on up or down. Adjusting allocation up or down doesnt change anything in the latency...

Turning off QOS (disable QOS) produces better results maybe 50% of the time, but not always obviously. But its never significantly worse. 

https://www.waveform.com/tools/bufferbloat?test-id=09fe9452-02a2-4de5-8c87-7fdaaefcf049 A

https://www.waveform.com/tools/bufferbloat?test-id=72cca003-aea9-4972-9df4-586235cbe973 A

https://www.waveform.com/tools/bufferbloat?test-id=d27071d1-6a65-41d1-b7f1-81c85d8c0842 B

 (these three are without QOS) and its significantly better. 

Ping plotter for QOS on (black) vs off (red)


This is earlier this evening just watching youtube at 720p DhatGav.png


Is my router broken? It seems like QOS is software so it should work if the hardware otherwise works. Could it be too hot or something? I would love to get some evidence that my ISP if screwing me (so I can file an FCC complaint) - I have had them out a dozen times in the last three years between the bucket trucks and the in-home techs. 

TBH, I am thinking about giving up gaming that requires time sensitive inputs. 

Link to comment
Share on other sites

6 hours ago, Netduma Liam said:

If you remove the XR500 from the mix and either use a different router or connect direct to the modem, do you get the same results in Ping Plotter?

If you run a Connection Benchmark, what scores do you get from this?

Sorry, My original post was a little dense, but I posted my direct to modem result: https://www.waveform.com/tools/bufferbloat?test-id=eb1cf4e0-a767-4611-b641-f2642688c892
Direct to my modem is a little higher bandwidth, and gives a similar bufferbloat result as having QOS off on the router (better than with QOS on) 

If I run a connection benchmark I get 

I spent a couple hours talking to the ISP last night, and while they started with everything showing up "green" they said I needed to rent their gateway and up my plan to 900mbps to see if that resolved it. 

Link to comment
Share on other sites

1 hour ago, Netduma Fraser said:

Could you do a PingPlotter from the modem so we can compare those results as well please?

Maybe this will get us there: direct from the modem



Link to comment
Share on other sites

  • Administrators

Okay interesting so some definite spiking and a bit of packet loss on the last. Under what circumstances were these tests done, i.e. were you downloading at the same time or were you just doing this test?

Link to comment
Share on other sites

All of these are waveform or "connection benchmark" tests with no other activity. I let it run about 10 minutes to get an unloaded ping (so I can see a baseline), and then start doing tests. Typically I trace two sites together, but I just now noticed I can open a second instance of ping plotter, so I did google.com as well (you can see the timestamps line up between the three). 


Link to comment
Share on other sites

15 minutes ago, Netduma Fraser said:

Thanks for the information, okay that makes sense then, the connection is pretty stable until you do a test so not an ISP issue. Are you using PPPoE, VLAN, IPv6 etc?

I dont know, can you walk me through that or link me? I know what it means, but I cant find it, and I just used the setup wizzard to make sure I didnt overstep my ability. 


 I have an mb8600 as my modem, IPv6 disabled on the router. 

Link to comment
Share on other sites

16 minutes ago, Netduma Fraser said:

You can find VLAN in Settings > Advanced Settings, is it enabled or disabled? 

For PPPoE go to Settings and on the first page that appears it will show you, does it say you're using a login?

Disabled, and no login. 

6xNqrNr.png S5pRU7l.png

Link to comment
Share on other sites

OK, in Traffic Prioritisation, could you please add a new rule for your device that you're running ping plotter on and select ICMP-Ping. This will now be a more accurate representation of what you're seeing in game. Could you then run a ping plotter and share the results with this rule enabled?

The spikes you're seeing there make sense as when you're running a connection benchmark, it's filling up the network queue to see how this is handled by QoS.

Link to comment
Share on other sites

Hey Liam, Maybe I am doing it wrong, but adding my computer running pingplotter and running a test on it looks the same, and shows no prioritized packets?


Either way, it looks like this. 

Link to comment
Share on other sites

No DMZ or port forwarding. 

But, since I added my computer to the traffic prioritization (still no prioritized packets though), I am getting packet loss on an idle connection. (the spike is from a scheduled connection benchmark test). Packet loss is between the router and the 2nd hop. 
Same timeframe pinging an east coast server I connect to a lot

Link to comment
Share on other sites

  • Administrators

You can ignore that, if there was 100% packet loss there you wouldn't have any internet at all. Do you have a spare router you could connect to the modem then connect the XR in AP mode and see if it still occurs?

Link to comment
Share on other sites

I do not have a spare router. I am not worried about the 100% on the first hop, or the 4.1% on the 5th. Its because I am pinging too fast. the 1.7 in that period (that carries through all the hops) is why I mention it.

Link to comment
Share on other sites

The spikes exist at 2.5. 2.5 is what I was running in all the tests except the latest one. 

This is the same time period on 1 second to reddit.com

I changed back to 2.5. Ill post some results. 

I am not sure what it matters, because I have seen you guys say that the connection benchmark doesnt work quite right, but this is what it looks like with QOS on

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...