Jump to content
chrisk

Completely dissapointed with this router

Recommended Posts

After purchasing this router, I had to wait 2 months to finally receive it as my order was pushed back an additional month from what was originally stated. My wired connection is great, but the wifi is horrible. The signal is alot weaker than my xfinity modem/router combo, and my speeds are extremely low. It has gotten worse as of lately only getting about 80-200mbps dl when I pay for 650mbps and have always gotten closer to 800mbps with the xfinity combo. It has also recently started completely disconnecting my devices with my network not even showing up, and the majority of the time DumaOS won't even fully load. I have factory reset it. I have tried with QoS enabled and disabled. Mirrored mode is off. Have attempted with Syn Flood Protection off. Along with many other suggestions you guys have made to the many other people complaining about this router. At this point I don't even want to use it anymore as my xfinity performs much better. How do I set up a return for a refund for this?

Share this post


Link to post
Share on other sites

Welcome to the forum!

Sorry to hear that, did disabling QoS improve speeds at all? We're aware that the wireless strength on the R2 is not where it could be and we'll be working to resolve that with firmware updates ideally.

If you'd like to return your R2, email [email protected] and quote your order number and reason for return.

Share this post


Link to post
Share on other sites

No unfortunately it didn't. Max wifi speeds I've seen with tinkering is about 200 down 25 up. If I swap back to my xfinity combo I'm getting at a minimum 650 down 30 up. My gaming pc is hardwired and no issues with speeds as I'm getting on average 750 down 30 up. Everything else in the house though is on the wifi and constantly buffering, dropping, or the network just dissappears altogether. Which hasn't sat well with the wife and kids lol.

Share this post


Link to post
Share on other sites

The R2 does not have as strong WiFi as the Xfinity router so even with updates you may not get that higher. Set the antennae to look like this _ | | _ for more range and stability. Also change 5GHz to 80 width. On the Xfinity set a static/reserved IP for the R2 and that should help with the disconnects. In System Information on the Rapp panel options change the retries to 5 then reboot the router from the interface.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...