Jump to content

Router Becoming Unresponsive


Recommended Posts

Started happening this weekend where the internet just dies and I can't log into the router without a power cycle. I've done the following:

  • Factory Reset 5 times.
  • Reuploaded the latest firmware and factory reset.

I've also noticed that my 4th ethernet port light on the front does not turn on even when plugged in and actively working. The port works fine, just the activity light on the front is out.

At this point it's completely removed from my network as I work from home and can't keep suffering through the troubleshooting during work times.

Is this something that needs to be RMA'd?

Link to comment
Share on other sites

9 hours ago, Netduma Fraser said:

It does sound like it yes but before then try downloading to the .123 firmware and then factory reset and see if it performs any better - of course that's unlikely to affect the LED on port 4.

Where can I download that from? I only see the latest firmware, .179

Link to comment
Share on other sites

I applied the old firmware and then upgraded it again and it seems to have resolved the issue of going nonresponsive.

I still went back to the XR500 because the Pi-Hole is much better system for AdBlock than what's cooked into the R2. I've observed the following:

  • Over the course of a day's worth of traffic, the R2 with a small block list (https://block.energized.pro/bluGo/formats/hosts.txt this file has 125K domains) blocked 75% of all DNS queries which is substantially more than my Pi-Hole with a much larger list (https://block.energized.pro/ultimate/formats/hosts.txt has 1.1M domains only blocking 12% with ads). I missed getting the exact values from the R2 but the Pi-Hole is sitting at 49,547 / 6,033 for a day. Not sure if there is some loop happening to inflate blocked traffic.. I'm no expert in this area.
     
  • R2 can't use block lists that are too large, seems like anything larger than 3MB will freak out the R2.
     
  • If I use the R2 with the Pi-Hole it seems to hold on to the DNS queries and once it reaches it's max of 150, it will no longer resolve any DNS calls. I'll see if message in the logs when it happens: Maximum number of concurrent DNS queries reached (max: 150). It will pop up a few more times before allow DNS queries to resolve again.

Not sure if there's any ways to fix this that maybe I don't know about but after spending a day researching, I couldn't find any way to change the Pi-Hole or the R2 to resolve. There's a lot of things pointing to OpenWRT settings to resolve but of course those settings are not exposed in DumaOS.

Edited by GenMatrix
added 2nd bullet point
Link to comment
Share on other sites

  • Administrators

Glad to hear that's fixed your issue so far, and thank you for the great feedback.

That's an interesting observation, I'll need to look into it a little further once I've got a minute and see if we can do something about that!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...