Jump to content
Aswitch

Too many devices/switches/AP's?

Recommended Posts

Hey Duma Army,

So bought the R1 back in 2015 and have since gotten the XR500 for about a bit over a year now i believe. Been having some issues with it that I can't necessarily point my finger to being the culprit (as it being my ISP Charter Spectrum, Modem the router etc.), other than bandwidth or too many devices possibly. i'll just spit out all of the details i can think of now:

Modem: Netgear CM1000

Router XR500:
Port 1: 24 port switch> 
                                       >8 port unmanaged switch

                                         >Dedicated Wifi access point

Port 2: Netgear router(configued as an access point)>Netgear 8 port unmanaged Switch> unmanaged 8 port Switch

Port 3: Roommate's PC

Port 4: Roomate's Console I believe

Network speeds: 300 Down/25 Up

Our household is probably uncommon i'd assume. I stay with 2 roommates. All of us are gamers. All three of us have PS4's and Nintendo switches(and occasionally play together). I have all of the consoles(old and new), but tend to play Xbox one and PS4 most. I also have PC(that I play online from time to time also). Amongst us all collectively, we have about 80-100ish registered devices(guests come over and use the wifi etc). Active on average we have probably about 10-15 devices on and connected at once(rest mode etc.).

For some weirdness i reserved some static IPs from the range of 192.168.88.1 - 192.168.88.20. I reserved those for mainly my PCs in order to use synergy. While also adding NAS related stuff as well.  

Now what's been a semi ongoing issue for the longest(doesn't happen too frequently, but happens enough to be annoying) is that one of us will get disconnected and not able to access without having to restart the router. This seems to occasionally happen when we're all home and presumably online at once. Not necessarily playing the same console or playing games for that matter but miscellaneous stuff(browsing the internet etc). When I check the stats on the router interface at the time the issue happens, it doesn't seem to indicate any issue from what i see at least.( I enabled logging so I can provide that info if needed).

An incident happened last night. I was on my PS4 playing death stranding(somewhat uses online) and my roommate was playing Monster hunter on his PS4. The roommate playing Monster Hunter was disconnected while myself and presumably my roommate was still connected. He said he kept getting kicked off. so It seems like he was able to connect for a time and then get disconnected. I believe my other roommate was streaming chrunchyroll possibly on PS4 via the app at the time but not 100% sure. Rebooted the router and that looks to have resolved the issue.

My issue and concern is that I shouldn't have to restart every time this happens and it should fix itself (I'd assume). I'm just curious as to why people are getting blatantly disconnected. Happened to me at a time and my other roommate at a time also. It basically happened to all of us more than once within a lets say 3 month timespan.

Anything that guys see that could pose being an issue like multiple PS4s online at once using the same router(and presumably same ports)? It hasn't really been an issue before for us that much. Every blue moon someone would get disconnected, but not noticeably.

Would putting my Netduma R1 in the mix behind the router as an access point possibly help? or hurt in this scenario?

Tried everything I could think of settings wise, but willing to try some additional things again if needed. Considering the nature of the issue, it's hard to say when it'll come back (or what could be causing it).

-factory reset without reinstalling the config file

-Turning off/on QoS

-Putting the bandwidth to 70%

-Unchecking share excess bandwidth

Those are the steps that I tried that came to my head so far at least

 

Any Impressions/thoughts as to what could be the possible culprit here?

Thanks!

 

 

Share this post


Link to post
Share on other sites

Thanks for the detailed rundown of your network setup.

Seems to me like it's possible this could be a DHCP issue, since there are so many devices... But it's not like all 80 of them are connected at the same time. When a device is disconnected, it's IP address should be freed up. Also your reserved IP devices should be unaffected even if you were to run out of IP addresses.

It might be something to do with DNS settings, but once again that doesn't quite cover it because that would only affect your ability to establish new connections, it wouldn't stop any existing connections. That said, just to be safe, it might be a good idea to set your XR500's DNS to something like 8.8.8.8, 8.8.4.4

If it was to do with IP addresses, I would suggest putting the downstream routers back into router mode, and giving them a different subnet. For example if the XR500 was 192.168.1.1, then the next router downstream could  be 192.168.3.1 and the other could be 192.168.4.1. That would mean that any devices connected downstream of those routers would appear as one device in the DumaOS Device Manager, which isn't ideal, but it would certainly save on IP addresses.

Another idea, maybe it's to do with the router's DHCP lease renewing? I have seen issues before where a lease renews and kicks everybody offline for a few seconds. This doesn't usually require a restart though.

Oh also, do you have UPnP enabled?

Share this post


Link to post
Share on other sites

Some good advice here. I'll mess around with these. I know for sure DNS wise I have 8.8.8.8 setup. Not sure about 8.8.4.4 but I'll add it if I haven't

I would've liked to refrain from separating the routers via subnet as i'd like to access the routers/devices if needed and see what device is causing an issue and assign a device for geofiltering and vpn use but I guess I could just blanket the whole router in theory in those instances which hasn't been needed lately as I mainly use those features, but if that were to resolve it ultimately, I'll give it a shot and see what happens. I'll setup my R1 behind my room with all of my devices on its own subnet and adjust the others to their own in that case. It feels like the abundance of devices might factor to some extent(possibly too much info to save) but didn't think it would since no more than like 10-15 devices are active at once. I know device manager wise, it's crazy so I have to switch to table view.

DHCP renewing could be the possible culprit. Seeing it first hand, it instantly disconnects and doesn't seem to connect back (within a reasonable time at least within 5 mins as i'd reboot before then in order to resolve). Only certain devices are affected, but not all of them. static ip andresses and dhcp leased addresses don't seem to matter either.

Yup UPnP is enabled as well.

I'll make these changes when I get home and see how they fair.

Thanks again for the help,

Share this post


Link to post
Share on other sites

Just giving and update since making the recommended changes. It basically seemed to present a bigger issue:

I couldn't connect(Netduma R1 that's now ahead of 24 port switch in port 1 behind the XR500) to my friends properly in a game(For Honor) as well as my friends in a different room(Connected to Netgear Router). I was able to join the lobby with my friends and we were able to join a PS4 party just fine, but when attempting to search for games, i would always get kicked out of the game. My nat overall became moderate consistently across my consoles and I wasn't able to extend my Plex server(Nas) outside the network due to it being behind my XR500 and R1. My friends behind the Netgear Router were able to connect and play just fine.

Tried DMZing my R1 from the XR500, but it gives me the error that it needs to be on the same subnet

So I ended up reverting back to my similar setup as before, with the slight variation of putting the Netgear router into its native AP mode (i manually set it into AP by changing the ip address and turning off dhcp )and putting it behind my switch instead of having my switch behind it. I also removed the R1 out of the equation and just connected my switch directly to my router as before. We have a lot of folks visiting this upcoming holiday so we'll be able to really stress this slight modification to see if that might do the trick.

Share this post


Link to post
Share on other sites

Keep us updated in regards to that modification. One thing I think could cause issues potentially is if you have multiple devices added on the Geo-Filter at once. Considering you can only use one lot of settings there and different games are being played that could cause some booting issues. Are you using the Geo-Filter at all? If so remove all the devices and see if that helps at all. Also what are the particular devices this happens to? Are they wired - if so are they connected to a switch? If wireless are they connected to the AP or the router?

Share this post


Link to post
Share on other sites

Ok so a similar issue just happened last night:

Roughly a little after 12am Midnight PST. I started playing For Honor on my PS4 Pro behind my switch (behind port 1 of the main router). My friends(PS4 OG, and PS4 Pro respectively) were already connected and playing the game behind the other switch behind Port 2 of the main switch(they were in a game together). They were playing for a while beforehand without any issues to my understanding.

It was only until after I started playing the same game but playing a different mode (and not with them)the issue started a while after. I was able to get into one match and complete it just fine without any issues(10-15min match). But shortly after getting matched into another match and playing for about 5mins is when I got disconnected and the two others that were playing as well ran into issues. It doesn't seem like anyone else was affected(about 2 others outside of us using the internet presumably not playing a game).

My one friend(PS4 Pro) was still connected but got disconnected about 10mins after we did. He was still in the game they were in for that time before being disconnected in the same manner we did.

My other friend and myself were completely kicked off the internet. My other friend was able to get on about 10mins afterward, but When I was trying to connect back during this time frame, I got the error along side something about the DNS when doing a connection test on the PS4, I forgot what it said verbatim but something pointing towards the DNS being the issue. about 1 min after trying to connect again, it did connect. When checking the logs on the router, there doesn't seem to be any error indicating the issue either around that time. Just a lot of UPnP nat rules being set.

Confirmed that DNS servers were set as instructed before:

Primary: 8.8.8.8

Secondary: 8.8.4.4.

Third: 199.85.127.10 (I want to say I looked this one up for reputable/reliable dns server just to have a third option I think it's norton but i'm removing it now even though I don't think it necesarily factored in this if it's the third option)

Confirmed that I had no devices set in Geo filter also

Could it possibly be related the the DHCP lease time? That by coincidence it happens release/renew when we're playing?

Possibly anti-bufferbloat conflicts? Going to try turning it off completely to see what that does since at 320/25 we shouldn't technically need it right?

The common denominator seems to most often be any game we play on PS4 if more than one of us are playing at once(the console everyone in the household owns outside of the Nintendo switch). I haven't run into any of these issues with my Xbox one/PC necessarily considering i'm the only Xbox one owner in the household with my friends occasionally playing PC games.

Any thoughts/recommendations?

 

 

Share this post


Link to post
Share on other sites

It's plausible that the lease renews when you're playing but you would expect to notice it at least one time when not playing. I doubt it's Anti-BB to be honest but you can give that a go. If it was going to be anything I think it would be Traffic Prioritization but if you disable QoS completely that'll do both.

I think it could be to do with NAT/ports. I suspect when the third person jumps on it's not equipped to open the next port. I would suggest looking into port forwarding for the games you play, specifically looking at what ports to open when there are multiple consoles. For example CoD will use 3074 for the first, 3075 for the second etc.

Share this post


Link to post
Share on other sites

I went ahead and added the general ports for Both PS4 and Xbox to the port triggering list. Checked majority of games and they seem to fall under the same ones so going to see how that fares.

Share this post


Link to post
Share on other sites

Ok was checking the other night and found what might be a culprit that I was unaware of until recently is that the CPU usage is really high according to the CPU graph hitting about 90 and above. Are there any processes that I'd be able to disable completely to possibly help reduce its stress? Not sure if it's consistent or maybe explains the sporadic nature of the disconnects in correlation with the CPU usage where possibly the router just needs to cool down and this is a possible factor of that. The same thing Happened Yesterday while I was playing Call of Duty: Modern Warfare. Was about 20 mins in a co-op game and it completely disconnected me from the internet, but let me connect back shortly thereafter. Didn't get a chance to verify the cpu usage at the time. I'll do some more digging and check the cpu usage to see if that was actually the issue.

Share this post


Link to post
Share on other sites

Only thing I recall changing was the IP address to 192.168.88.1 and reserving 20 ip adresses by adjusting the dhcp starting pool to 192.168.88.21 to reserve those 20 ip addresses for static ip addresses(with my main one being my NAS). I added the port forwarding as suggested via port triggering as well. Everything else is basic outside of QoS of which I manually added our up and down speeds. Didn't add any devices to the priority list.

Share this post


Link to post
Share on other sites

You don't need to change the DHCP pool to reserve IPs as if you just reserve them then DHCP won't allocate them anyway. Could you try changing the pool back to default? Could you provide a screenshot of the port triggering you've done please?

Share this post


Link to post
Share on other sites

dang I ended up just clearing them out since they didn't seem to help before getting that last part. But I basically added these :  

PS4

TCP: 80, 443, 1935, 3478-3480. UDP: 3478-3479.

Xbox

Port 88 (UDP)

Port 3074 (UDP and TCP)

Port 53 (UDP and TCP)

Port 80 (TCP)

Port 500 (UDP)

Port 3544 (UDP)

Port 4500 (UDP)

For honor said to open the same ports for PS4 as well.

I didn't duplicate the ones that are within both.

After removing these and changing the starting dhcp address to 192.168.88.2 it looks like it put the cpus in the 50-60 range now. I'll check back in a while to update if that was the snafu.

 

Share this post


Link to post
Share on other sites

Okay keep us updated. Just FYI though, it's not a good idea to port forward/trigger port 80 or 443 as these are the main ports used for web browsing, downloading etc. It's better that it was on a trigger but if the console starts downloading an update for example then that could cause issues for other devices.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...