Jump to content

XR500 - Wi-Fi and LAN not communicating properly

Recommended Posts

My mate recently purchased an XR500 and I recently got the XR300. We both have a CCTV system connected to our LAN using these gaming routers. He has been having issues connecting to the CCTV on Wi-Fi, but he can connect over cellular with no problems at all. 

We tried many different combinations of wireless settings. No matter what we did, we could not load the config webpage for the CCTV on Wi-Fi with a laptop. However we could ping the CCTV over Wi-Fi. If we connected the laptop into LAN, it loaded config webpage no problem.

It was the same for the CCTV software on Wi-Fi the CCTV ( shows as offline. When we connect to LAN shows online immediately. All devices have internet access on Wi-Fi. But for some reason LAN and Wi-Fi aren't communicating properly.  It is almost as if access to a LAN device is blocked for a wireless device.

The CCTV system uses ports 37777 and 37778. I dont understand why he has this trouble on his network. I have the exact same setup (same CCTV, same IP range), the only thing which is different is the model XR300 and XR500. Also he has VLAN tagging for his NBN connection to work. Could VLAN tagging cause this issue?

Anyone got any ideas?

Link to comment
Share on other sites

  • Administrators

It's possible that VLAN could be causing it but lets take a look at some other options first. Most WiFi issues I've seen are to do with smart connect being enabled as not all devices support it very well, especially older devices. Have you tried disabling smart connect and connecting directly to 2.4GHz?

Link to comment
Share on other sites

We disabled smart connect. Same issue on both 2Ghz and 5Ghz. We also just tried disabling the VLAN tagging and trying to connect to the CCTV webpage over Wi-Fi. Both 5Ghz and 2Ghz did not work. 

Any other suggestions? 

Link to comment
Share on other sites

  • 2 weeks later...

This appears to be an issue caused by VLAN tagging. The default VLAN tag 2 for internet is applying to LAN ports and wireless by default. The ISP website says that VLAN tags do not need to be applied to wireless but this cannot be changed for the default internet VLAN. See below setting from ISP website for VLAN tagging:



The information I have found says that a VLAN bridge may need to be created so Wi-Fi and LAN communications do not need to pass through the router Network Address Translation. 

FYI we were able to communicate with CCTV device on LAN via Wi-Fi after we did a factory restore and no VLAN tagging enabled.

Link to comment
Share on other sites

  • 3 weeks later...
  • Administrators
12 hours ago, kymadn said:

You cant edit the default Vlan tag. The default Vlan tag is applied to all port and wireless. It wont allow me to edit the rule

Click on the selector circle for the default VLAN tag then click edit. Then change VLAN ID to 0 which then means VLAN is not used for the group and apply. Then you should be able to make your own VLAN tags how you wish.

Link to comment
Share on other sites

  • 4 years later...

I know this is 5 years later, but the fix for me was the following

Under Vlan/Bridge Settings which is under advanced.

Go to By VLAN tag group and create a new group called "LAN" in the vlan ID box call it vlan 1 and select up to 3 Wired and 2 wireless (keeping one Wired port free)


After doing this click apply

Next and this is the most important step under where you see this new group. Make sure where it says "Enable" , Untick it!


For some reason what this does it keeps your one wired and one WAN as the one single vlan ID you require for internet.

And then it sets the rest of your wireless and wired as vlan 0, making communication work again across the different ways of communication (wired, wireless, 2.4/5ghz)

I'm also on the beta version XR500 V2.3.2.134-dumaos33-rc14

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...