Jump to content
michaeljfig

Please fix geofilter

Recommended Posts

Come on guys this router has been out for awhile and it's useless. I bought this router to lower my ping OR to be able to play with people and not have lag problems.

 

There is nothing different from this router and any other basic router because when you enable features you can barely find lobbies OR with ping assist to auto it puts me in Japan servers. Really?? I'm in USA. I've reset it numerous times. I can't set ping assist to anything lower than 50 or I can't find a lobby. I can find 50ms servers with a regular router seriously!

 

We paid a good amount of $ which we thought was an awesome router but it's no different than any other.

 

You only update features, bug fixes every 2-3 years so looks like I'll have to go with a different gaming router. 

 

I made the mistake of selling my R1 Netduma router just to buy xr500. It had same features and bugs. Not that I would want the R1. 

 

You guys say you listen to feedback but I don't think you really do. Look how many people that made these kinds of posts and nothing has changed. Oh and on another thread it said "stay tuned next week for next major update". It's next week and I don't see anything.

 

You should say in "earth" time what date or time you really meant by next week. Next year?

 

I'm not trying to gripe and all that but you guys have us waiting like something is gonna get fixed.

 

Anyone interested in XR500 let me know. Cause it's time to move on.

Share this post


Link to post
Share on other sites

The news we were going to share this week has been pushed to next week. It's all written and ready to go but we need to get the OK from all parties before we can post it.

Even if you do sell your XR500, I hope you will keep an eye on Netduma because we have big plans for the future.

Share this post


Link to post
Share on other sites

Thanks for getting back, was mostly irritated with Black Ops 4. I like this community and like the router just wish it did what it is supposed to do on PS4. It's hard getting into "great" lobbies where pings and everything is low. What's weird is sometimes not using router my ping gets around 40 ms.

 

I know it's most likely a Black Ops server issue. See I'm in Reno, NV and closest server is probably around Portland OR. Also one in San Diego CA. So it also could be a West Coast problem.

 

My internet speed is 975mbit down and 40mbit up. Yeah terrible upload for gig internet but it's Spectrum 🥺.

 

Yeah I'll hold off and check out the news cause I know this could be an even better router.

Something else that was spoken about by me and others will there be an "app store"? Because I know there are intelligent devs out there that can create great apps.

 

Thanks again for the reply. 🙂

Share this post


Link to post
Share on other sites

Hi Michael, it seems as though you haven't made a topic regarding your issues before which makes it hard to help you. If you could summarise all your issues here and include some more details such as your exact physical setup, your base ping to speedtest.net when connected to the ISP hub and nothing using the internet we can begin to find out what is happening. If you could include a screenshot of one of those instances where Ping Assist doesn't seem to be working correctly that would help - include the Ping Panel of that particular server as well.

R-Apps will become more relevant in future :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...