Jump to content

Congestion Control Bug?


Recommended Posts

Hey -- I am currently running Netduma 1.03.6h. My bandwidth is set to 250 up and 12 down. When the congestion control is set to 100%, I easily get speed test results around 245mbps, with buffer bloat around C+. If I set the congestion control to 99%, my buffer bloat hits A+, but my speeds are capped at 150mpbs. Every percentage drop from there is based on this 150 cap, rather than the stated 250. (Congestion control at 50 give me 75mpbs instead of 125mbps.) I have tested this directly through the Netduma and via 3 different routers, all with the same effect -- some in router mode and some in AP/bridge mode (although that causes another speed issue I can't figure out.) 

 

Deep packet mode is disabled, turbo mode is enabled, and super-turbo mode is disabled.

 

Why is 99% congestion control dropping my speeds by 40%? Any ideas on how to get this working properly?

Link to comment
Share on other sites

  • Administrators

Hey, welcome to the forum!

 

Congestion control can be quite conservative in order to prevent any local congestion which could explain the drops - this won't happen in DumaOS. 

 

However, lets assume that may not be the cause. Have you got 250/12 input into bandwidth settings? Have you got it setup like this other than when you lower anti-flood?

  • Reactive Algorithm
  • 100% anti-flood
  • Share excess enabled
  • Reset device prioritisation & apply
  • Disable IPv6 in WAN, LAN & misc
  • Disable deep packet in misc
  • Enable turbo mode
  • Ensure the ethernet cables you're using connecting the R1 to hub & R1 to PC are Cat5e+/can handle your speeds.
  • Do a wired speed test from a PC
Link to comment
Share on other sites

Thanks for the reply. I verified that all settings are exactly as you listed. Wired and wireless speed tests both still max at 150mbps when anti-flood is set to 99%. When I first set up the Netduma I may have set the bandwidth limit to 150, but I have changed and updated the values several times since and it only seems to recognize 250 when at 100%.

Link to comment
Share on other sites

  • Netduma Staff

Thanks for the reply. I verified that all settings are exactly as you listed. Wired and wireless speed tests both still max at 150mbps when anti-flood is set to 99%. When I first set up the Netduma I may have set the bandwidth limit to 150, but I have changed and updated the values several times since and it only seems to recognize 250 when at 100%.

 

As Fraser said, it sounds like it's being conservative, but it's going to work in a different way with DumaOS.

Link to comment
Share on other sites

  • 2 weeks later...

Ok I guess. Any chance that the compatibility with other wireless routers in bridge mode is going to change? I can't get any more than 30mbps when I switch any of my routers to bridge mode or even DCHP Only. If I bypass the Netduma or if I leave the router in normal mode I get full speeds.

Link to comment
Share on other sites

  • Administrators

There shouldn't be a reason you're not getting full speeds. I'll be happy to take a look in a 1 on 1.

 

Post in the 1 on 1 section: http://forum.netduma.com/forum/66-request-1-on-1/and I will have a look. Let me know dates/times you'd be available next week.

Please read this first before making the post: http://forum.netduma.com/topic/11450-read-before-posting-a-1-on-1-request/

Link to comment
Share on other sites

  • 4 months later...

I took a break from Netduma for a while because I couldn't get anything to work properly. I recently got a new modem and a new router to use as an AP, and I think some of the original issues are gone. However, I still can't get more than 400mbps wired directly to the Netduma (~950mbps direct to modem -- all Netduma setting guides followed and confirmed properly) but the real issue is the ~9mbps down and up that I'm getting when connecting through the AP. If I set it to router mode I get closer to 200mbps but I lose connectivity to other devices on my network. Going back to AP mode drops my speeds significantly 100% of the time. I have reset everything to factory defaults several times. Is this still something we could look at in a 1:1?

Link to comment
Share on other sites

  • Administrators

In your original post you didn't mention you had those high speeds. Enable super turbo mode as well and you should achieve higher - this will also disable congestion control so there are no restrictions, what do you get through the AP then?

Link to comment
Share on other sites

Yeah my speeds changed in the meantime. I did follow the guide to update settings for the higher speeds. I'm capped at 9 down and up with AP mode turned on.

 

Different modems, different speeds, different routers. All combinations have resulted in really slow speeds when using an access point.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...