Jump to content

Recommended Posts

Hello I can't seem to get upnp to work on the xr500. I tried playing some games on PC and got moderate nat, I then checked to see if any ports were opened on the router under upnp and it was empty. I don't want to DMZ my PC just to get open Nat please help.

Share this post


Link to post
Share on other sites

Hello I can't seem to get upnp to work on the xr500. I tried playing some games on PC and got moderate nat, I then checked to see if any ports were opened on the router under upnp and it was empty. I don't want to DMZ my PC just to get open Nat please help.

Please can you tell us the current firmware version you are using? If you are on version lower than 2.3.2.22 Then please update to the current version.

 

  • Installation flow improvement.
  • Added support for SHA256 certificates in lieu of MD5 for OpenVPN.

Bug Fixes:

  1. Fixes the UPnP port mapping issue.

Upgrade Instructions:

  1. Using the Download Link below, download and extract the new firmware to a convenient place such as your desktop. The filename after extracting is XR500-V2.3.2.22.img

    Download Link : http://www.downloads...0-V2.3.2.22.zip

  2. Run your web browser and open http://www.routerlogin.net.
  3. Click Settings => Administration => Firmware Upgrade page.
  4. Click Browser button and locate the firmware image file.
  5. Click Upload button.
  6. Wait for upgrade progress to complete.

If any problem occurs after upgrading, try clearing the configuration by pressing the Reset Button on Rear Panel until the Power LED blinks and hold on for 5 seconds at least, then the router will reboot with default configuration

Share this post


Link to post
Share on other sites

Hello thanks for the reply and yes I did update the firmware yesterday hoping it would fix the upnp but nothing has changed. Switched back to r1 and the upnp on that was working but I like the xr500 more because the connection is on point lol. I think its anti bufferbloat doing an amazing job but I have to DMZ the console to get an open Nat but for PC I'd rather the upnp was working rather than put my PC on DMZ.

Share this post


Link to post
Share on other sites

Setup is xr500 routers wan port connected to homehub2000 modem/router lan 1, I then setup pppoe on the xr500, then disabled the wifi on homehub and connected everything to xr500. I looked online and was told this setup was the closest I can get this modem/router to be in bridge mode.

Share this post


Link to post
Share on other sites

What is your physical setup? modem > xr500 etc

 

By DMZing the console you're essentially saying forward all ports to the console which explains your issue.

I removed my console from DMZ, I then turned it off to see if upnp would work for my PC games and when I checked upnp it is was still empty.

Share this post


Link to post
Share on other sites

You'll need to put the XR500 in the DMZ of the homehub by going to Advanced View' > ' Network Settings' then select DMZ, your router and click add. on the homehub itself. That will then forward all ports to the router and UPnP can do its thing unimpeded.

Share this post


Link to post
Share on other sites

Great thank you very much for helping Fraser upnp is working, too bad upnp is not working with pppoe though.

I use PPPoE and UPnP is working... I have a modem connected to the wan of the  XR500 which does all the heavy lifting. Can you put your hub into bridge mode? Or best go grab a modem, you can pick them up very cheaply, and it might cure your issues. Is the homehub still in router mode by any chance?

Share this post


Link to post
Share on other sites

I use PPPoE and UPnP is working... I have a modem connected to the wan of the  XR500 which does all the heavy lifting. Can you put your hub into bridge mode? Or best go grab a modem, you can pick them up very cheaply, and it might cure your issues. Is the homehub still in router mode by any chance?

i looked online on how to bridge homehub2000 and people all said the same thing, the closest i can get it to bridge mode is to use pppoe on the second router and just attach it to the via lan to homehub2000. The reason i used pppoe instead of dmz in the first place was because when i was using the Netduma R1 it showed this blue message saying i was behind another router as (opposed to modem ) the R1 was already DMZ'd and the only way for me to get rid of that message was to use ppoe on the R1 and it worked! upnp worked as well on the r1 but when i switched over with the same setup on the xr500 upnp did not work until Fraser told me to do the dmz method for the xr500. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×