Jump to content

Uncaught ReferenceError: d3 is not defined


Recommended Posts

Hello Fraser, Liam,

I got the error below just after clicking the QoS view in the menu. Is this related to something in particular?

Who is d3 in this case? Sounds like device3 or something...

Log shows only some info messages about applying QoS settings and nothing else special. I did not make any changes to the QoS function.

 

May 16 14:56:36 XR1000 user.info com.netdumasoftware.neighwatch: DHCP new event.  86
May 16 14:56:36 XR1000 user.info com.netdumasoftware.neighwatch: DHCP lease change.  89
May 16 14:56:43 XR1000 user.info com.netdumasoftware.neighwatch: DHCP new event.  86
May 16 14:56:43 XR1000 user.info com.netdumasoftware.neighwatch: DHCP lease change.  89
May 16 14:56:46 XR1000 user.info com.netdumasoftware.qos: applying qos for zone wan  89
May 16 14:56:49 XR1000 user.info com.netdumasoftware.qos: applying qos for zone lan  89
May 16 14:56:57 XR1000 user.info com.netdumasoftware.neighwatch: DHCP new event.  86
May 16 14:56:57 XR1000 user.info com.netdumasoftware.neighwatch: DHCP lease change.  89
May 16 14:57:37 XR1000 user.info com.netdumasoftware.qos: applying qos for zone wan  89
May 16 14:57:39 XR1000 user.info com.netdumasoftware.qos: applying qos for zone lan  89

 

image.thumb.png.5f6982bb9471f928718adac2fc51f0a4.png

 

Please let me know if this related to something I did wrong.

Best Regards,

Adrian

Link to comment
Share on other sites

Hello Fraser,

What firmware version are you on currently? If you click ok will it allow you to use the feature without issue?

XR1000 1.0.0.64_1.0.49

It allowed me to continue using the feature after clicking ok.

Nothing you did wrong! Do you have Armor enabled?

Armor is disabled.

Link to comment
Share on other sites

I use an incognito tab to login and clear the cache and cookies from before every login into the interface, I don't force any HTTPS from my point of view...

image.thumb.png.08ad763d45a30f0901c8ae3abef87c58.png

I set the Chrome add blocker extension to 'pause on all sites' before logging in using the incognito tab.

But perhaps you have some better ideas on how to avoid receiving all those errors from time to time...

Link to comment
Share on other sites

  • Administrators
2 hours ago, munteanadrian88 said:

I use an incognito tab to login and clear the cache and cookies from before every login into the interface, I don't force any HTTPS from my point of view...

image.thumb.png.08ad763d45a30f0901c8ae3abef87c58.png

I set the Chrome add blocker extension to 'pause on all sites' before logging in using the incognito tab.

But perhaps you have some better ideas on how to avoid receiving all those errors from time to time...

Are you connected directly to the XR via ethernet/Wi-Fi or do you go through any other devices such as switches, access points, powerline adapters?

Link to comment
Share on other sites

Are you connected directly to the XR via ethernet/Wi-Fi or do you go through any other devices such as switches, access points, powerline adapters?

Directly to XR via ethernet.

But the XR connected WAN to WAN with the ISP's router. The problem is that my device connected to the XR used for administration (my laptop) is currently offline. (see below snapshot)

image.png.61bc3679205818c7c7d3672b86c37998.png

Should I restart the one in bridge mode also (ISP's router)?

I currently use 2 LANs directly plugged into the XR which is connected WAN to WAN to the one from the ISP, and I normally use one of them for administration (e.g. laptop) and the other has custom DumaOS settings applied on it (e.g. PS5 device).

 

Link to comment
Share on other sites

It is quite frustrating for me that something happens to the LAN I have applied dumaOS settings, I play with the gaming settings (under geo-filter and ping heatmap) all the time, especially when u jump out from a game because you are not happy with the connection or so. For me is not obvious when gaming settings are working for real (doesn't matter if I use radius, polygon or ping assist features).

 

I started to use the geo filter the following way: by disabling that filter until getting into a lobby and starting an online matchup.

Link to comment
Share on other sites

  • Administrators

Take the ISP router out of bridge mode, then reboot the XR from the interface, wait 2 minutes, then access and copy the WAN IP shown in the System Information page. Paste that into the DMZ on the ISP router. 

Would be best to focus on the original issue and then we can get into the other things but the server could be outside your radius/zoom level or if no icons are appearing it could be allowed. You can draw a polygon and it will allow servers in that zone. It is also best to keep the filter enabled before you launch the game otherwise it may not block correctly.

Link to comment
Share on other sites

By take out you mean to call my ISP and ask them to take it out of the bridge mode completely since I can't do it myself or simply to unplug the cable between the routers and do the rest of the steps you mentioned above?

Link to comment
Share on other sites

  • Administrators
2 minutes ago, munteanadrian88 said:

By take out you mean to call my ISP and ask them to take it out of the bridge mode completely since I can't do it myself or simply to unplug the cable between the routers and do the rest of the steps you mentioned above?

Ah do you not have access to the ISP router? If you can call and they are able to set the DMZ for you that would be good. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...