Jump to content

OpenVPN hybrid vpn connection setup


Recommended Posts

Hello, 

I am trying to setup an openvpn configuration on the hybridvpn section of my router XR450 

Firmware version XR450 V2.3.2.114

I have a .ovpn file that works on my android. see below

 

client
dev tun
proto udp
remote <PERSONALDDNS.NET> 1194
resolv-retry infinite
nobind
remote-cert-tls server
tls-version-min 1.2
verify-x509-name raspberrypi_6366fed8-e944-49a4-8e9c-36983927cd90 name
cipher AES-256-CBC
auth SHA256
auth-nocache
verb 3
<ca>
-----BEGIN CERTIFICATE-----
<alpha numeric stuff>
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
<alpha numeric stuff>
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
<alpha numeric stuff>
-----END PRIVATE KEY-----
</key>
<tls-crypt>
#
# 2048 bit OpenVPN static key
#
-----BEGIN OpenVPN Static key V1-----
<alpha numeric stuff>
-----END OpenVPN Static key V1-----
</tls-crypt>

 

when i submit this in the advanced section I get this in the log:

neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can't ask for 'Enter Private Key Password:'.  If you used --daemon, you need to use --askpass to make passphrase-protected keys work, and you can not use --auth-nocache.

 Exiting due to fatal error

 

 

I have tried with username and password, as well as setup a user without a password. 

based on the logs, it seems to be the auth-nocache line. But I don't know how to proceed. Unfortunately I could not find a solution online.

Can I imbed the user name and password in the code? or is there a specific tag needed when adding a new pivpn user?

 

PLEASE AND THANK YOU IN ADVANCE!

 

Link to comment
Share on other sites

Bummer,  this is unfortunate. It is for a personal deployment of open vpn.  Is there any work around for this? Duma  v3?

 

Or perhaps through a server of some sorts. What are my options?

Link to comment
Share on other sites

15 hours ago, Netduma Fraser said:

You can remove the auth-nocache and replace it with auth-user-pass and make sure you've set a username and password for the server, enter it in the boxes on advanced and it might work

this is EXACTLY what i needed   THANK YOU  THANK YOU THANK YOU

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...