Jump to content
Tivo

XBOX Party chat no working with crossplay players

Recommended Posts

I have the same bunch of guys I play with on XBOX.
One of them switched to PC a while ago and since then, I'm unable to connect to an XBOX party if he's in it already. (He uses the XBOX companion app on his PC to connect)
If I get there first and then he joins, I get disconnected.

We thought maybe it was related to him but another friend switched over to PC and same thing happens.
Everyone else in the party can hear them but I always get disconnected after about 5 seconds.

I've tested multiple settings in my Netduma (enabling/disabling GeoFilter), making sure they were in the geo filter zone, remove the console from the list of devices, putting it in spectating mode, flush clouds, etc. Nothing seems to work.

uPnp is enabled and I manually configured many ports to get forwarded to my XBOX.

The weird thing I can hear them in game chat when I switch over.
If I join the party on my XBOX phone app, I can hear everyone and don't get disconnected.
The problem seems related to my XBOX party chat. Like I said, other XBOX players in the party chat have no problem hearing the PC players.


Anyone have an idea of what's going on and what I can do to fix this?

Share this post


Link to post
Share on other sites

First thing to check is do you receive an Open NAT on your console? Also if you can ask your friends on the PC to check if they get an open NAT on PC by going to PC settings > Gaming > Xbox Networking.

Share this post


Link to post
Share on other sites

Hi Fraser, thanks for the quick reply.

My NAT type is open. Both of them said their NAT type was always open but sometimes they had Toredo errors?
Still unsure why everyone else have no problem hearing them.

Share this post


Link to post
Share on other sites

Thanks for checking that. When they get the teredo error, there is a button that says fix it, if they click that and when it tells them to, do the test again does it switch to open then? When it's then open can you connect to them? If you can't then it's definitely not to do with NAT. I've done some research, and found that apparently IPv6 for their PCs should be disabled, here is a guide on how to do so if needed, once they've done that do the NAT test and fix if necessary and then try chatting again. Seems it is a common issue though so might be the case of trying a view different things.

https://www.tenforums.com/tutorials/90033-enable-disable-ipv6-windows.html

Share this post


Link to post
Share on other sites

Not sure if I can jump in on this as I'm having the same issue.  Only way currently to chat with PC players via Xbox is to bypass the Netdumer.  Definitely not a NAT problem and tried switching off IPv6...no luck

Any suggestions?

Share this post


Link to post
Share on other sites
3 hours ago, lsr101 said:

Not sure if I can jump in on this as I'm having the same issue.  Only way currently to chat with PC players via Xbox is to bypass the Netdumer.  Definitely not a NAT problem and tried switching off IPv6...no luck

Any suggestions?

If you bypass the R1 then you're probably bypassing the NAT issue of having two routers connected anyway. What is your exact physical setup and how have you set it up e.g. is the ISP router in modem mode? Are you using the Geo-Filter? If so have you added them to the allow list so your settings don't block them?

Share this post


Link to post
Share on other sites

Hi Fraser,

Thanks for replying.  The R1 was connected to my ISP modem and is in the DMZ (to prevent double-NAT). Xbox and Google WiFi are then connected to the R1.

Using Geofilter set to Germany (to try and increase my ping as it's 7-9ms locally, and believe I get compensated by MW servers).  Not sure how to create the environment in order to accept a particular 'peer' into the Geofilter, is there knowledge document somewhere for this pls?

Share this post


Link to post
Share on other sites
On 8/12/2020 at 1:27 AM, purplethingy said:

I feel this has Zero issue to the NETDUMA firmware. This happens to everyone I know because the Xbox app is Poopy.  

You're probably right, but it also means that I can't use the R1 with the Xbox so it's become a redundant purchase. 

@Netduma Fraser added Peer but still won't connect to party chat with PC players.

 

Share this post


Link to post
Share on other sites

Teredo is a Microsoft technology for interfacing between IPv4 and IPv6... Sounds to me like this is specifically an IPv6 issue.

DumaOS 3.0 has improved IPv6 support, so if you want I can add you to the beta, and you can see if the new IPv6 features help at all?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...