Jump to content
mountainping

Artificial packet loss. (Long read)

Recommended Posts

Artificial Packet Loss

 

Running into some issues with geo filter settings which are causing/mimicking packet loss. Experiencing Players skipping ,myself skipping/rubber banding,red bar etc..

NOTE: [wifi turned off & only game console and pc are connected via rj45 during all this] geo filter turned on / strict mode off, In / miscellaneous settings I have only multicast snoop enabled / And turbo mode enabled

Cloud : auto cloud disabled / bleeding edge disabled

28

26

28

________________

 

First off, I was playing a few pvp matches of Uncharted 4 I frequently got messages about my connection or icons indicating I was disconnecting for a moment . I found this odd because whilst playing destiny the day prior, I would find lobbies with hosts close to me but get kicked from them just before landing and starting the match. I can more or less equate this to my filter distance setting & maybe ping assist.

For starters I tried being advantageous and set my ping assist to 0 thinking I would find great lobbies (read somewhere on the Duma forums destiny doesn't use ping assist nor auto ping host) though when I did this I frequently got booted from a lobby before even landing/starting the match. (I would find hosts close though) My filter distance was at about 2000miles I believe.

Then I reduced the distance to about 1000 and left ping assist at 22ms. I found lobbies and they were great though I would be red bar and get a contacting destiny servers message after the match was over and looking for another lobby..

 

Next, uncharted 4. My settings were at 2000 miles 12ms ping assist. I found lobbies though would skip/rubber band hear and there. So I reduced to about 800miles with 25ms ping assist , found lobbies very close though this is where the artificial packet loss would start. The game would kick me mid game stating that I had continuous packet loss which was pretty apparent since I was skipping and enemies were skipping and teleporting everywhere.(hence where the title of this post comes from) Also in game it wouldn't show me other players ping bars in uncharted 4

It would only show 3 out of 10 people's ping bars through out the match(first times I seen it do this)

 

Next, Played a few matches of uncharted 4 with my filter distance changed & increased to 1337miles and 14ms ping assist and wala found lobbies close by with no issues and no skipping/teleporting from my teammates nor myself. The being bottled before landing into a Destiny pvp match also stopped and I was able to load into a match and play no problem. ALSO When I increased the distance I could see all of my teammates ping bars in uncharted and a couple of the enemies ping bars.

 

To conclude , I start to have connection issues when my ping assist is set to 0 near that regardless of distance. I also cannot lower my filter distance lower than say 1200 or so without experiencing "packet loss" (when in reality there is no packet loss, to be extra sure I ran another internet diagnosis from Duma GUI after experience these things and everything came back exceptional again with no packet loss.)

Any ideas as to what I can do differently to achieve a lower filter distance without it causing major connection issues? Or better yet what exactly is happening here when I decrease the geo filter distance and get booted or see packet loss after doing this?

 

kind regards

Share this post


Link to post
Share on other sites

I think you've misunderstood how ping assist works.

 

Ping Assist works independently of the Geo Filter radius, it allows you to also connect to hosts outside of the circle if your ping to that host is lower than the number you set.

It does not have any effect on anything within the circle. Ever.

 

If you're finding worse connections with your Geo radius set smaller then it's quite likely that you're cutting it short of the dedicated servers. That's assuming it plays on dedis and if it's even supported.

 

I think you're probably better off with the Geo filter disabled completely for Uncharted, unless another Mod/Admin has told you otherwise.

Try with it disabled and see how it plays.

 

 

Are you playing on a wired or wireless connection by the way?

 

As you seem to be suffering a lot of packet loss, I would test your line properly. Rather than use the Netduma Diagnostics, which is just a snapshot, you should download some free software to check. I'd recommend Ping Plotter, it's easy to use and has instructions.

Share this post


Link to post
Share on other sites

I think you've misunderstood how ping assist works.

 

Ping Assist works independently of the Geo Filter radius, it allows you to also connect to hosts outside of the circle if your ping to that host is lower than the number you set.

It does not have any effect on anything within the circle. Ever.

 

If you're finding worse connections with your Geo radius set smaller then it's quite likely that you're cutting it short of the dedicated servers. That's assuming it plays on dedis and if it's even supported.

 

I think you're probably better off with the Geo filter disabled completely for Uncharted, unless another Mod/Admin has told you otherwise.

Try with it disabled and see how it plays.

 

 

Are you playing on a wired or wireless connection by the way?

 

As you seem to be suffering a lot of packet loss, I would test your line properly. Rather than use the Netduma Diagnostics, which is just a snapshot, you should download some free software to check. I'd recommend Ping Plotter, it's easy to use and has instructions.

I am finding games with A+ connection ping wise when I set the geo filter radious small say about 1000miles. Though when I do this it start skipping around for what ever reason. This has nothing to do with my wan connection and is completely independent to the geo filter being set to 1300miles or lower for example.

Uncharted 4 is peer 2 peer connection based. Non dedicated.

I played it with geo filter off for a few games and the ping/hit detection felt a lot heavier which is to be expected since I was connecting to hosts on the opposite side of the USA from where I am, as to when I set the radious some what small I connect to hosts the next state over or even in my own state.

 

I play direct wired never wireless. and I understand what you are saying though my line has been tested before, through say ping plotter and it comes back with great results.to just be frank, I do not have actual packet loss on my line. The packet loss is artificial and pertains only to the geo filter being active. It non existent when geo filter is off or the geo filter radious is set to be very wide covering most of the USA.

 

Thanks for reply by the way! Still not quite sure why this issue persists when filter radious is set small.

Share this post


Link to post
Share on other sites

Your cloud settings are very old. You can now re-enable auto & bleeding edge cloud - it's updated for Destiny.

 

What are your bandwidth speeds? You mentioned you have turbo enabled, is this required for your speeds. I would first disable this and see if your issue occurs.

 

Colonic has described how ping assist already. The Geo-filter itself will not cause packet loss or anything like that, it will simply allow you to force the servers that you want to play on. Also what are your congestion control settings?

Share this post


Link to post
Share on other sites

I enabled auto cloud and bleeding edge though the same issues are still occurring when geo filter set low say about 700miles with strict mode off(I've never used strict mode btw). Both in uncharted (I have to leave the distance above 1400 or else strange things happen like peoples ping bars not showing up) and destiny. In destiny I set radius to 750miles found a match with people very close to me though as we were flying in half way through I got beaver booted from lobby with a beaver error code and didn't even get to see the map that was about to be played. Also, my NAT is open.

 

My bandwidth package is for 100down/10up

reccomend I still disable ?

Congestion control sliders are at 100% for both upload and download.

Only 2 devices are connected and 1 person using the network (myself)

and anti flood is set to the console I am using (ps4). Anyone else get booted from lobbies when your geo distance is set below 900miles?

 

for the most part I find lobbies very close with a low distance filter setting, although when i am put into that lobby, i end up being booted(destiny) or strange things happen in the match where i find myself teleporting/rubber banding & enemies standing still. as well as packet loss messages in game within -> (uncharted 4) . It's not until I increase the distance in miles to around 1500 and up do things seem normal, somewhat defeating the purpose of trying to find lobbies close by.

Share this post


Link to post
Share on other sites

Yes disable turbo, you do not need it for your speeds. What is it like after disabling that? 

 

Congestion control recommend putting to 70/70. 

 

Destiny you may get booted, it seems there are always more IDs to add to the cloud for that game which ill keep adding. 

 

Do the above and see if it's any better please.

Share this post


Link to post
Share on other sites

Yes disable turbo, you do not need it for your speeds. What is it like after disabling that?

 

Congestion control recommend putting to 70/70.

 

Destiny you may get booted, it seems there are always more IDs to add to the cloud for that game which ill keep adding.

 

Do the above and see if it's any better please.

I just disabled turbo , left geofilter active at 1000miles and still the same booting issues persist in destiny. In uncharted when I find a lobby with geo filter set at 1000miles Strange things still occur. Sometimes I'll get booted, or I will miraculously load in the lobby & hit detection feels crispy(Feels like I'm playing on LAN), but when I do load into a lobby, like I mentioned earlier with the geo filter is set low around 1000miles uncharted 4 keeps indicating I have packet loss, and show me a disconnection icon in the middle of the screen.this never happens with geo filter off

 

What if the geo filter had a some sort of smart action that allowed you to find and connect to the lobby and then turn itself off that way it wouldn't boot you from that lobby? Hmmm..

 

Here is an id I had to whitelist shortly after installing the r1 as my router or else I couldn't log into destiny on ps4 at all. ID: 78cd59246a17ccd1

 

Thank you for replies btw.

Kind regards

Share this post


Link to post
Share on other sites

Thanks for the ID, I'll try to do another cloud update tomorrow that should help with booting.

 

Also post in the 1 on 1 section with dates/times you're available & I'll take a look.

Here is another id that I whitelisted on my end , without it white listed I cannot connect to halo 5 and or sign into halo 5 with geo filter enabled & set to within my states radius.

ID: 90d1723d6e2f0d12

 

Worth to note that I Do have both auto cloud and bleeding edge cloud enabled . Along with "host filtering service" set to xbox1 console, Halo 5 instead of Xbox live.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...