Jump to content
Jetset57

Xbox One - Double NAT Detected

Recommended Posts

I'm using an R1 router with the ZyXEL C3000Z DSL modem (CenturyLink).

 

This is what my Xbox One lists under Current Network Status:

Wired

IPv4

NAT Type: Moderate

Double NAT detected

 

I've forwarded all necessary ports and I've placed the console into DMZ mode to no avail. I'm at a bit of a loss at what to do. If anyone has any suggestions, I'd love to hear them.

Share this post


Link to post
Share on other sites

I'm using an R1 router with the ZyXEL C3000Z DSL modem (CenturyLink).

 

This is what my Xbox One lists under Current Network Status:

Wired

IPv4

NAT Type: Moderate

Double NAT detected

 

I've forwarded all necessary ports and I've placed the console into DMZ mode to no avail. I'm at a bit of a loss at what to do. If anyone has any suggestions, I'd love to hear them.

Hi,

 

Welcome to the forum

 

You need to put the R1s WAN IP into DMZ on your ZyXEL

 

Here is a guide on getting an open NAT.

 

http://support.netduma.com/support/solutions/articles/16000022359-how-do-i-open-my-nat-

Share this post


Link to post
Share on other sites

I'm using an R1 router with the ZyXEL C3000Z DSL modem (CenturyLink).

 

This is what my Xbox One lists under Current Network Status:

Wired

IPv4

NAT Type: Moderate

Double NAT detected

 

I've forwarded all necessary ports and I've placed the console into DMZ mode to no avail. I'm at a bit of a loss at what to do. If anyone has any suggestions, I'd love to hear them.

 

Hi, welcome to the forum! I'd recommend the suggestion above, it should hopefully resolve this issue. Please let us know how you get on :)

Share this post


Link to post
Share on other sites

You need to put the R1s WAN IP into DMZ on your ZyXEL

This worked initially; The console and games had an Open NAT... But today I noticed that the console is now in a Strict NAT type and I've no idea why. No settings were changed.

 

Just to clarify, I shouldn't need to port forward in the ZyXEL interface if I am port forwarding in the Netduma interface right?

Share this post


Link to post
Share on other sites

As long as the R1 is in the DMZ then no further action needs to be done on the Zyxel interface, except perhaps disabling it's UPnP and any current port forwarding rules present on it. The Strict NAT is likely caused by the Geo-Filter being enabled (doesn't mean you have a strict NAT just that the Geo-Filter is blocking the server it uses to read the NAT status). Disable the Geo-Filter then enable when you're on the game itself, should then see an open NAT.

Share this post


Link to post
Share on other sites

As long as the R1 is in the DMZ then no further action needs to be done on the Zyxel interface, except perhaps disabling it's UPnP and any current port forwarding rules present on it. The Strict NAT is likely caused by the Geo-Filter being enabled (doesn't mean you have a strict NAT just that the Geo-Filter is blocking the server it uses to read the NAT status). Disable the Geo-Filter then enable when you're on the game itself, should then see an open NAT.

 

I've done everything you've suggested, but I've now reached the odd dilemma in which my Xbox One's network settings still show Strict NAT and Double NAT Detected, but every game I've tried shows an Open NAT.

 

So... Is my console actually in an Open NAT state right now, but it's just displaying the incorrect NAT status?

 

Edit: Games are now showing moderate NAT, console is showing Strict. How fun.

Share this post


Link to post
Share on other sites

I've done everything you've suggested, but I've now reached the odd dilemma in which my Xbox One's network settings still show Strict NAT and Double NAT Detected, but every game I've tried shows an Open NAT.

 

So... Is my console actually in an Open NAT state right now, but it's just displaying the incorrect NAT status?

 

Edit: Games are now showing moderate NAT, console is showing Strict. How fun.

 

Since this is an Xbox One issue you could try this solution:

 

- Go to Xbox dashboard.
- Go to system settings
- Go to network
- Go to advanced settings
- Go to alternate MAC address Clear
- Your Xbox will tell you It will restart.
- Once you have restarted the NAT type should be open.
 
Originally this guide was for unavailable NAT types, though it could work in this case as well. Please let us know if that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×