Jump to content

Netduma R2 Double nat issue on Xbox Series X

Recommended Posts

What's your setup? Is your R2 behind any other Routers? If it's connected to your Gateway/Modem/ONT, you should be fine, but still check its settings to see if it has a "DMZ" or "Passthrough" feature, and if it does, put the R2 into that mode. Also, do you need to port forward any ports for this remote play operation? To test this, put the XBOX into DMZ mode on the R2. If it works, then you need to forward ports to your XBOX. You can look up the ports, or turn on UPNP.

Link to comment
Share on other sites

  • 4 months later...

I have had the same issue and I have tried the methods mentioned but nothing changes ,still strict nat on xbox series x with double nat detected ,virgin hub with the r2 connected to it ,dmz on my isp is the same as my wan on the r2 ,and no change I have also tried my xbox ip into my r2 router and still no change ,am I missing something or what else am I doing wrong 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...