Jump to content

Wifi Local IPv4 Network not working

Recommended Posts

Hello this is very similar issue to




My Local network works fine on wan local means via wired all works fine however via wifi I can't access local network, well technically I can but take 5 - 10 minutes to load simple http page and services like ssh just timeout it works if I connect ethernet.


I noticed it works fine with local IPv6 but not IPv4 so seems there is some firewall, or configuration in the router which we don't have access too... Would be great if you could look into this as I'm not the only person with same issue as above on netgeat forum.

looks like software issue with IPv4 it's blocking local rules on wifi well making it a lot slower takes forerver to load anything. The internet works just fine.


Yes I have disabled QoS and everything possible I tried upgrade to beta too and even downgrade to 2.0. tried enable all traffic in the traffic control.

did over 10 Factory resets that's why I discovered it's issue on IPv4 via Wifi


Let me know if you need more details but clearly there is something up with IPv4 Local something is making the connection super slow it just timeouts.



Link to comment
Share on other sites

  • Administrators

I think probably the best way of doing this is instead collecting the relevant information so I can pass it onto NG. I don't think there are any settings that can be changed to make it work.

I'd suggest going here: http://routerlogin.net/debug.htm then enabling LAN/WAN Packet Capture then click start capture. Attempt the access on WiFi and once you've done that a few times, go back to the page and save the debug log. Send it to me in a PM and post here when you have done that. I can then pass that onto Netgear for them to take a look at.

Link to comment
Share on other sites

  • Administrators

That is great thank you very much, I've passed it onto the NG dev. If I get any information/updates regarding this I will let you know. In the meantime, if you need to then you may want to look into another way such as using another router downstream for these purposes.

Link to comment
Share on other sites

  • Administrators

Okay so I have some feedback and they would like more information please.

  • Can you make a backup config of the router settings and then provide this?
  • Go to routerlogin.net/debug.htm and Enable LAN/WAN Packet Capture and click start capture
  • Use WireShark on the PC and capture packets in parallel to the router capturing packets
  • Attempt the local connections that are the issue 
  • Go back to debug page and click Save Debug log
  • Save Wireshark capture
  • Put the config, wireshark capture and debug log in a zip file 
  • Send it to me in a PM
  • Post here when you've done so 
Link to comment
Share on other sites



Thank You for the update, I have send the update.


I noticed the issue is between wifi and lan


example I can connect device which work this way


Wifi to Wifi works

Wifi to Lan Nope

Lan to Lan Works

Lan to Wifi Nope

And vice versa


So issue is between communication with lan and wifi inside the router.


Link to comment
Share on other sites

  • 2 weeks later...

I did some research and seems issue is related to




With VLAN as my Fiber require to use VLAN 10 and I expirence the same issue.


This issue seems to be since 2019 so i guess it's impossible fix for this router?



I guess my idea is to get some modem between fiber and router which support vlan and set is as internet gateway so router don't need to use vlan anymore

Link to comment
Share on other sites



I can confirm the issue is VLAN,

I have used my ISP router as a bridge to XR500 and local network works just fine now.

So once VLAN is enabled on XR500 local network just don't work correctly.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...