Jump to content

What am I doing wrong???

Recommended Posts

So I just purchased the XR500 two weeks ago. I previously had the R1, and figured I'd upgrade hardware, anyways, I've got a PS3 playing BO2 and went to do a speed test on speedtest.net, connected to a laptop windows 10 with a CAT 6 Ethernet cable. The speed test readings seem to be weird at best.... I'd get a 15 to 20 ms ping.

For example: My speeds are 120mb down / 5mb up through Comcast at 100% anti-bufferbloat. If I decrease only the upload bar say to 90% and leave download alone and do a speed test, BOTH down and up load speeds decrease versus only the upload. I would assume I'd be getting approx. 120mb down and 4.5 up.

Also I'd do a dslreports test to test for bufferbloat. My bufferbloat NO LIE at 70% sliders down and up, its between 500-1000ms..if not more sometimes. Getting C and D grades.

Is this the router??? I've talked to Comcast and they say the line is fine. Funny thing is I ran the same tests on my PS4 and it worked fine with the R1. (I don't have it any longer)


Any help or thoughts as to what's going on?


Link to comment
Share on other sites

  • Administrators

Hi - could you go through this QoS setup guide:


When going through the guide double check you have set the correct total speeds for your connection in Anti-Bufferbloat. Also make sure you haven’t accidentally disabled Share Excess in Bandwidth Allocation. 

After going though all of that could you then check your speeds and bufferbloat results using your PC. Don’t use a console, their speed tests are often very unreliable. 

Let us know what you’re getting after that and we’ll help you with the next steps. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...