Jump to content
green1234

QOS distribution bug/issue when new devices connect

Recommended Posts

Misc Background info: I have the Wi Fi switched off on the R1. I use my old Linksys EA6900 as a wireless access point. At first, I turned off DHCP on the Linkysys and it worked fine and out of interest set it to bridge mode and it worked exactly the same except many of the menu settings removed from the Linsys Interface, so I left it in bridged mode as it seemed better that way. Anyway, either bridged or not the Linksys appears with its own 192.168.88. IP address allocated by the Netduma R1 and I can log into it via that IP address.

Recently I got the R1 singing along perfectly with zero BB, set to always around 80%. So I did a nice clean reboot of everything waiting 5 minutes between ISP Router > R1 > connected WiFi AP (EA6900). Then started switching on wifi devices within the home.

 

Problem:

When I did a speed test on the first wifi device I switched on (iphone) I got full speed 68/18 (this is my 100% max speed) and the associated lag spikes on the ping plot as if BB was set to never and NOT the expected 62/14 from BB Always and no lag spikes. Three more tests and the same problem. I had to do 2 things to get it working:

1. Set the QOS slider for the Linksys Wirelsss AP to ZERO 

2. Update distribution both download and upload.

The image below shows the 4 speed tests run from a newly connected  iphone, the 4th test finally shows no lag on the network (pingplotter running on the main PC)  and I only achieved this after setting the linskys slider to 0%

2054790770_wifiQOS.thumb.JPG.84db632ba01150943a4f2b85b84f4986.JPG

 

Then I switched on the mac connected by wifi. The exact same thing happened I got 100% speeds (not the correct lower speeds) and when I checked pingplotter (running on the main PC) I had lag spikes 3 tests giving full bandwidth speed, so the mac was unaffected by the Always BB setting. 

So, I update distribution on both upload and download within the R1 interface and hey presto, everything worked again,  speed test gives slower speeds (62/14) and no network lag on pingplotter.

Conclusion:

Each time a new device connects I need to go into the R1 interface and update distribution.

So I think this might be a bug. I don't think I should need to consistently update distribution whenever a new device might join the network in order to correctly place it within the QOS umbrella. 

So far, each time a new device connects I tried 3 speed test and got 100% speeds and will see the accompanying lag spikes on pingplotter until I manually going into the R1 and update distribution with these new devices on the petal in order to get everything within the QOS umbrella. If I gave the R1 more time, would it have done this automatically?

Share this post


Link to post
Share on other sites

You shouldn’t have to do that. Are you sure the Linksys is in bridge mode? This is usually for when you’ve connected a router to it and routing all traffic from the Linksys to that router. This could be the cause, do you have the option for AP mode? If so I’d recommend doing that and it should work then.

Share this post


Link to post
Share on other sites

I think I wasn't being patient enough. I was eagerly speed testing within seconds of a new wireless device connecting.

I noticed recently through the system logs that it takes a brief amount of time for the QOS to be applied and it's possible by the third test the R1 had settled down and it had nothing to do with moving the slider to 0% for the Linksys. The same thing was happening when I tried the original firmware. I've also gone back to 70% BB as once all the household devices connected I found 80% a bit too ambitious.

 

It's all working well and after trying the original firmware again I decided to come back to DumaOS as its super good at picking up the high priority packets automatically and I feel more confident it does its job when gaming on either of the two pc's or switch without me checking or messing around with it all the time.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...