Jump to content

Switched to 5G and now router won't appear under my network list

Recommended Posts

Just got the NetDuma R1 was super excited and I got it set up and running. I went under the settings panel and noticed there was an option to change the frequency from 2.4g to 5g. I clicked 5g and clicked save, the web browser went into a loading screen and now my netduma router disappeared (cannot connect to it). It does not appear under my network list. I tried to reset both the netduma router and my home router but that did not seem to work. Can still connect to my home router (hence how I have internet at the moment but my netduma router has disappeared all together. Not really that techie.


Any suggestions?



I got the router to appear under the network list by resetting it (pressed the reset button) but cannot connect to it. It keeps saying I do not have the correct password.

Any solution around this? I tried the same S/N # but it is not working.

Link to comment
Share on other sites

Did you try disconnecting power to reboot it?  Also, there is a factory reset button on the unit.  Once you press it, you should hear a beep that confirms that it is resetting.



Yep, did that. But now I cannot connect to the network. It appears under the network list but it keeps saying invalid password whenever I try to connect to it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...