Jump to content

"Can't get a Teredo IP address"

Recommended Posts

So I thought I had this all worked out yesterday but after a couple of hours of not playing and leaving the Xbox on, I returned to get the same "Cannot connect to Destiny servers" message again. I ended up unplugging everything and using my AT&T router to get through raid night. Today I decided to do a factory reset on the NetDuma and start from scratch. Below is my process and current outcome.


1. followed quickstart guide to the letter and did not set up any geo-filter device so it would be disabled no matter what.

2. turned on Xbox which is wired to the NetDuma router and had a moderate NAT.

3. Followed the instructions here for getting an open NAT and after enabling upnp Forwarding I restarted my console and had an open NAT.

4. Attempted to launch Destiny and received the "Cannot connect to Destiny servers" message with the Marionberry error code which is a local networking error as if I wasn't connected to the internet.

5. Went back to the link in step 3 above and continued down the page to the DMZ section. I did in fact have that blue box on my device manager page so I followed the instructions to add the NetDuma IP to the DMZ of my AT&T router. After rebooting the NetDuma it now displayed my public IP.

6. I reset my Xbox and following that had a strict NAT

7. I continued down the page from the link in step 3 above all the way down to the video for how to get an open nat, upon trying the "Test multiplayer connection" option I get a message that says "Can't get a Teredo IP Adress" despite that I am connected to Xbox Live, can browse the web through the Edge browser, can see all of my friends online and access the store with no issues except with multiplayer games, which act like I'm not connected at all.


I have none of these issues when I connect my Xbox directly to my AT&T router, I bought the NetDuma to get an improved matchmaking experience. I'm hoping there's a simple fix for this that I'm just missing, but so far I've spent two days of trying to get it to work, to no avail.

Link to comment
Share on other sites

  • Administrators

Hey, please try the following: 

  • Hard turn off the Xbox
  • Remove UPnP and port forwarding from the AT&T 
  • Disable UPnP forwarding from settings > miscellaneous
  • Ensure only UPnP OR port forwarding on the duma is enabled. Not both. 
  • Power on Xbox, ensure it's connecting via automatic settings and do a network test

Does this resolve the issue?

Link to comment
Share on other sites

Upnp and port forwarding were disabled on the AT&T router from the beginning and upnp was enabled only on the NetDuma. Additionally I've just spent the last hour attempting to get my Xbox to work on the AT&T router again. Every time I have to reboot all the devices after making those changes it takes 10-15 minutes. Maybe others don't have these kinds of issues but I'm put off by them to be sure. I'm a fairly tech savvy guy who's worked in hardware, software and networking for a couple of decades and this process should be much easier.


Perhaps it's just AT&T's hardware and network that are making it a challenge, but until I can know for sure what to do within the Uverse environment, I think I'm through trying things.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...