Jump to content

Recommended Posts

Hey all,


I recently built a NAS for our home network to share media and to hold backups. After several hiccups in the build process, we finally installed FreeNAS on it, only to see that transfers were always being halted when sending to the CIFS Share, and on the odd occasion that it didn't halt, it would only transfer at around 70KB/s! That was ridiculous, given we specifically bought a gigabit NIC for the box and plugged it in through ethernet to ensure it would be able to cap out the drive speeds.


After ages of testing I switched over to nas4free since people had said good things about it, but there wasn't any noticeable difference. However, at this point I realised that the transfer speed was stuck at ~77KB/s and I had set my Congestion Filter to 70% (Upload Speed set to 1Mbps because that's all we get realistically). I tried setting it to 100% and lo and behold, the transfer speed crept up towards the 100KB/s mark. I tried placing false values in the Bandwidth inputs to see if it would raise any barriers, and files started transferring at 2MB/s! This was extremely relieving for me, especially because any hangs had disappeared from the transfer. I then plugged the client computer straight into the same switch as the NAS and files began speeding to and from the NAS at 115MB/s - I know WiFi has its limitations, but that's not the main point of this post.


So, TL;DR, the Congestion Filter on the R1 seems to be throttling transfers within my local network. This simply cannot do, since I had to set our Upload Speed to 300Mbps to make it transfer at 'normal' speeds, but then setting the Congestion Filter to 70% will have no effect since 300 * 0.7 = 210Mbps, much higher than our 1Mbps Upload Speed.


Any fix(es) for this?


Thanks in advance.

Link to comment
Share on other sites

Does pressing reset distribution under device prioritisation fix it? :)

Thanks for the quick reply. This seems to have fixed it for now, but I'll see if any issues pop up as we continue testing it.


Thanks once again!!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...