DumaOS on the Netduma R1 is now in Open Beta! Learn more here: http://forum.netduma.com/topic/26315-dumaos-on-the-netduma-r1-is-now-in-open-beta/

 

Jump to content
Sign in to follow this  
Pete

Slow wifi

Recommended Posts

I just upgraded my internet from 50/10 to 300/25 mbps. Ethernet speeds are normal and working fine but wifi is way off.

Running speed tests with default router settings gives less than 1 for both up and down (tried 3 different speed tests multiple times on both laptop and cell phone). I tried this with the default (let the router decide between 2 and 5 G), then I tried separating frequencies and tried each one with both devices. Surprisingly the 2G did better than the 5G even when standing next to the router with all of my other wireless devices unplugged to minimize interference.

Speeds were always 50/10 before but after upgrading internet speeds the wifi seems broken.

I did a erase settings from the admin menu and then did auto setup. Router detected the correct speeds and as I said before ethernet speeds are correct. 

I verified the default settings were as expected. Then I tried to disable qos but that did not help so I turned qos back on.

What settings should I change from default to try and correct this?

Thanks in advance.

Share this post


Link to post
Share on other sites

Use a WiFi analyser to find the least congested channel in your area. Depending on where you live there could be a lot of WiFi signals broadcasting on the default channels.

 

Also have you updated Anti-Bufferbloat to reflect your new speeds?

Share this post


Link to post
Share on other sites

Use a WiFi analyser to find the least congested channel in your area. Depending on where you live there could be a lot of WiFi signals broadcasting on the default channels.

 

Also have you updated Anti-Bufferbloat to reflect your new speeds?

 

The Anti-Bufferbloat did reflect my new speeds. As far as congested channels, I never had a problem with them before.

The problem actually seems to be fixed now. What I did (out of curiosity) was enable the guest wifi and ran a speed test on that. Speeds were much improved so I disabled the guest wifi and tried a speed test again and now speeds seem to be proper.

Weird issue and fix but I suppose that stuff can happen from time to time. 

Thanks for the support Fraser!

Out of curiosity, any idea when the next firmware update will be and what it might include? (I'm always curious)

 

Edit: 

One hour later and wifi speeds are suffering again. Upload seems stable but download is less than half as tested with iPhone 8 and gaming laptop with AC adapter.

Is there a wifi analyzer that you recommend? I used windows wifi analyzer and see no issues. I really don't think that congested channels is my issue but I will follow your troubleshooting tips as suggested. Again, the router is updated with my new speeds.

Share this post


Link to post
Share on other sites

Thats definitely weird! I'm not sure when it will be available but it is mainly fixes, Nintendo Switch will be a new device type. 

 

I've sent you a PM with something to try.

 

I don't have any specific recommendations for a wifi analyser unfortunately but should be some decent free ones online

Share this post


Link to post
Share on other sites

I just upgraded my internet from 50/10 to 300/25 mbps. Ethernet speeds are normal and working fine but wifi is way off.

Running speed tests with default router settings gives less than 1 for both up and down (tried 3 different speed tests multiple times on both laptop and cell phone). I tried this with the default (let the router decide between 2 and 5 G), then I tried separating frequencies and tried each one with both devices. Surprisingly the 2G did better than the 5G even when standing next to the router with all of my other wireless devices unplugged to minimize interference.

Speeds were always 50/10 before but after upgrading internet speeds the wifi seems broken.

I did a erase settings from the admin menu and then did auto setup. Router detected the correct speeds and as I said before ethernet speeds are correct. 

I verified the default settings were as expected. Then I tried to disable qos but that did not help so I turned qos back on.

What settings should I change from default to try and correct this?

Thanks in advance.

You didnt disable WMM did you? Also when you said you erased from admin settings have you tried a factory reset using the button at the back of the router? I found that I had better results using that for a factory reset than using the one in the menu for some reason, and at this stage it could not hurt to try that way then set up using, no back ups. I would try Also don't turn on 160Mhz or untick 20/40Mhz coexistence leave them as they are. Unless you have faulty hardware that's what I would try as a last resort.

Share this post


Link to post
Share on other sites

Thats definitely weird! I'm not sure when it will be available but it is mainly fixes, Nintendo Switch will be a new device type. 

 

I've sent you a PM with something to try.

 

I don't have any specific recommendations for a wifi analyser unfortunately but should be some decent free ones online

Tried your advice in the PM but that made it worse so I undid that change.

Upload speeds are reasonably close to what they should be but download seems to be the main problem since they are less than the upload during speed tests.

That really should not be the case since I get 300 down and only 25 up. Sometimes I can get around 70 down but it comes and goes and is still less than 1/3 of the speeds I should see.

Checked wifi analyzer again and router seems to be selecting the least congested channel. I really don't have too many strong wifi networks nearby though.

 

 

 

You didnt disable WMM did you? Also when you said you erased from admin settings have you tried a factory reset using the button at the back of the router? I found that I had better results using that for a factory reset than using the one in the menu for some reason, and at this stage it could not hurt to try that way then set up using, no back ups. I would try Also don't turn on 160Mhz or untick 20/40Mhz coexistence leave them as they are. Unless you have faulty hardware that's what I would try as a last resort.

I don't normally disable WMM but I did try it just to see and didn't make any difference in my tests.

I used to do the factory reset by using the button on the back but after the second or third time I did that (during previous firmware upgrades) the button got broken so I can only do it from the admin settings now.

I did not try to load any saved settings when I reset to factory, I always just adjust the settings I need to (such as qos).

I left all wifi settings as default but when I didn't get expected speeds I tried changing some different things. Some made it worse and some made it a little better but nothing has been able to give me anywhere close to the 300 down that I should be able to get close to. I have tried with iPhone 8 and gaming laptop with ac wireless adapter.

 

 

I will try to see if I can get the router to do a factory reset using the button on the router but can't try to fix that now because family is using the internet.

Share this post


Link to post
Share on other sites

Tried your advice in the PM but that made it worse so I undid that change.

Upload speeds are reasonably close to what they should be but download seems to be the main problem since they are less than the upload during speed tests.

That really should not be the case since I get 300 down and only 25 up. Sometimes I can get around 70 down but it comes and goes and is still less than 1/3 of the speeds I should see.

Checked wifi analyzer again and router seems to be selecting the least congested channel. I really don't have too many strong wifi networks nearby though.

 

 

 

I don't normally disable WMM but I did try it just to see and didn't make any difference in my tests.

I used to do the factory reset by using the button on the back but after the second or third time I did that (during previous firmware upgrades) the button got broken so I can only do it from the admin settings now.

I did not try to load any saved settings when I reset to factory, I always just adjust the settings I need to (such as qos).

I left all wifi settings as default but when I didn't get expected speeds I tried changing some different things. Some made it worse and some made it a little better but nothing has been able to give me anywhere close to the 300 down that I should be able to get close to. I have tried with iPhone 8 and gaming laptop with ac wireless adapter.

 

 

I will try to see if I can get the router to do a factory reset using the button on the router but can't try to fix that now because family is using the internet.

The button on the back is recessed its a small pinhole, never heard anyone breaking that! WMM should not be disabled. HT160 and 20/40 coexistence should always be left at default which is off. Avoid changing anything on the Netgear Wireless advanced settings page, apart from turning off router pin for WPS. Have you disabled antibufferbloat and QoS? There really should be no reason you are seeing such a drop unless the hardware is faulty. For issues like this I would suggest Netgear Support or if its really new take it back and swap it.

 

 Hardware faults do occur even on new equipment so if the issue remains I would contact Netgear support as they should RMA your router if you cant take it back to where you bought it, although you will have to tell them the pinhole reset button was broken, that itself should not happened so tell them it broke when pushed gently doing a reset, its a tiny hole and very small button... most odd. I would want it swapped out for that alone tbh. Finally what frequency is giving you the bad download speeds. If its both 5Ghz and 2.4Ghz I would say that points to hardware issues yet again, unless something is causing massive interference on both bands which although possible is highly unlikely. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×