Jump to content

Recommended Posts

Hey guys, ive tried everything on settings with my netduma r1.

 

I get strict nat every time i open up destiny 2 on my pc.
 

just for the record im a big noob at know what the different things are in settings, just so you know :)

could really use some help thx.

 

best regards BeNNerG

Share this post


Link to post
Share on other sites

Hi, welcome to the forum!

 

If you go into Settings > UPnP, do you have this enabled? Make sure it's enabled, then make sure there are no rules set in Settings > Port Forwarding.

 

On the Host Filtering page, you'll need to make sure your PC has the 'Xbox Live' service. (It's a bit confusing I know, but the Xbox Live service contains all the ports you need to properly filter PC games).

 

With Strict Mode disabled on the Geo-Filter, do you still get a strict NAT with these settings?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×