Jump to content

Trouble accessing the XR500 dashboard using a mobile device

Recommended Posts

I just got an XR500 router, specifically for the DumaOS features. Right now my desktop is out of commission, and personally, I don't see myself building a new pc soon, due to ridiculous memory, and video card prices.


Out of the box, the router works great. I used the Netgear Nighthawk app to setup the routers basics. I tried logging in to the router via Chrome(and every other browser I can think of on Android), and I can "get into" the dashboard. But it constantly gives me an error, see attached screenshot. Clicking on any of the icons does nothing. I tried rebooting while it sits on this screen, no luck.


So basically I'm sitting here with a 300 dollar router where I cant access 98% of its features. I have also tried pulling the desktop version of the site, no luck. Is there any way around this? Or do I have to wait for a dumaOS app to come out, that has been mentioned for months that it is coming....but when?


Anyone have any ideas?


View the full article

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...