Jump to content

XR500 Wireless Constantly Slows/Disconnects

Recommended Posts

I just recently replaced my Aeris DOCSIS 3.0 Modem and Asus AC66RU Router with a Netgear CM1000 and XR500 when I upgraded to Xfinity Gigabit, and so far it has been a nightmare.


Wired works fine. I am able to reliably get 980+ Mbps and low latency on my desktop and PS4 Pro that are wired into the XR500. 


Wireless has been terrible. At first I thought it was just my first gen Vizio smart TV platform/old 2.4ghz only WiFi adapter...but both a new Roku Express and my Pixel have issues on 2.4ghz or 5ghz. Sometimes it will let me get a few episodes into Netflix and other times it will drop connection after only a few seconds. Sometimes the connection comes right back and other times I have to reset the router in order to restore the internet -- though the devices will still "connect" to the router the internet will just fail to work.


I have done the following:


-Verified my modem's status/connection strength (all channels are locked in and around +/- 8 or 9 dbv and noise level is good

-My modem is on a direct line from the main splitter into my apartment with nothing else sharing it

-Verified my modem is running the latest firmware from Xfinity and even done a refresh and reprogram with them



-Updated to the latest firmware

-Reset to factory settings (multiple times throughout)

-Turned off smart connect

-Turned QoS/Anti-BufferBloat to Always, Sometimes, Never

-IPV6 is OFF

-MIMO tried ON and OFF

-Tried Xfinity DNS, Cloudflare DNS, Google DNS

-Turned off 20/40mhz coexist or w/e its called

-Used Wifi analyzer and have swapped channels multiple times. 6 seems to be least congested in my area. And there is very little 5ghz at all.


I have just swapped the AC66RU back in. And unfortunately its dated processor can only handle speeds of around 450 Mbps over my wire, but I am going to test the Wifi with it to confirm its either the XR500 or a combo issue with the CM1000/XR500. If the AC66R works then I am just at a loss as to what to do? I feel like I have done everything but the Wifi simply doesn't work period.


View the full article

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...